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1 Glossary 

Term Definition 

Channel 
A port on the front panel of the ODiSI instrument. There is a 
maximum of 8 channels on an ODiSI. 

Configuration  

A set of Luna defined hardware and software parameters that 
change the measurement capabilities of the ODiSI instrument. 
Measurement parameters that change between configurations 
include (but are not limited to): measurement rate, maximum 
sensor length, and gage pitch. The ODiSI software 
automatically selects the fastest measurement rate based on 
the maximum sensor length detected and user-selected Gage 
Pitch. 

Gage 

Subset of a fiber sensor that is used to make a single strain or 
temperature measurement. A fiber sensor is divided into 
numerous gages which provide distributed measurements of 
strain or temperature along the fiber. 

Gage Pitch 
Length of fiber between the center of a single gage and the 
center of a neighboring gage.  

High-Definition 
(HD) Sensor 

A fiber sensor that provides a unique Rayleigh scatter signature 
that the ODiSI instrument can use to make distributed strain or 
temperature measurements. 

Measurement 
Rate 

This is the rate (in Hz) at which the ODiSI provides strain or 
temperature measurements. 

ODiSI 
Measurement 
Streaming 
Protocol (OMSP) 

JSON based protocol for the transfer of ODiSI strain or 
temperature data to another PC. 

Sensor 
Key/Reference 

Data set containing the unique Rayleigh scatter pattern of a 
single fiber sensor. This is compared to measurement scans to 
calculate strain or temperature. When a sensor is rekeyed, a 
new reference data set is captured. Once installed or 
generated, these files are stored in the Sensor Repository on 
the ODiSI controller. 

Standard Length 
Remote Module 

Supports sensor lengths from 1 m to 20 m. 

Extended Length 
Remote Module 

Supports sensor lengths from 1 m to 50 m. 

RLC 
Ruggedized LC connector. These connectors are used for the 
connections between the standoff cable and ODiSI instrument 
as well as between the standoff cable and the remote module.  
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Segment 
A collection of Gages defined by a Start Gage and an End 
Gage. 

Sensor (Strain) A fiber optic cable sensitive to strain. 

Sensor (CFG) 

Continuous Fiber Grating (CFG) fiber sensor sold by Luna. 
Rather than utilizing the intrinsic Rayleigh backscattering of the 
fiber, fiber Bragg gratings are written into the fiber and utilized 
by the ODiSI system to make distributed measurements. 

Sensor 
(Temperature) 

A fiber optic cable sensitive to temperature. 

Sensor     
(SC Temperature) 

A fiber optic cable sensitive to temperature with strain 
compensation. 

Sensor Length Length of the sensing region of the fiber optic sensor. 

Sensor 
Repository 

Directory on the ODiSI controller that contains sensor specific 
data such as reference files, Tares, and Gage and Segment 
definitions. Installing and uninstalling sensors adds or removes 
this sensor data. 

Standoff Cable 

Length of optical fiber placed between the ODiSI instrument 
and the remote module. This length does not count toward the 
system’s sensor length. The ODiSI instrument can be used with 
several different standoff cable lengths with RLC connectors on 
each end: 10 m, 50 m, 100 m, 150 m, and 200 m. The longer 
lengths can be achieved by connecting two shorter standoff 
cables together using a Luna provided connector. 

Strain 
Coefficients 

Polynomial coefficients used to accurately scale optical 
frequency measurements into strain. These coefficients can 
vary between sensors and are calibrated at the factory. 

Temperature 
Coefficients 

Polynomial coefficients used to accurately scale optical 
frequency measurements into temperature. These coefficients 
can vary between sensors and are calibrated at the factory. 

Test Data Binary file containing measurement data from an ODiSI. 

Time Stamp 
The time at which a raw (optical) data acquisition was collected 
by the ODiSI instrument. Time stamps are always with 
reference to UTC. 

Touch to Locate 
The process of sequentially identifying individual Gage 
locations using a hot or cold input. 

TSV File 
Tab separated value data file containing measurement data 
from an ODiSI. 
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2 Safety 

The advisory words Danger, Warning and Caution used in this manual identify the level of 

hazard that may be encountered by the user.  

• DANGER means if the danger is not avoided, it will cause death or serious injury.  

 • WARNING means if the warning is not heeded, it can cause death or serious injury.  

 • CAUTION means if the precaution is not taken, it may cause minor or moderate injury. 

 

 Warning 

The protection provided by the equipment may be impaired if the equipment is used in a 

manner not specified by the manufacturer, resulting in serious injury or death. 

The power cord is the main electrical disconnect for this equipment. If it is necessary to ensure 

no power to the unit, remove the power cord. 

The use of controls, adjustments, performance, or procedures other than those specified 

herein may result in hazardous laser radiation exposure and one or more safety protections 

may be impaired or rendered ineffective. 

 

 Attention 

La protection fournie par l'équipement peut être compromise si l'équipement est utilisé d'une 

manière non spécifiée par le fabricant, entraînant des blessures graves ou la mort. 

Le cordon d'alimentation est le principal disjoncteur électrique de cet équipement. S'il est 

nécessaire de ne pas mettre l'appareil hors tension, retirez le cordon d'alimentation. 

L'utilisation de commandes, d'ajustements, de performances ou de procédures autres que 

celles spécifiées ici peut entraîner une exposition dangereuse au rayonnement laser et une 

ou plusieurs protections de sécurité peuvent être altérées ou rendues inefficaces. 

 

3 System Overview 

Luna Innovations’ Optical Distributed Sensor Interrogator (ODiSI 6) is a strain and 

temperature measurement system designed to meet the needs of engineers and scientists 

who are performing material characterization, process control, structural testing, and service 

life monitoring of vehicles, components, power systems, and a variety of other applications.  

The ODiSI employs an optical frequency domain reflectometry (OFDR) technique to interpret 

the signal from fiber optic sensors to make strain and temperature measurements on a test 

article.  



 
  

ODiSI 6 

 
 

ODiSI 6 User’s Guide Page 8 

 

The ODiSI’s fiber optic sensors range from 1 m to 100 m in length for distributed strain 

measurements and 1 m to 5 m for temperature measurements. Optical fiber’s flexibility and 

small diameter (< 0.2 mm) lends itself to being located and routed through and inside parts 

and locations not typically accessible with foil gages and thermocouples.  

Because optical fibers undergo well defined local optical changes as a result of changes in 

strain and temperature, the ODiSI is able to interpret the reflected signal along a sensor into 

independent strain or temperature measurements throughout the length of the fiber at 

intervals as low as 0.65 mm. 

 

Figure 3-1 ODiSI sensor fiber. 

 ODiSI Instrument Specifications 

The ODiSI platform is available in several channel configurations. Channels are sampled 

serially at the maximum allowable data rate for the specific sensor length and number of active 

channels. Both temperature (not SC Temperature) and strain sensors can be used on different 

channels during the same test. A test with SC Temperature sensors cannot contain other 

sensor types. A test with Luna CFG sensors cannot contain other sensor types. 

The table below outlines the performance specifications for different configurations. Further 

details can be found in the product data sheet, which is available on the Luna website 

(www.lunainc.com). 

http://www.lunainc.com/
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This User’s Guide uses examples and graphics from a setup with multiple sensors. It is 

important to note, however, that whether the system is set up for one or multiple sensors, the 

hardware setup and the application interface remain consistent. 
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 Hardware and Physical Setup 

The ODiSI 6 system is shipped with the following key components: 

 
Optical Distributed Sensor Interrogator (ODiSI 6) 

 
Dedicated Instrument Controller 

 
Standoff Cable(s) 

 
Remote Module(s) 

 
Optical Fiber Bulkhead 

Cleaners 

 
Optical Fiber Connector 

Cleaner 

 
Flash drive with user guides 

and recovery software 

 
ODiSI Power Cord 

 
Laptop Power Adapter 

 
USB3 Type A to B cable 

 

 Assembly 

1. Remove all the components from the packaging and verify that the components are 

undamaged. 

2. Place the unit on a stable surface capable of supporting the entire weight of the unit.  

3. Confirm that airflow into and out of the vents at the side and rear of the unit is not 

obstructed. 
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4. Clean the duplex LC-APC connectors at the ends of the standoff cable using the 

provided Cletop connector cleaner (see Setup Guide for cleaning instructions). 

5. Connect one end of the standoff cable to one of the front panel ports on the ODiSI. 

6. Connect the other end of the standoff cable to the remote module. 

Note:  Repeat steps 5 and 6 for each remote module that came with the configuration.  

7. Unpack and set up the instrument controller (laptop) according to the manufacturer’s 

instructions.  

8. Connect the ODiSI 6 to the controller using the supplied USB 3.1 Gen I cable. 

9. Attach the power cords to the controller and ODiSI 6. 

10. Turn on the ODiSI 6 and the instrument controller (laptop). 

Note: The ODiSI 6 can be restarted without restarting the laptop. 

11. Log into the laptop using the following credentials: 

User Name:  odisi 

Password:  odisi 

12. Launch the ODiSI software by double clicking on the OD6 desktop icon. 
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4 Software Overview 

 

Figure 4-1: Main screen of the user software 

This chapter provides an overview of the functionalities available in the ODiSI 6 user software. 

Instructions for how to quickly set up a test and log data are found in the next chapter 

(Software Quick Start Guide). Following that is a detailed explanation of all the ODiSI 6 

software functionalities (Using the ODiSI 6 Software).  

The functionalities provided by the software relate to the following main actions: 

1. Configure operational parameters 

2. Install sensors 

3. View and evaluate sensor performance  

4. Set up the ODiSI for data logging 

5. Run a test 

6. View test data 

 Operational Parameters 

When the software is first launched, the software will go through an initialization process. 

Once completed, the main user interface will be displayed, showing the status of the system 

as well as each channel on the ODiSI. Other information on display in the main software 

interface include the measurement mode of the system, the gage pitch, the performance mode 

of the system, the associated per channel measurement rate, and the loaded test 

configuration as well as the sensor types connected on each channel.  
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 Manage the Sensor Repository 

The ODiSI is configured for use with Luna’s fiber optic strain and temperature sensors. Each 

sensor has a unique optical signature which is used to 

1. Characterize the sensor’s strain or temperature state, and 

2. Automatically identify the sensor (for most Luna fiber sensor types). 

This reference file is also called a sensor key and is contained in Luna-labeled flash drives 

shipped with each sensor. In order for an ODiSI to make measurements from a sensor, that 

sensor’s key needs to be installed onto the controller prior to use. Once installed, these files 

are stored in the Sensor Repository on the controller.  

Actions related to installing sensors and managing the Sensor Repository can be accessed 

from the “Tools → Manager Sensors” menu. These actions include installing sensors, 

renaming sensors, deactivating sensors, deleting deactivated sensors, and exporting sensors. 

For more information, see Manage the Sensor Repository. 

 View and Evaluate Sensor Status 

Once a sensor is identified and added to a particular Channel’s configuration, its performance 

can be viewed for evaluation by clicking the associated “View”    button. The 

subsequent interface provides a look at the strain or temperature profile along the sensor. 

Other actions that can be accessed from this interface include creating and selecting a Tare, 

defining individual gages and segments for data logging and streaming, as well as Rekeying 

the sensor. 

 Set Up the ODiSI for Data Logging 

Once satisfied with the sensor performance on each channel, the ODiSI can be set up for 

logging test data. Data logging rates, trigger settings, as well as data streaming settings are 

accessed through the Settings menu. The test naming is accessed through the “File → Set 

Test Data File Save Options” menu. 

 Run a Test 

Clicking on the “Arm”      button prepares the ODiSI for running a test. This 

will initially display the Sensor Plot screen. 
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Figure 4-2: Arming a test shows the Sensor Plot screen 

When a test is running, the Sensor Plot and Gage Plot visualizations are available. The Sensor 

Plot allows viewing of the strain or temperature along all sensors, and the “Gage Plot” allows 

viewing strain or temperature measurements from select individual gage locations along all 

sensors, over time. 

 View Test Data 

Test data is logged in binary files that are stored in the Test Data folder on the controller. Test 

data can be played back through the “Play Back Test Data” function and can be converted to 

human readable tab delimited .tsv files through the “Generate Test Data TSV Files” function. 

These TSV files can be opened in external programs such as Excel or Matlab for further data 

analysis. 

5 Software Quick Start Guide 

This chapter quickly goes through the process of setting up a single channel ODiSI test with 

test data file logging enabled. The test data file is then opened for playback afterwards. 

 Operational Parameters 

1. Launch the software. 

a. Double click the “OD6” desktop shortcut. The application window will display 

an “Initializing” status. Once this reaches 100%, the main software interface is 

active. 

2. Check that the “Status” is updated to “Ready”. 
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Figure 5-1: Main screen of the user software after successful initialization, status field shows “Ready” 

 Installing a Sensor 

1. Install a sensor. 

a. Plug the flash drive containing the sensor key into a USB port of the ODiSI 

controller. 

b. Open the menu by clicking the      button in the top-left corner. 

c. Click on “Tools → Manager Sensors” to bring up the Manage Sensor Dialog 

as show in the figure. 
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Figure 5-2: Manage Sensors menu item 

d. Click on the “Install Sensor”      button. 

e. Navigate to where the sensor key is located, select it and click the “Open” 

button. 

f. Click “Close” to exit the “Manager Sensors” window. 

 

Figure 5-3: Manager Sensors window with Install Sensor dialog 

 View and Evaluate Sensor Status 

1. Add the identified sensor to the channel configuration. Do this by clicking the      

button beside the identified sensor. 
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2. For the ODiSI 6100 Series, measurements can be taken with the 1.3 mm Gage 

Pitch. To change the gage pitch, select the “Settings → General” menu item to open 

the “General Settings” dialog and then choose “1.3 mm” from the Gage Pitch drop-

down. For the ODiSI 6000 Series, choose “5.2 mm” from the Gage Pitch drop-down. 

  

Figure 5-4: General Settings menu item Figure 5-5: General Settings dialog 

3. Click on the “View”      button. 

 

Figure 5-6: Added identified sensor to test configuration on channel 1, View button enabled 

4. Click the “Fit Plot”      button to auto-scale the measurement vs. length plot. 
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Figure 5-7: View strain along the length of the sensor 

5. Confirm that the measurement length matches the expected sensor length. 

6. Zero out residual strains along the sensor. Click on the “Save Tare”  

button and give the Tare a name. 

7. Define additional Gages and Segments using Touch to Locate. 

a. Click on the “Start Touch to Locate”      button. 

b. Apply a localized hot or cold touch to the sensor at the gage location of interest. 

c. A red vertical cursor will appear at the touch location. 

d. Click the “Add Gage” button. 

e. Repeat the above steps for other gages of interest. 



 
  

ODiSI 6 

 
 

ODiSI 6 User’s Guide Page 19 

 

 

Figure 5-8: Define Gages and Segments 

 Set Up the ODiSI for Data Logging 

1. Set up test data file saving. 

a. Ensure “Save Test” is checked. 

 

Figure 5-9: Check the "Save Test" checkbox 

b. Click on “File → Set Test Data File Save Options” to specify the test name, 

notes and destination folder. 

 

Figure 5-10: Menu item for test data file saving options 
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c. Enter the “Test Name”, “Notes” and click the “Browse” button to select the 

destination folder. 

 

Figure 5-11: Test data file saving properties 

2. Adjust measurement rate 

a. Click the “File → Filter and Downsample” menu item. 

 

Figure 5-12: Filter and Downsample menu item 

b. Click the check box next to “Temporal Downsampling Factor” and specify the 

“Temporal Downsampling Factor” to down-sample from the full data rate. 

c. Click “OK” to save these settings and close the dialog. 
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Figure 5-13: Set a temporal downsampling factor 

 Run a Test 

1. Lock the current test configuration and prepeare the ODiSI to acquire data by clicking 

the “Arm”      button. The Sensor Plot screen will be displayed. 

2. Click the “Start”      button to start logging data. You can view the 

measurement versus length in the “Sensor Plot” screen. 
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Figure 5-14: Sensor Plot screen updates with live data after clicking Start 

3. View sensor single plot screen by selecting the “Single Plot” from the associated 

drop-down menu. 

 

Figure 5-15: Plot type selection 

4. The sensor single plot screen will be displayed. 
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Figure 5-16: View Single Plot 

5. View individual gages versus time by selecting the “Gage Plot” screen in the drop-

down menu. 

 

Figure 5-17: Select Gage Plot 

6. The Gage Plot will be displayed. Enable plotting for individual gages on the “Gage 

Plot” by checking the corresponding checkboxes in the list. The color for a particular 

gage line can be changed by clicking the corresponding color square and selecting 

the desired color in the dialog that appears. 
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Figure 5-18: Enable plotting for some gages 

 

 

Figure 5-19: Live plot for the enabled gages over time 

7. Click the “Stop”      button once the test is complete. 

 View Test Data 

1. Play back test data. 

a. Click the “Tools → Playback Test Data” menu to display the ODiSI Player 
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Figure 5-20: Playback Test Data menu item 

b. Select the Test Data file to view. 

c. Play back or scroll through the test data using the navigation buttons. 

 

Figure 5-21: Playing back the test data 

2. Convert binary test data into ASCII format. 

a. Click the “Tools → Generate Test Data TSV Files” menu item to open the 

“Generate Test Data TSV Files Dialog”. 
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Figure 5-22: Generate Test Data TSV Files menu option 

b. Select the desired Test Data file(s). Add them individually or in a batch. Then 

click “Save”. 

 

Figure 5-23: Select Test Data file(s) for conversion to TSV file(s) 

c. Select the folder to which TSV files will be written. Then click “Save”. 

d. Once file conversion is complete, the status will be indicated in a pop-up 

window. 
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Figure 5-24: Completion status for generating TSV file(s) 
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6 Using the ODiSI 6 Software 

This section describes in detail all the functionality of the ODiSI 6 Software. 

 Operational Parameters 

When first launched, the user interface displays the system Status and Sensor Properties. 

Among other things, the “Sensor Properties” screen displays the current state of the system 

including information on the configuration of each channel and detailed information for each 

sensor. 

 

Figure 6-1: Main Sensor Properties screen 

 Instrument Status 

The system Status is indicated in the top left corner. The status displayed is one of the 

following: 

• Initializing: The software has just been launched and is connecting to and configuring 

the hardware. 

• Ready: The software is ready to start making measurements using the fiber sensors. 

• Running Test: The system is currently making measurements for a test. 

 Operational Parameters 

 Measurement Mode 

The ODiSI 6 provides three different Measurement Mode options to choose from. The 

Measurement Mode setting is accessed by clicking on the “Settings → General” menu item. 
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HD Standard Length: High Definition Standard Length remote modules are used with 

sensors that are less than 20 m long, or combinations of sensor and patch cord that are less 

than a total of 20 m long. 

HD Extended Length: High Definition Extended Length remote modules can be used with 

sensors that are 1 m and up to 100 m long or with a patch cord (maximum length 19 m) where 

the combinations of sensor and patch cord are less than a total of 100 m long. 

Note: The system can only operate in either standard or extended length mode. 

Standard length and extended length remote modules cannot be used simultaneously 

during the same test configuration.  

Luna CFG Sensing: Continuous Fiber Grating (CFG) sensors sold by Luna. Rather than 

utilizing the intrinsic Rayleigh backscattering of the fiber, fiber Bragg gratings are written into 

the fiber and utilized by the ODiSI system to make distributed measurements. This mode 

functionality provides a fixed 6 mm gage pitch and requires slightly different operation than 

other ODiSI 6000 sensors which requires that CFG sensors cannot be used with other 

sensors. 

 Luna CFG Sensing 

Select “Settings → General” as described above and select the “Luna CFG Sensing” option 

from the “Measurement Mode” drop-down. 

 

Note that the Gage Pitch selected is 6 mm and it cannot be changed.  Upon clicking “Ok”, the 

CFG Sensor Properties Screen is displayed. 
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Figure 6-2: Sensor Properties screen when using Luna CFG Sensing 

The user must manually select the sensor that is connected to a given channel on the ODiSI. 

It is recommended to name the installed CFG sensors so that they are more recognizable to 

the user. See the Manage the Sensor Repository section for more information on installing 

and renaming sensors. Once the sensor is successfully selected, the status will show a green 

“Ready” 
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Figure 6-3: Luna CFG sensor is ready 

All other operations such as viewing the sensor, defining gages and segments, and running a 

test are the same as other sensor types. Note that when viewing a sensor plot, the 0-meter x-

axis position for these CFG sensors corresponds to the first grating for which results are 

returned; the 0-meter x-axis position is not the fiber sensor connector. 

 Gage Pitch 

The “Gage Pitch” selection specifies the distance between the center of one gage and its 

nearest neighbor. For the ODiSI 6100 Series, there are five Gage Pitch selections: 1.04 cm 

(only for SC Temperature sensors), 5.2 mm, 2.6 mm, 1.3 mm (not available for sensors longer 

than 50 m), and 0.65 mm (not available for sensors longer than 20 m long). For the ODiSI 

6000 Series, there are two Gage Pitch selections: 1.04 cm (only for SC Temperature sensors) 

and 5.2 mm. Select the Gage Pitch most suitable for the test by clicking the “Settings → 

General” menu item. 

6.1.2.3.1 Advantages of a Smaller Gage Pitch 

A smaller gage pitch setting can be used to see smaller features in the strain data that would 

normally be hidden within a single gage when viewed with a larger pitch. Additionally, a 

smaller gage pitch setting can improve the ability of the system to make measurements in 

areas of high strain gradients (large strain change over a small distance).   

6.1.2.3.2 Gage Pitch and Measurement Rate 

A given gage pitch setting presents a tradeoff between measurement rate and the 

measurement density. Choosing a larger gage pitch automatically increases the 

measurement rate. 
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6.1.2.3.3 Gage Pitch, Sensor Length, and Measurement Rate 

The sensor length also has an impact on the measurement rate of the system. Generally, as 

the sensor length increases, the measurement rate for a given gage pitch decreases. For this 

reason, it is often preferable to use multiple shorter sensors rather than a single longer sensor. 

 Performance Mode 

The Performance Mode selection determines the processing capability of the instrument. 

Select the Performance Mode most suitable for the test by clicking the “Settings → General” 

menu item. For the ODiSI 6000 Series, this selection is not available; the Full Optimization 

mode is always used. 

Maximum Rate: The ODiSI outputs measurements at the fastest rate possible, given the 

Measurement Mode, sensor length, and Gage Pitch selections. 

Full Optimization: The ODiSI optimizes measurements to provide the highest quality results 

at half the maximum measurement rate, given the Measurement Mode, sensor length, and 

Gage Pitch selections. 

 Measurement Rate Per Channel 

Displays the measurement rate that will be achieved on each channel. This rate depends on 

the sensor length, Measurement Mode, Gage Pitch, Performance Mode, and number of 

channels. 

 Loaded Test Configuration 

Displays the name of the configuration file that was loaded through the “Configuration → Load 

Configuration” menu or displays the default configuration that is loaded on start up. If no 

configuration is loaded, then “NONE LOADED” is displayed. If a configuration is loaded and 

the configuration is changed, the configuration name will be displayed in red. 

 Channel Status 

The status of each channel is indicated in the main body of the control software. 

View: The “View” button for each channel becomes active once a channel has been correctly 

configured. Click to display a preview of the strain or temperature along a single sensor. 

Channel: Lists the number of channels the instrument is configured for 

Sensor: Lists the name of the sensor added to the configuration of each channel. Click on the  

 button to remove the sensor from the configuration of the specific channel. 

Status: Indicates the status of each channel. Below are various text strings that could be listed 

for each channel, with multiples possible, separated by dashes: 

• “Identifying...” 

• “Remote module type does not match Measurement Mode setting” 

• “No remote module connected” 

• “No sensor connected” 

• “Identified” 
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• “Sensor connected via # m patch cord” 

• “Sensor length/Remote module type mismatch” 

• “Total length/Remote module type mismatch” 

• “Total length requires Extended Length remote module” 

• “The 0.65 mm gage pitch cannot be used with sensors longer than 20 m” 

• “Sensors longer than 50 m must use the 2.6 mm or 5.2 mm gage pitch” 

Status messages in green indicate that the channel setup is part of the active test 

configuration. 

Status messages in black indicate that the channel setup is not part of the active test 

configuration. 

Status messages in red indicate that the channel is part of the active test configuration, but 

there is a problem that needs to be resolved before making measurements. 

Information button : Displays detailed information for the specific channel, comparing 

the expected configuration parameters to actual detected parameters. These details include: 

• The Channel of the ODiSI for which the information is being displayed. 

• The Status of that channel. 

• The user-defined Sensor Name. 

• The Sensor Serial Number issued when the sensor key was created. 

• The Sensor Type (Strain, Temperature, or SC Temperature). 

• The Sensor Length (in meters). 

• The Patch Cord Length of any detected patch cord on that channel. 

• The Key being used for the identified sensor (if a sensor has been rekeyed). 

• The Tare being used for the identified sensor. 

• The type of Remote Module being used on that channel, either Standard or Extended. 
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Figure 6-4: Clicking the information button gives details for a particular channel 

Clicking the “Advanced” button provides additional optical information about the connected 

sensor. 

 

Figure 6-5: Clicking the Advanced button shows additional optical information 

Remote Module: Indicates the type of remote module detected on each channel, either no 

remote module detected (--), Standard, or Extended. 

Sensor Info: Indicates what sensor has been identified on each channel. Click on the      

button to add the identified sensor to the configuration of the specific channel. 
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 Example: Operational Parameters 

 

Figure 6-6: Sensor Properties screen with three connected sensors 

In the above figure: 

• Status: “Ready”, meaning the hardware has been set up and is ready to identify 

sensors and make measurements. 

• Measurement Mode: HD Standard Length selected 

• Gage Pitch: 2.6 mm Gage Pitch selected 

• Performance Mode: Full Optimization selected 

• Measurement rate per channel: Based on the sensor lengths, number of channels, 

Gage Pitch, and Performance Mode, the resultant measurement rate per channel is 

25.00 Hz 

• Channel 1: A 10.27 m strain sensor has been identified and added to the configuration 

of Channel 1 and this channel is ready for making measurements. The Status 

message is in green and the “View” button is active. 

• Channel 2: A sensor has been identified but not added to the configuration of Channel 

2. It is a 20.19 m strain sensor on an Extended Length remote module. This does not 

match the Measurement Mode selection of Standard Length. This description is 

displayed in the Status of Channel 2 in black. 

• Channel 3: A 5.24 m strain sensor has been identified as being connected to the 

remote module through a 3.18 m patch cord. This does not match the original 
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configuration on Channel 3, which is of the same sensor (FSHD2017LUNAS60095) 

connected without a patch cord. The status message is in red. 

Note: The system can only operate in either standard or extended length mode. 

Standard length and extended length remote modules cannot be used simultaneously 

during the same test. 

 Manage Sensors 

The detection of the correct sensor on each channel depends on the presence of the sensor 

key within the instrument’s Sensor Repository. Click on the “Tools → Manage Sensors” 

menu item to access the sensor management window. 

 

Figure 6-7: Manage Sensors menu item 

 

The sensor management window provides the ability to install new sensor keys, delete 

unused sensor keys, and rename installed sensor keys. 

Serial Number: Lists the serial numbers of all sensor keys installed on the controller. 

Name: Lists the user-assigned names associated with all sensor keys installed on the 

controller.  

Rename: Click to change the name associated with this sensor. 

Deactivate: Click to deactivate the sensor key from the system. Deactivating sensor keys 

removes them from the list of keys used for sensor identification thereby also making them 

unavailable for making strain and temperature measurements. Deactivating sensor keys can 

decrease the time it takes to identify connected sensors. 

Reactivate: This will reactivate the sensor key. Reactivating sensor keys makes the keys a 

part of the identification process again thereby also making this sensor keys available for 

making strain and temperature measurements. 

Delete Deactivated Sensor: Click the      to delete a deactivated sensor. 

Note: This will permanently remove the sensor and any associated data from the system’s 

memory, including Tares, Rekeys, and Gages and Segments. 
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Rekey: Select the specific Rekey to use with the listed sensor. 

Install Sensor: Click to install a sensor from a Luna-provided flash drive containing the sensor 

key. Install sensor will also install a package file that was exported via Export Sensor. The 

package file contains Tares, Rekeys, and Gages and Segments associated with this sensor.. 

Delete Deactivated Sensors: Click to delete all deactivated sensors. 

Note: This will permanently remove the sensor and any associated data from the system’s 

memory, including Tares, Rekeys, and Gages and Segments. 

Export Sensors: Click to export the entire installed sensor folder including Tares, Rekeys, 

and Gages and Segments to a flash drive or CD drive. 

 

Figure 6-8: Manage Sensors dialog 

 View and Evaluate Sensor Status 

Once a sensor is Identified and added to a particular Channel’s configuration, its performance 

can be viewed for evaluation, and the sensor can be set up for eventual testing. Click on the 

“View” button for a given active channel. 

Channel: 1: Drop-down menu that allows the user to preview sensors on different channels 

or go back to the main software interface. 

Information button : Displays detailed information for the channel. Refer to the section 

on Channel Status for more information. 
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Figure 6-9: View measurements down the entire sensor length for a specific channel 

 Sensor Tare 

A sensor can be zero-ed out before the start of a test. This re-zero-ing is called a Tare. Tares 

are specific to Gage Pitches.   

Save Tare: Click this button to zero out a sensor. 

Tare dropdown menu: Select from multiple saved Tares. 

Delete Tare: Click to delete the selected Tare. 

 Sensor Key 

Any sensor whose key has been installed in the software and is able to be identified can be 

rekeyed. Reasons for needing to Rekey include re-splicing a broken sensor, taking the sensor 

to higher strain ranges, re-centering the strain and temperature range around a new point, 

and permanently removing strain gradients induced in the sensor. For example, if a strain 

sensor is installed and is loaded to 10,000 µε prior to a test, the system will only be able to 

measure an additional 5,000 µε. If the sensor is rekeyed, the sensor can then be used over a 

larger strain range. It is important to ensure that the sensor and system are static and in a 

quiet environment when Rekeying a sensor. 

Rekey: Click this button to capture a new Rayleigh backscatter reference for this sensor. 

Key dropdown menu: Select from multiple sensor keys to be used for the sensor. 

Delete Key: Click to delete the selected Rekeyed trace. 
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 Define Gages 

The Gage and Segment tables may be hidden to expand the plot view by clicking the down 

arrow     located at the right side of the screen above the Segment Table. To view the 

Gage and Segment tables after hiding them, click the up arrow      located at the bottom 

of the screen. 

 Table of Gages 

Gages are a list of individual measurement points from individual sensors. These points can 

be used to define the start and end locations of Segments or can be viewed individually using 

the Gage Plot display. Gages can be created in three ways. 

1. Touch to Locate 

The Touch to Locate feature automatically detects the presence of a hot or cold touch to the 

fiber sensor. This is used to aid in the selection of Gages at specific locations along the sensor.  

To use the Touch to Locate feature, click the “Start Touch to Locate”      button 

and then touch the fiber with a small hot or cold object. The software will detect this 

temperature change and will automatically move the red vertical cursor to the location of the 

hot or cold touch and update the Location field (see the below figure for an example). Click 

the “Add Gage” button to add this new Gage to the Gage list. 

2. Cursor 

To display the cursor, click once on the plot. To place the cursor at a specific location, double 

click on the plot. The cursor on the graph can also be moved manually by placing the mouse 

pointer close to the red cursor and then dragging the cursor to the desired location. Once the 

cursor has been moved to the desired location, click the “Add Gage” button to add this new 

Gage to the Gage list. 

3. Manual entry 

A Gage and its location can be manually entered into the Location field. Changes to the 

location field will automatically be reflected in the cursor location. Click the “Add Gage” button 

to create a Gage and change the Gage Name and Location. 

For any of the above methods, if the Name field is left blank or is a duplicate of an existing 

gage, the software will assign the new Gage a default name (Gage 1, Gage 2, etc.). These 

names can be edited by clicking on them in the Gage table. 

A Gage can be deleted by selecting the desired Gage and then clicking on the trash can      

button next to the gage location. 

All sensors include default Start and End Gages, as well as a default All Gages Segment that 

spans from the default Start Gage to the default End Gage. 

 Table of Segments 

Segments are continuous sections of measurement data that start and end at previously 

defined gages. To create a Segment, choose the start and end Gages from the dropdown 
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menus. As with the Gages, the Segment name can be edited within the Segment table by 

clicking on it. 

Segments can also be deleted by selecting the desired Segment in the Segment table and 

then clicking the trash can icon in the upper right corner of the Segment table. 

 

Figure 6-10: Gages and Segments 

 Plot Navigation 

The ODiSI 6 software uses plots and graphs to display measurement data. The X and Y axes 

of these plots can be rescaled to better view features in the measurement data.  

 Unconstrained Zoom In/Out 

To zoom in on data in both X and Y, move the mouse cursor to the region of interest and use 

the scroll wheel to zoom in or out. If using a laptop touch pad, use two fingers to swipe up or 

down to change the zoom level. 

 X/Y-Axis Constrained Zoom 

To zoom in on only one axis, click on the desired axis (this highlights it in blue) and use the 

mouse wheel or two-finger scroll to zoom in or out. 

 Fit Plot 

The Fit Plot      button automatically zooms in or out to fit all the data present in the plot. 

Note: No data is being saved or streamed when viewing and evaluating the sensors. 
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 Set Up the ODiSI for Data Logging 

 File Saving 

Measurement data is stored to the instrument controller for playback or analysis when “Save 

Test” is checked and the system status shows “Running Test”. 

 

Figure 6-11: Test data file saving is enabled 

Test files can be labeled with a Test Name and contain Test Notes. These names and notes 

are used to sort and browse for test data files along with time stamps. 

Save Test: Check to log data 

Click on the “File → Set Test Data File Save Options” menu item to specify the test name, 

notes, and destination folder. 

 

Figure 6-12: Menu item for setting specific test data file saving options 

Test Name: Enter a name for the test. 

Notes: Enter notes associated with the test. 

Directory: Click “Browse” to change the Test Data logging directory. 

 

Figure 6-13: Specify test data tile saving options 

Test data files are saved to the local drive under the OD6_Test Data Directory. Clicking the 

“Browse”      button will display the Test Data File Dialog. 
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Figure 6-14: Test data file dialog accessed via the Browse button 

To save a file to an external drive, click the external drive      button which will navigate to 

an external drive connected to the controller through USB. 

 

Figure 6-15: Navigate to an external drive to save test data 
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To navigate back to ODiSI Test Home, click the home      button. 

 Managing Test Data Files 

Test Data Files may be deleted or moved from one directory to another. 

To manage test data files: 

1. Click “File → Manage Test Data” 

 

Figure 6-16: Manage Test Data menu item 

2. To move test data files, select one or more test data files and/or directories in the left pane 

of the window. To select more than one file or directory, hold the ctrl or shift key. Click the 

“Move”      button to move the selected files and/or directories. 

 

Figure 6-17: Select files and/or directories to move 

3. To delete test data files or directories, select one or more test data files and/or directories 

and click the delete      button. 



 
  

ODiSI 6 

 
 

ODiSI 6 User’s Guide Page 44 

 

 Copy Test Data 

To copy test data files to/from an external drive, click “File → Copy Test Data”. 

 

Figure 6-18: Copy Test Data menu item 

1. To copy files to a USB/CDROM drive: 

a. Select the drive type      on the left file browser. 

b. If using a USB drive, select the desired directory on the left file browser. 

c. Select the files and/or directories to copy on the right file browser. 

d. Click the “Receive”     button. 

 

Figure 6-19: Copy test data to USB/CDROM 

2. To copy files from a USB/CDROM drive: 

a. Select the drive type      on the left file browser. 
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b. Select the files and/or directories on the left file browser 

c. Navigate to the destination directory on right file browser 

d. Click the “Send”      button. 

 

Figure 6-20: Copy test data from USB/CDROM 

 Copying Test Data TSV Files. 

To copy test data .tsv files to/from an external drive, click “File → Copy Test Data TSV Files” 

 

Figure 6-21: Copy Test Data TSV Files menu item 

1. To copy files to a USB/CDROM drive: 

a. Select the drive type      on the left file browser. 

b. If using a USB drive, select the desired directory on the left file browser. 

c. Select the files and/or directories to copy on the right file browser. 
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d. Click the “Receive”     button. 

 

Figure 6-22: Copy .tsv files to USB/CDROM 

2. To copy files from a USB/CDROM drive: 

a. Select the drive type      on the left file browser. 

b. Select the files and/or directories on the left file browser 

c. Navigate to the directory on right file browser 

d. Click the “Send”      button. 
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Figure 6-23: Copy .tsv files from USB/CDROM 

 Settings Menu 

 General 

Select the General Settings menu by clicking “Settings → General”. 

 

Figure 6-24: General settings menu item 

Measurement Mode: Select the Measurement Mode that matches the sensor lengths and 

remote modules connected to each channel. 

Gage Pitch: The gage pitch selection specifies the distance between the center of one gage 

and its nearest neighbor. 
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Performance Mode: The Performance Mode selection determines the processing capability 

of the instrument. Selecting “Maximum Rate” provides the fastest measurement rate given the 

Measurement Mode (i.e. remote module type), sensor lengths, and Gage Pitch selection. 

Selecting “Full Optimization” provides the highest quality results at half the maximum 

measurement rate given the Measurement Mode (i.e. remote module type), sensor lengths, 

and Gage Pitch selection. 

X-Axis Units: Select length units from the drop-down menu. 

Use Patch Cord: Check if using a patch cord (fiber jumper) between the remote module and 

the sensor. Required to properly identify sensors when using patch cords. 

 

Figure 6-25: General settings dialog 

 Channel Settings 

Select the Channel Settings menu by clicking “Settings → Channel Settings”. 

 

Figure 6-26: Channel Settings menu item 

Standoff Length: Select standoff cable length per channel from the drop-down menus (10 m, 

50 m, 100 m, 150 m, or 200 m). The longer lengths can be achieved by connecting two shorter 

standoff cables together using a Luna provided connector. 
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Figure 6-27: Channel Settings dialog 

 Streaming Properties 

Select the Streaming Properties Settings menu by clicking “Settings → Streaming Properties”. 

 

Figure 6-28: Streaming Properties menu item 

ODiSI measurement data can be streamed to a separate remote PC for analysis and/or 

storage. The ODiSI software uses a Luna defined JSON-formatted TCP/IP protocol called 

ODiSI Measurement Streaming Protocol (OMSP) for data transfer. Details on this protocol 

can be found in section ODiSI Measurement Streaming Protocol (OMSP). 

Luna also provides the ODiSI Remote application which gives the ability to Arm, Start, Stop, 

and Disarm the ODiSI controller software from a remote PC as well as receive and display 

live measurements from the ODiSI control software in real-time. The ODiSI Remote software 

is covered in more detail in a later section. 

Controller Host Name: Displays the Controller’s Host Name. 

Controller IP Address: Displays the Controller’s IP Address. The controller needs to be 

connected to a network prior to the ODiSI software being launched in order for the IP Address 

to be detected and populated. 

OMSP Enabled: Check to stream measurement data. 
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When a test is started, the specified port is opened and the ODiSI software begins listening 

for a client connection. The client program can then initiate a TCP connection to the OMSP 

server on the specified port number. As soon as a connection is established, the ODiSI begins 

sending messages to the client. If the ODiSI loses the connection with the client, it resumes 

listening for a new client connection.  

Once a new connection is established, the ODiSI resumes sending data, but does not send 

measurement data that was missed during the time the connection was interrupted.  

The application data is one way. That is, the ODiSI sends data to the client but does not look 

for any responses.  

When a connection is made, the Status changes to “Client connected”. The Test Name and 

Notes are included as Metadata to the client. 

Remote Enabled: Check to enable remote control of the ODiSI control software. 

The Remote Control allows the user to connect to the ODiSI controller using a TCP/IP 

connection and send Arm, Start, Stop, and Disarm commands to the instrument to control the 

starting and stopping of measurements. See the section on ODiSI Remote Operation for 

more information about the ODiSI Remote application and how to connect to an ODiSI 

controller using the ODiSI Remote. 

Note on Measurement Streaming and Saving: There is an important distinction between 

saved measurements and streamed measurements. Saved measurements are stored on the 

instrument controller and are accessible for file playback. Streamed measurements are sent 

to a third-party PC and no record of them is maintained by the instrument controller. You can 

enable and utilize both of these features simultaneously. 

 

Figure 6-29: Streaming Properties dialog 

 



 
  

ODiSI 6 

 
 

ODiSI 6 User’s Guide Page 51 

 

 Triggers 

Select the Trigger Settings menu by clicking “Settings → Triggers”. 

 

Figure 6-30: Triggers settings menu item 

The “Start” button controls the software trigger to start logging data. The Stop button controls 

the software trigger to stop logging data. 

Triggering Enabled: Check to control the starting and stopping of data logging using a 

repeating pattern or through external electrical triggers. 

BNC port number 2 on the back of the instrument controls the hardware trigger to start logging 

data. BNC port number 3 controls the hardware trigger to stop logging data. Both are sensitive 

to a 0-5V TTL signal and trigger on the rising edge. For convenience, BNC port number 1 

provides a synchronization output that is active when the ODiSI instrument is actively 

acquiring measurement data. 

Start: Time Interval Select the time interval between subsequent automatic Starts. 

Stop: Measurement Count This is the number of scans taken each time a start trigger signal 

is received. 
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Figure 6-31: Triggers settings dialog 

 Strain Sensor 

Select the Strain Settings menu by clicking “Settings → Strain”. 

 

Figure 6-32: Strain settings menu item 

Y-Axis Units: Displays the Y-Axis Units for Strain. 

 

Figure 6-33: Strain settings dialog 

 Temperature Sensor 

Select the Temperature Settings menu by clicking “Settings → Temperature”. 
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Figure 6-34: Temperature settings menu item 

Y-Axis Units: Select temperature units from the drop-down menu (°C, °F, K) 

Temperature Offset: When used together with a Tare for the temperature sensor, the 

temperature offset effectively converts the temperature change measurements into absolute 

temperature. 

 

Figure 6-35: Temperature settings dialog 

 Filter and Downsample 

Select the Filter and Downsample Settings menu by clicking “Settings → Filter and 

Downsample”. 



 
  

ODiSI 6 

 
 

ODiSI 6 User’s Guide Page 54 

 

 

Figure 6-36: Filter and Downsample menu item 

Spatial Moving Average Size: Specifies the size of the spatial moving average filter window 

to apply to the calculated strain/temperature results. 

Spatial Downsampling Factor: Specifies the number of gage results to throw away spatially, 

thereby changing the “effective gage pitch.” For example, providing a value of 3 here means 

that for every 3 neighboring gages only 1 of those gage results will be kept. 

Effective Gage Pitch: The gage pitch when taking into account any specified spatial down 

sampling. This represents the nominal spacing between reported gage results. 

Temporal Moving Average Size: Specifies the size of the time moving average filter window 

to apply to the calculated strain/temperature results. 

Temporal Downsampling Factor: Specifies the reduction factor in time of the reported 

strain/temperature results. 

Measurement Rate Per Channel: Measurement rate that will be achieved on each channel. 

This rate depends on the sensor length, Measurement Mode, Gage Pitch, Performance Mode, 

number of channels, and Temporal Downsampling Factor. 

 

Figure 6-37: Filter and Downsample settings dialog 
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 DAC Settings 

Select the DAC Settings menu by clicking “Settings → DAC Settings”. 

 

Figure 6-38: DAC Settings menu item 

The DAC Settings provides an interface for enabling and configuring a connected USB-3106 

Analog Output Module. 

Enable DAC: Enable/Disable output to the DAC 

Output Range: Select the desired output range (-10V to +10V, 0V to +10V, 0mA to 20mA). 

Scale: Output scale based on the selected output range 

DAC Channel: Corresponds to the 16 channels on the USB-3106.  

Channel: Sensor: Select the desired channel: sensor that is currently in the test configuration. 

Gage: Select the gage associated with the selected sensor. During a test run, the 

strain/temperature value of the selected gage will be scaled to the appropriate output value 

and driven out on the associated DAC channel. 
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Figure 6-39: DAC settings dialog 

 Run a Test 

Once the active sensors have been selected for a test, the system can be initialized for data 

logging by clicking the “Arm” button. The system will configure itself based on all the current 

settings, and once the instrument is ready the “Start” button will become active. 

Arm / Disarm: Click “Arm” to initialize the system for data logging. Click “Disarm” to exit data 

logging mode. 

Start / Stop: Click the “Start” button to display, save, and stream measurement data 

immediately. Click the “Stop” button to end these processes. 

In order to change any of the various test configuration items or system settings, the system 

must first be Stopped and then Disarmed. 

 Sensor Plot 

The Sensor Plot screen displays measurements along sensor length once a test has Started. 

The screen displays data for the sensors that are included in the active configuration as shown 

in the Sensor Properties screen. Sensors that are no longer part of the current test 
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configuration but were used prior, are displayed as the last measurement trace on a gray 

background. 

Use the drop-down menu to toggle between viewing each individual sensor (Multiple Plots) or 

viewing all sensors stacked on a single plot (Single Plot). The Single Plot view displays the 

strain axis on the left and the temperature axis on the right. 

 

Figure 6-40: Sensor Plot screen 

 Gage Plot 

The Gage Plot screen displays measurements from individual Gages as a function of time 

once a test has Started. Active sensors are listed on the left. Each sensor’s tree menu contains 

branches for all Gages and Segments that have been created. 

Check the associated checkbox for a given Gage to have the line graph for that Gage appear 

on the Gage Plot. 

Click the color square to customize the color associated with a Gage. The color selection will 

be saved and remain the same for subsequent tests. 
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Figure 6-41: Gage Plot screen 

 View Test Data 

 Play Back Test Data 

The test data files collected using the ODiSI software can be replayed from within the same 

software. When in Play Back mode, the measurement data can be viewed with the same plot 

visualizations as the live data. Furthermore, measurement data can be still be streamed using 

OMSP when in Play Back mode. Note that the sensor properties and the test file saving 

actions are no longer available in Play Back mode. 

Browse for a test data file from the menu bar using “Tools → Play Back Test Data”. Navigate 

to the test file and click Open. 
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Figure 6-42: Play Back test data file open dialog 

Click the external drive     button to navigate to a connected external drive. 

If a play back file has associated clip files, it will have a small right arrow next to the file name 

(for example, ). Clip files are previously defined smaller sections of a larger 

test data file. Clicking the right arrow will display the associated clip files which can be read 

into the player. The icon     denotes a clip file. 

 

Figure 6-43: Example list of test data files 

 



 
  

ODiSI 6 

 
 

ODiSI 6 User’s Guide Page 60 

 

 

Figure 6-44: Play Back test data screen 

Test Name: Displays the Test Name associated with the selected test data file. 

Notes: Displays the Notes associated with the selected test data file. 

Play Back Controls: There are various playback control buttons described below. 

Reset button  Reset the file Play Back to the beginning of the test. 

Rewind button / Fast Rewind  Plays the measurements backward. Each successive 

click will cause the rewind speed to double until a maximum speed is reached.  

Play button Starts file play back. 

Pause button:  Play button converts to pause button while data is being played. 

Clicking the pause button will stop the file play back. 

Fast Forward:  Plays the measurements at 2x speed. Each successive click will 

cause the fast forward speed to double until a maximum speed. 

Backward and forward buttons:  and   Step through the test file one 

measurement at a time. 

Slider: Drag the blue slider across the top of the Sensor Plot to scroll through the data. 



 
  

ODiSI 6 

 
 

ODiSI 6 User’s Guide Page 61 

 

 

Figure 6-45: Scroll bar slider for test data file playback 

Time values: The start time is displayed on the upper left, above the slider. The end time is 

displayed on the upper right, above the slider. The current time value as depicted by the slider 

is centered above the slider. 

Index: The index is the current scan position of the play back file. The start index is always 1 

and is displayed on the lower left, below the slider. The end index is displayed on the lower 

right, below the slider. The current index value as depicted by the slider is centered below the 

slider. 

Create Clip:   Creating a clip allows for playing back a smaller section of the 

test data file. Clicking this will display clip controls. 

 

Figure 6-46: Scroll bar slider with clip definition arrows 

Start and end clip sliders: Drag the arrows to define the start and end of the clip. The down 

arrow  slider defines the start of the clip. The up arrow  slider defines the end of the clip. 

Start: Scan number of the first scan to be included in the new Data Clip. Used to manually 

enter the starting scan number or fine tune the start scan number. 

 

End: Scan number of the last scan to be included in the new Data Clip. Used to manually 

enter the ending scan number or fine tune the end scan number. 

 

Remove Clip:  Click to remove clip and play back original full input file. 

Save Clip: Save clip file by clicking “File → Save Clip” 
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Figure 6-47: Save clip menu item 

File menu: 

To read in a new test data file, click “File → Playback test Data” 

 

Figure 6-48: Playback Test Data menu item 

To Generate a TSV File from the existing test data in the player, click “Tools → Generate 

Current Test Data TSV File.” 

 

Figure 6-49: Generate Current Test Data TSV files menu item 

 Generate TSV File 

The test data collected during a test is stored in a non-human readable binary format. This 

data can be exported to an easily readable, tab separated, text file for further analysis. 

Select test data files for conversion from the menu bar using “Tools → Generate Test Data 

TSV Files”. 
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Figure 6-50: Generate Test Data TSV Files menu item 

Multiple files can be selected at a time for batch conversion. Select the desired files and then 

click Save. 

 

Figure 6-51: File selection window for batch conversion of data files into TSV files 

After file selection, the TSV Directory window pops up. 

Gages/Segments: Check to generate a TSV file containing all Gages and Segments. 

Full: Check to generate a TSV file containing measurements from the entire sensor. 

Select Channel(s): Select subset of Channels for which a TSV file is to be generated. 

Index Range: Specify the scan index range to be written to the TSV File to limit the amount 

of data. 

Select the directory to which TSV files are stored. 
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Figure 6-52: Directory selection window when generating TSV files 

The converted test files use a tab separated value (TSV) format to store measurement data 

as well as important configuration information stored as header lines. After the header rows, 

each row of the data file is a measurement scan from the sensor. After the header rows, each 

column of the data file is a Gage location along the sensor.  

The Gages and Segments converted TSV file contains 1 more header row compared to the 

Full converted TSV file, where the Gage Names are included above each Gage Location. 

A snippet of a test data TSV file is shown below. 
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Figure 6-53: Example test data TSV file 
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 Manage Configuration 

The specific sensor combination on each channel, as well as Tare, Rekey, and all settings 

made through the settings menu can be saved as a Configuration for the ease of setting up 

the same test with the same combination of sensors. 

Save Configuration: Click “Configuration → Save Configuration” to save the current settings 

used to configure the ODiSI. Type the configuration name in the “Save Configuration” dialog. 

 

Figure 6-54: Save configuration 

Load Configuration: Click “Configuration → Load Configuration” to load the previously saved 

settings in the named configuration. 

 

Figure 6-55: Load previously saved configuration 

The loaded configuration is displayed on the top right of the User Interface. 

 

Figure 6-56: Configuration name is displayed when configuration is loaded 
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If the configuration is changed after a saved configuration is loaded, the configuration name 

will be displayed in red. 

 

Figure 6-57: Configuration name shown in red if settings changed after load 

Default Configuration: Click “Configuration → Default Configuration” to specify a saved 

configuration that will be used when the ODiSI software is started. 

  

 

Figure 6-58: Set default configuration 

To remove the default configuration, click the “No Default”      button. 

Delete Configuration: Click “Configuration → Delete Configuration” to delete the current 

saved configuration from the system. 

 

Figure 6-59: Delete the current saved configuration 
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 Update Feature Keys 

Click “Tools → Update Feature Keys” to update the software with optionally purchased 

features. Once the file dialog is displayed, select the Luna provided feature key update file. 

The ODiSI software must be restarted after updating the feature keys on the instrument. 

 

Figure 6-60: Update Feature Keys menu item 

 Time Synchronization Settings 

Click “Tools → Time Synchronization Settings” to bring up the Time Synchronization Settings 

dialog. 

 

Figure 6-61: Time Synchronization Settings menu item 

Synchronize ODiSI time stamps to one of these systems: 

• System: Synchronize to the user specified time. Change the system date and time by 

modifying the date and time and clicking the “Apply”      Button. 

• PTP: Synchronize to IEEE 1588-2008 Precision Time Protocol.  

Click the “Apply”      button to apply the PTP settings without starting 
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PTP synchronization. Click the “Start”      button to both apply the PTP 

settings and start PTP synchronization. To start PTP automatically when the ODiSI 

software is started, check the “Start PTP Automatically”      

checkbox. 

• NTP: Synchronize to RFC 5905 Network Time Protocol. 

Click the “Apply”      button to apply the NTP settings without starting 

NTP synchronization. Click the “Start”      button to both apply the NTP 

settings and start NTP synchronization. To start NTP automatically when the ODiSI 

software is started, check the “Start NTP Automatically”    

checkbox. 

 

Figure 6-62: Time Synchronization Settings dialog 

 Help 

 Documentation 

These help documents can be accessed directly from the ODiSI control software: 

• What’s New: Displays a list of the changes made from previous versions of the 

software. 

• User Guide: Matching version of the ODiSI 6 User’s Guide. 

• Setup Guide: Instructions for how to set up the ODiSI 6. 

• Sensor Application Guide: Comprehensive guide containing the best methods for 

attaching a fiber optic strain sensor to a test article. 
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Figure 6-63: Help documentation sub-menu 

 Send us feedback 

 

Figure 6-64: Send Us Feedback menu item 

Generate a report on any issues encountered while running the ODiSI software or feature 

requests associated with software functionality. This report is packaged for subsequent 

emailing to Luna support. 
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Figure 6-65: Form for providing feedback to Luna 

 Update 

 

Figure 6-66: Software update menu item 

Update the ODiSI software to the latest version, or downgrade to a previous version. The 

ODiSI software will automatically restart once the update is initiated. 
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Figure 6-67: Dialog to select software update file 

 Language 

Select the language to be used in the ODiSI software user interface. The ODiSI software must 

be restarted for the language selection to be applied. 

 

Figure 6-68: Menu to select user interface language 
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 About 

 

Figure 6-69: About info menu item 

Displays the ODiSI software version information, connected hardware information, list of 

optional installed features and Luna contact information. 

 

Figure 6-70: About info dialog 
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7 ODiSI Remote Operation 

 ODiSI Remote Application 

The ODiSI Remote application provides the ability to Arm, Start, Stop, and Disarm the ODiSI 

controller software from a remote PC. When the ODiSI controller software is making 

measurements, the remote software will display the measurement data in real time. The ODiSI 

instrument and controller must be running in order for the ODiSI Remote application to 

connect successfully to the ODiSI controller. 

 

Figure 7-1: ODiSI Remote application window 

 Remotely Control an ODiSI 

Configure the Remote Software with the same IP address and port displayed in the main 

ODiSI control software’s Streaming Properties tab. Click the plug head button , which will 

change from red to green upon successful connection. 

The ODiSI Remote application provides limited remote control functionality. The user can 

Arm/Disarm, Start/Stop, and enable/disable test data file logging on the ODiSI controller. 

 Stream in ODiSI Measurement Data  

Configure the Remote Software with the same IP address and port displayed in the ODiSI 

main control software’s Streaming Properties tab. Click the plug head button , which will 

change from red to green upon successful connection. 

Measurement data as defined by Gages and Segments will be streamed into the ODiSI 

Remote application and can be displayed on a Sensor Plot. Within the Sensor Plot, Gages 

will be displayed as circle markers while Segments will be displayed as a line plot. 
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Figure 7-2: ODiSI Remote Sensor Plot 

The ODiSI Remote also provides the ability to Play Back test data files and Generate Test 

Data TSV Files through the menu bar. 

 ODiSI Remote-control Interface 

This section describes the commands (utilized internally by the ODiSI Remote application) 

that facilitate remote-control of the ODiSI controller application. The remote-control interface 

is a two-way interface in which the remote-control application sends a command and the 

ODiSI controller application provides a status update in response. This remote-control 

connection is facilitated over a TCP/IP network connection. Only one such active connection 

can exist at one time. The ODiSI controller application will block any attempts to establish 

additional simultaneous connections. 

 ODiSI Remote-control Commands 

The following table describes the remote-control commands that can be sent after establishing 

a connection. 

Table 7-1 List of remote-control commands 

Command Description 

remote:arm Arm Test 

remote:disarm Disarm Test 

remote:start Start Test 
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Table 7-1 List of remote-control commands 

Command Description 

remote:stop Stop Test 

remote:set_filesave_on Turn Test Data File saving on 

remote:set_filesave_off Turn Test Data File saving off 

remote:getfilesave Poll ODiSI Controller to get the file save state 

remote.getfile Download the last save test data file. 

remote:add_channel=# Add an identified sensor to the test configuration. The 

hashtag/number sign should be replaced by an integer value 

where 1 ≤ # ≤ the number of ODiSI channels 

remote:remove_channel=# Remove a channel/sensor from the test configuration. The 

hashtag/number sign should be replaced by an integer value 

where 1 ≤ # ≤ the number of ODiSI channels 

 ODiSI Controller Status 

The following table describes the status messages that are sent back to the remote-control 

application after a connection is established. The ODiSI controller will send status messages 

back to the connected remote-control to indicate state changes and to give periodic updates 

when the ODiSI controller application is in the identify/standby state. 

Table 7-2 List of remote-control status messages 

Status Description 

status:ready Instrument is ready 

status:armed Intrument is armed 

status:arming Intrument is arming 

status:start Instrument started test 

status:noinstrument No instrument is connected to the controller 

status:notready Controller is in a state where it is not ready. 

(Example: Incorrect configuration, no sensors connected) 
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status:ODiSI6 Notify connected to an ODiSI6 when a remote connection 

is made. 

status:refused Notify that the connection has been refused when a 

remote connection is made. 

status:filesave_on File saving is on 

status:filesave_off File saving is off 

status:filesend_start Sent after remote.getfile command. Test Data File 

download has started.  

status:filesend_done Test Data File download has completed. 

field:testname=TEXT Test Name field has changed. This notification contains 

the test name text after the equals sign (shown here as 

TEXT). 

field:notes=TEXT Test Notes field has changed. This notification contains 

the notes text after the equals sign (shown here as TEXT). 

status:add_channel_success=# Indicates adding the channel to the test configuration was 

a success. The hashtag/number sign is replaced by an 

integer value where 1 ≤ # ≤ the number of ODiSI channels 

status:add_channel_failure=# Indicates adding the channel to the test configuration was 

a failure. The hashtag/number sign is replaced by an 

integer value where 1 ≤ # ≤ the number of ODiSI channels 

status:remove_channel_success=# Indicates removing the sensor/channel from the test 

configuration was a success. The hashtag/number sign is 

replaced by an integer value where 1 ≤ # ≤ the number of 

ODiSI channels 

status:remove_channel_failure=# Indicates removing the sensor/channel from the test 

configuration was a failure. The hashtag/number sign is 

replaced by an integer value where 1 ≤ # ≤ the number of 

ODiSI channels 

status:identified_sensors=TEXT Periodic status message that indicates the currently 

identified sensors. The text after the equals sign (shown 

here as TEXT) is a single line of comma separated values 

(CSV) where each value in the CSV set is the sensor 

name for the corresponding channel on the ODiSI (or 

sensor serial number if the sensor does not have a user-



 
  

ODiSI 6 

 
 

ODiSI 6 User’s Guide Page 78 

 

 ODiSI Remote-control Workflow 

The following shows an example workflow. 

Table 7-3 Example remote-control workflow 

ODiSI Remote Control Command ODiSI Controller 

Remote initiates 
connection 

Open TCP/IP Connection 
and Port 
 

 

 status:refused 
 

Controller refuses 
connection 

 status:ODiSI6 
 

Controller accepts 
connection. The 
controller will also send 
its current status. 

 status:noinstrument Controller is not 
connected to an 
instrument. 

 status:ready Controller is connected 
to an Instrument and is 
Ready 

 status:identified_sensors=TEXT  
 

Controller sends list of 
identified sensors 

Remote turns on saving 
test data file 

remote:set_filesave_on 
 

 

 status:filesave_on 
 

Controller sets file saving 
on 

provided name) or is blank if no sensor is identified. The 

number of commas in the CSV set is one less than the 

number of ODiSI channels 

status:configured_sensors=TEXT Periodic status message that indicates the sensors 

currently in the test configuration. The text after the equals 

sign (shown here as TEXT) is a single line of comma 

separated values (CSV) where each value in the CSV set 

is the sensor name for the corresponding channel on the 

ODiSI (or sensor serial number if the sensor does not have 

a user-provided name) or is blank if the corresponding 

channel is not in the test configuration. The number of 

commas in the CSV set is one less than the number of 

ODiSI channels 



 
  

ODiSI 6 

 
 

ODiSI 6 User’s Guide Page 79 

 

Table 7-3 Example remote-control workflow 

ODiSI Remote Control Command ODiSI Controller 

 

 

field:testname=TEXT 
field:notes=TEXT 
 

Controller sends 
testname and notes. 

Remote turns off saving 
test data file 

remote:set_filesave_off 
 

 

 status:filesave_off 
 

Controller sets file saving 
off 

Remote can check file 
save state. This is done 
on startup 

remote:getfilesave  

Remote adds channel remote:add_channel=# 
 

 

 status:add_channel_success=# 
 

Add channel succeeded 

 status:add_channel_failure=# 
 

Add channel failed 

 status:configured_sensors=TEXT  
 

Controller sends list of 
configured sensors 

Remote remove channel remote:remove_channel=# 
 

 

 status:remove_channel_success=# 
 

Remove channel 
succeeded 

 status:remove_channel_failure=# 
 

Remove channel failed 

Remote arms instrument remote:arm 
 

 

 status:arming 
 

Instrument Arming 

 status:armed 
 

Instrument Armed 

Remote starts test remote:start 
 

 

 status:start 

 

Instrument started test 

Remote stops test remote:stop 
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Table 7-3 Example remote-control workflow 

ODiSI Remote Control Command ODiSI Controller 

 status:armed Instrument stopped test 
and is back in an armed 
state 

Remote disarms 
instrument 

remote:disarm 

 

 

 status:ready Instrument is disarmed 
and is back to a ready 
state 

 status:notready Software controller has 
an incorrect 
configuration, or no 
sensors connected 

Remote requests 
download of latest test 
file. 

remote:getfile  

 status:filesend_start Controller initiates test 
data file download to the 
remote. 

Controller sends content 
of file to the Remote. 

 status:filesend_done 

 

Controller completes the 
file download to the 
remote 
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8 ODiSI Measurement Streaming Protocol (OMSP) 

In the discussion of Streaming Properties above, the measurement data is streamed to and 

analyzed in a separate client. This is accomplished using the ODiSI Measurement Streaming 

Protocol (OMSP). Custom client code can be programmed to connect to the ODiSI 6 and 

receive measurement data for display and logging. 

The protocol consists of JSON-formatted data sent over a TCP/IP connection. JSON is a 

lightweight data interchange format that is easy to read and parse and is supported in virtually 

all programming languages. 

OMSP consists of four message types: 

• An initial acknowledgment message when the connection is established. This 

message type looks like an empty metadata message. 

• Metadata messages provide information about the ODiSI system, the active sensors, 

and the names and locations of the gages that will be streamed.  

• Measurement messages contain the gage values generated from a single 

measurement. 

• Tare messages contain the value of the tare that has been applied to the 

measurements. This is provided in case the client wants to store information about the 

tare or remove the effect of the tare on the data. 

 Terminology 

The ODiSI measures strain or temperature at multiple points along a sensor. 

 Channel 

The ODiSI acquires data from multiple channels (1 to 8 for the ODiSI 6). A different strain or 

temperature sensor is attached to each channel. The channel number is used in OMSP to 

specify which sensor is being referred to. 

 Sensor 

An ODiSI sensor is used to measure either strain or temperature. Each sensor contains 

thousands of different gages at evenly spaced intervals, at which strain or temperature 

measurements are made. 

All of the gages on a given sensor have the same measurement type (strain or temperature) 

and units. 

 Gage 

The ODiSI always calculates measurements at each gage along the sensor. Users can name 

specific gages of interest, and use OMSP to stream those named gage values to another 

program. 

A named gage is defined by its name and its location on the sensor. 
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 Segment Vector 

A segment vector is an array of multiple contiguous gage values. A segment is defined by 

specifying the location of the first gage and the number of gages in the vector. 

All segments will use the same spacing between gages, which is defined by the properties of 

the ODiSI test and the properties of the sensors. 

 Streaming Connection 

The ODiSI streams data over a TCP/IP connection. The TCP/IP port can be configured; the 

default port is 50000. 

Upon configuration by the user, the ODiSI device opens a port and begins listening for a client 

connection. The client program will initiate a TCP connection to the ODiSI server on the 

specified port number. As soon as a connection is established, the ODiSI will begin sending 

messages to the client.  

If at any time the ODiSI loses connection with the client, it will resume listening for a new client 

message and will resume sending data once a new connection has been established. The 

ODiSI will not send measurement data that was missed during the time the connection was 

down. If the user has enabled test data logging to file, the data will still be available in the 

saved test data file. 

The application data is one way. That is, the ODiSI sends data to the client but does not look 

for any responses. 

Each new message starts at the beginning of a new TCP packet. 

 Message Types 

Four types of messages are transmitted over the streaming protocol: an initial 

acknowledgement, a Measurement Message, a Metadata Message, and a Tare. 

The initial acknowledgement is returned when the client first connects. A metadata record is 

returned informing the client that it has connected to the ODiSI Controller. 

The Measurement Message is a simple format, consisting mostly of an array of numeric data 

which represents the measured strain and temperature gage values. The metadata needed 

to fully interpret the data (gage and segment names, locations, units, etc.) require too much 

space to be transmitted with every measurement and are instead transmitted less frequently 

within the Metadata Messages. The Tare message contains the value of the tare that was 

applied to the measurement; it is provided for informational purposes. 

All message types use JSON formatting. This data is human readable text, encoded as UTF-

8. The language of the JSON fields is always English, and is not affected by the language 

selection made in the main software. However, all fields that hold user defined values (test 

name, sensor name, gage name, segment name) support the full UTF-8 character set. 

User defined values will use an escape character to encode quote marks and backslash 

characters (if they appear in the user data). A quote mark is represented as \” in the JSON 

string. A backslash is represented as \\. These are the only characters that need to be escaped 



 
  

ODiSI 6 

 
 

ODiSI 6 User’s Guide Page 83 

 

in order to not preserve JSON formatting. Most JSON libraries should automatically handle 

the conversion from escaped characters back to the original text.  

The ODiSI will transmit a Measurement Message for every acquired measurement. A 

Metadata Message will be transferred once every 5 seconds. Following the Metadata 

Message, one Tare Message will be sent for each active channel. 

When the ODiSI is stopped and not acquiring data, the Metadata Message will be sent once 

every 5 seconds to keep the connection alive. Measurement Messages and Tare Messages 

will be sent when ODiSI operation is started again. 

 Metadata Messages 

 Contents 

The Metadata Message is formatted as human readable UTF-8 text, using JSON formatting. 

A carriage return plus line feed (\r\n) follows the closing curly brace of the JSON text. A CRC-

16-ANSI (0x8005) checksum (encoded as 4 hexadecimal characters) follows the carriage 

return plus line feed. A NULL character follows the checksum and marks the end of the 

message. 

The metadata message contains the following information, formatted as JSON name/value 

pairs: 

Table 8-1 OMSP Metadata Message. 

Description JSON name Value 

Message type ”message type” String “metadata” 

Message format 
version 

“message version” Integer. Ex: 2 

Product “product” String Ex: “ODiSI 6000”. 

System serial number “system serial number” String 

Software version “software version” String. Ex: “1.2.0” 

Hardware version “hardware version” String. Ex: “1.0.0” 

Test name “test name” String. User defined in ODiSI 
software. 

Notes “notes” String. User defined in ODiSI 
software. 

System status “system status” String. “stopped” or 
“measuring”.  

Array of sensors “sensors” Array of JSON elements 
contained in [] brackets 

Measurement rate per 
channel 

“measurement rate” Decimal number indicating 
measurement rate per 
channel. 
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Each sensor contains the following information, formatted as JSON name/value pairs. In a 

multi-channel system, any unused channels are omitted from the metadata message. 

Table 8-2 OMSP Sensor Information. 

Description JSON name Value 

Channel “channel” Integer. 1-8 for ODiSI 6. 

Sensor name “sensor name” String. User defined in ODiSI 
software. 

Sensor serial number “sensor serial number” String 

Sensor part number “sensor part number” String 

Sensor length “length (m)” Decimal number indicating 
length in meters 

Gage pitch “gage pitch (mm)” Decimal number indicating 
the spacing between 
individual gages along the 
sensor. 

Sensor type “sensor type” String. “Strain”, 
“Temperature” or  
“SC Temperature”. 

Units “units” String. “microstrain” or “deg 
C” 

Array of gages “gages” Array of JSON elements 
contained in [] brackets 

Array of segment 
vectors 

“segments” Array of JSON elements 
contained in [] brackets 

 

Each gage contains the following information, formatted as JSON name/value pairs. 

Table 8-3 OMSP Gage Information. 

Description JSON name Value 

Gage name “gage name” String. User defined in ODiSI 
software. 

Gage location “location (mm)” Decimal number indicating 
the gage location in 
millimeters. 
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Each segment vector contains the following information, formatted as JSON name/value 

pairs. 

Table 8-4 OMSP Segment Vector Information. 

Description JSON name Value 

Segment name “segment name” String. User defined in ODiSI 
software. 

Starting location “location (mm)” Decimal number indicating 
the location in millimeters of 
the first gage in the segment 
vector. 

Vector size “size” Integer. Number of gages 
contained in the segment 
vector. 

 

This provides all of the information needed to parse the measurement data transmissions into 

specific gage values. 

• The metadata message may contain a gage section, a segment vector section, or 

both. A segment vector will always begin at a location for which there is also a named 

gage. 

• The “system status” field indicates whether the system is currently acquiring and 

producing data or is stopped. A value of “measuring” indicates that the system is 

producing data. A value of “stopped” indicates that the system is not producing data. 

When the system is stopped, the system will send Metadata Messages only. When 

the system is measuring, it will send both Metadata and Measurement Messages. 

• No changes will be made to the sensor, gage, or segment configurations when the 

system is processing. When the metadata messages indicate a system status of 

“measuring”, the client can be guaranteed that this information will not change from 

one metadata message to the next.  

• The client can also use the Metadata Message checksum to determine whether 

changes have been made to the configuration. If a Metadata Message contains the 

same information as the previously transmitted Metadata Message, its checksum will 

remain the same as well. 

• When the system is in a “stopped” state, the sensor and gage configuration may be 

changed by the ODiSI user. The metadata messages will reflect the current 

configuration, but the client should be aware that this information may change. 

• The JSON portion of the Metadata Message is followed by a 16 bit CRC-16-ANSI 

(0x8005) checksum, encoded as a 4-character hexadecimal number. The checksum 

is calculated over the entire length of the JSON text, beginning with the starting curly 
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brace and including up through the carriage return plus line feed after the closing curly 

brace of the JSON text. 

• The checksum is followed by a single NULL character to mark the end of the Metadata 

Measurement transmission. 

 Example 

{ 

    "message type": "metadata", 

    "message version": 1, 

    "product": "ODiSI 6000", 

    "system serial number": "2017ODB10032", 

    "software version": "6.0.0", 

    "hardware version": "1.0.0", 

    "test name": "My Test", 

    "system status": "measuring", 

    "measurement rate": 25, 

    "sensors": [ 

        { "channel": 1, 

          "sensor name": "left wing", 

          "sensor serial number": "FS02017LUNA001234", 

          "sensor part number" : "HDS05LC220P", 

          "length (m)": 5.1, 

          "spacing (mm)": 2.476302, 

          "sensor type": "strain", 

          "units": "microstrain", 

          "gages": [ 

              { "gage name": "Left front", "location (mm)": 1456 }, 

              { "gage name": "Left mid",   "location (mm)": 2494 }, 

              { "gage name": "Left back",  "location (mm)": 4611 }, 

          ], 

           "segments": [ 

              { "segment name": "Segment A", "location (mm)": 3007, "size": 50 } 

          ] 

       }, 

        { "channel": 2, 

          "sensor name": "right wing", 

          "sensor serial number": "FS02017LUNA002165", 

          "sensor part number" : " HDS05LC220P", 

          "length (m)": 5.1, 

          "spacing (mm)": 2.476302, 

          "sensor type": "strain", 

          "units": "microstrain", 

          "gages": [ 

              { "gage name": "Right front", "location (mm)": 1243 }, 

              { "gage name": "Right mid",   "location (mm)": 2517 }, 

              { "gage name": "Right back",  "location (mm)": 4487 }, 

          ], 

           "segments": [ 

              { "segment name": "Segment B", "location (mm)": 1543, "size": 65 }, 

              { "segment name": "Segment C", "location (mm)": 3307, "size": 40 } 

          ] 

        }         

    ] 
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}8F0A 

 Measurement Message 

 Contents 

The Measurement Message is formatted as human readable UTF-8 text, using JSON 

formatting. A carriage return plus line feed (\r\n) follows the closing curly brace of the JSON 

text. A CRC-16-ANSI (0x8005) checksum (encoded as 4 hexadecimal characters) follows the 

carriage return plus line feed. A NULL character follows the checksum and marks the end of 

the message. 

 Product Name and Serial Number 

The Measurement Message includes a product name and a system serial number.  This 

allows the client program to receive data from multiple ODiSI units. Each ODiSI will transmit 

its own Metadata Message containing an identifying system serial number. The system serial 

number in the Measurement Message allows the client to determine which ODiSI unit the 

measurement data is from, and which Metadata Message to use to interpret the data.  

 Sequence Number 

The Measurement Message includes a sequence number, which is incremented by the ODiSI 

with each measurement transmission. This number allows the client to determine if any 

measurements have been missed. 

 Timestamp 

The Measurement Message includes a timestamp, which is split into separate JSON fields for 

year, month, day, hours, minutes, seconds, and milliseconds. There is also a field to indicate 

the time zone of the timestamp. The ODiSI always uses UTC timestamps, regardless of the 

local time zone. 

 Channel Number 

The Measurement Message includes a channel number, which is used to map the array of 

data values to the gages defined for a particular sensor in the Metadata Measurement.  The 

Measurement Message does not contain gage names or units, so it is necessary to refer to 

the Metadata Message to fully interpret the gage values contained in the Measurement 

Message. 

 “Data” Element 

The “data” element of the Measurement Message contains an array of decimal gage values, 

formatted as human-readable ASCII text.  The gage values are transmitted in the same order 

in which they are defined in the metadata message. Individual gages are defined and 

transmitted first, followed by segment vectors. 

The measured values provided within the “data” array are provided as floating point values. 

The JSON value null will be used to indicate a NaN, or “not a number” value. (Under certain 

conditions, the ODiSI may not be able to calculate a strain or temperature value for a certain 

gage. In these events, the ODiSI reports NaN as the gage value). 
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 Number of Gages 

The element “number of gages” indicates the length of the “data” array. This value should be 

the same as the total number of gages defined in the “gages” and “segments” section in the 

Metadata Message. It is included as a sanity check. 

There is no limit on the number of gages that can be contained in a single sensor. The current 

ODiSI product can generate a maximum of approximately 38,500 gages per sensor (50 m 

sensor with Gage Pitch of 1.3 mm).  

The Measurement Message header contains the following information, formatted as JSON 

name/value pairs. 

Table 8-5 OMSP Measurement Message Header. 

Description JSON name Value 

Message type ”message type” String “measurement” 

Message format version “message version” Integer. 2 is the current 
version. 

Product “product” String Ex: “ODiSI 6000”. 

System serial number “system serial number” String 

Sequence number “sequence number” Integer, 0 - 4,294,967,295. 
(Unsigned 32-bit integer.) 
Sequence number will wrap 
back to 0 after 
4,294,967,295. 

Timestamp “year” Integer, 4-digit year. Ex: 2018 

 “month” Integer, 1 – 12 

 “day” Integer, 1 – 31 

 “hours” Integer, 0 - 23 (24 hour 
notation) 

 “minutes” Integer, 0 - 59 

 “seconds” Integer, 0 - 59 

 “milliseconds” Integer, 0 - 9999 

Time zone “time zone” String. Ex: “UTC-0” 

Channel “channel” Integer. Should match one of 
the “channel” fields in the 
“sensors” array of the 
Metadata Message. 

1 - 8 for the ODiSI 6. 

Number of gages “number of gages” Integer 
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Data “data” Array of decimal numbers. 
The JSON value null 
indicates NaN. 

Quality factor “quality factor” Array of decimal numbers 

 

The JSON portion of the message is followed by a 16 bit CRC-16-ANSI (0x8005) checksum, 

encoded as a 4-character hexadecimal number. The checksum is calculated over the entire 

length of the JSON text, beginning with the starting curly brace and including up through the 

carriage return plus line feed after the closing curly brace of the JSON text. 

The checksum is followed by a single NULL character to mark the end of the Measurement 

Message transmission. 

 Example 

{ 

    "message type": "measurement", 

    "message version": 1, 

    "product": "ODiSI 6", 

    "system serial number": "2017ODB10032", 

    "sequence number": 125, 

    "year": 2017, 

    "month": 1, 

    "day": 13, 

    "hours": 13, 

    "minutes": 23, 

    "seconds": 14, 

    "milliseconds": 56, 

    "time zone": "EST UTC-5", 

    "channel": 1, 

    "number of gages": 4, 

    "data": [ 805, -754.5, null, 901 ] 

    "quality factor": [ 0.3544, 0.384, 0.367, 0.391 ] 

}AF37 

 Tare Message 

 Contents 

The Tare Message contains the value of the tare that was applied to the measurement. It is 

provided for informational purposes but is not necessary for interpreting the measurement 

values. 

The Tare Message contains the tare value for a single sensor. One Tare Message is sent for 

each active channel in the test. 

The Tare Message is formatted as human readable UTF-8 text, using JSON formatting. A 

carriage return plus line feed (\r\n) follows the closing curly brace of the JSON text. A CRC-

16-ANSI (0x8005) checksum (encoded as 4 hexadecimal characters) follows the carriage 

return plus line feed. A NULL character follows the checksum and marks the end of the 

message. 
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 Product Name and Serial Number 

The Tare Message includes a product name and a system serial number, allowing the client 

program to receive data from multiple ODiSI units. Each ODiSI will transmit its own Metadata 

Message containing an identifying system serial number. The system serial number in the 

Tare Message allows the client to determine which ODiSI unit the measurement data is from. 

 “Data” Element 

The “data” element of the Tare Message contains an array of decimal gage values, formatted 

as human-readable ASCII text.  The gage values are transmitted in the same order in which 

they are defined in the metadata message. Individual gages are defined and transmitted first, 

followed by segment vectors. 

The JSON value null will be used to indicate a NaN, or “not a number” value. (Under certain 

conditions, the ODiSI may not be able to calculate a strain or temperature value for a certain 

gage. In these events, the ODiSI reports NaN as the gage value.) 

 Number of Gages 

The element “number of gages” indicates the length of the “data” array. This value should be 

the same as the total number of gages defined in the “gages” and “segments” section in the 

Metadata Message, and the same as the “number of gages” field in the Measurement 

Message. It is included as a sanity check. 

The Measurement Message header contains the following information, formatted as JSON 

name/value pairs. 

Table 8-6 OMSP Tare Message header 

Description JSON name Value 

Message type ”message type” String “tare” 

Message format 
version 

“message version” Integer. 2 is the current 
ODiSI version. 

Product “product” String Ex: “ODiSI 6000”. 

System serial number “system serial number” String 

Channel “channel” Integer. Should match one of 
the “channel” fields in the 
“sensors” array of the 
Metadata Message. 

1 - 8 for ODiSI 6. 

Number of gages “number of gages” Integer 

Data “data” Array of decimal numbers. 
The JSON value null 
indicates NaN. 
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The JSON portion of the Tare Message is followed by a 16 bit CRC-16-ANSI checksum, 

encoded as a 4-character hexadecimal number. The checksum is calculated over the entire 

length of the JSON text, including the starting and final braces. 

The checksum is followed by a single NULL character to mark the end of the Tare Message 

transmission. 

 Example 

{ 

    "message type": "tare", 

    "message version": 1, 

    "product": "ODiSI 6", 

    "system serial number": "2017ODB10032", 

    "channel": 1, 

    "number of gages": 4, 

    "data": [ 103, -57.5, null, 91 ] 

}B3F4 

 Receiving Messages Across TCP Packets 

The described JSON messages may be split across multiple TCP packets, depending on the 

size of the message and the number of sensors and gages that have been defined. 

Each message will begin in a new TCP/IP packet. The checksum and terminating NULL 

character will occur at the end of a packet. 

A program receiving ODiSI Measurement Streaming Protocol messages can use either or 

both of the following methods to determine when a complete Metadata or Measurement 

Message has been received. 

• Concatenate multiple TCP packets until a NULL character is received. The four 

characters preceding the NULL should be interpreted as a checksum. Everything 

preceding the checksum should be interpreted as a JSON-encoded Metadata or 

Measurement Message. 

• Count pairs of curly braces (that is, the { character and the } character) as data is 

received. Each JSON message will begin with an opening { curly brace. Other pairs of 

{} curly braces will be present within the message. When a closing } curly brace 

matching the opening { curly brace is encountered, the receiver can conclude that the 

end of the message has been reached. The receiver should expect to see seven more 

characters – two characters for the carriage return plus line feed, four characters for 

the hexadecimal checksum, and a terminating NULL character. 

If at any time the receiving program encounters a new packet that begins with: 

 {"message type" 

the program should assume that this is the beginning of a new message. If the program was 

in the process of storing TCP packets in order to assemble a message whose end has not 

been received, the program should discard the previous partially-received message and begin 

processing a new message starting with the new packet.  
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9 Additional Information 

 Sensing Results near the Fiber Termination 

One common question about sensing with the ODiSI is, “How close to the end of the 

sensor will I get strain/temperature results?” The answer to this question is determined 

by three parameters: 

1. Where is the physical sensor termination inside the protective tube? 
2. How does the ODiSI software locate the sensor termination? 
3. How much space does the ODiSI 6000 put between where it locates the sensor 

termination and the end of strain or temperature sensing? 

 
Consider the illustration of the termination end of a Luna fiber sensor: 

 

Figure 9-1: Illustration of the termination end of a Luna fiber sensor 

1. There is some variation in the position of the physical sensor termination in the 
protective tube. The goal is to place the physical sensor termination near the 
middle of the protective tube. The protective tube is ≤ 1 cm long. No strain or 
temperature results are possible for the length of the protective tube. 

2. The structure and width of the termination will cause some variation in where 
exactly the termination event is located by the software. The ODiSI 6000 control 
software is looking for the point in the optical data at which there is the steepest 
drop from the sensor scatter level down to the instrument’s noise floor. 

3. The ODiSI 6000 control software will end its strain/temperature sensing 1 cm 
before the detected sensor termination event. This 1 cm is a fixed quantity in the 
ODiSI 6000 control software. It is necessary because the termination splice has 
some width and sensing is not possible where the sensing fiber is contaminated 
by the termination. 

 
Typically, the sensing ends ~1.5 cm from the far end of the protective tube. The worst-

case occurs when the termination is at the very beginning of the surrounding protective 

tube. In that case the length for the sensing dead zone at the end of the sensor is equal 

to the 1 cm protective tube plus 1 cm of fiber, or 2 cm total. 
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 System Operation Guidelines 

The ODiSI 6 system provides precise strain or temperature change measurements at a high 

spatial resolution along the length of an optical fiber sensor. It is best suited for static or low 

loading rate tests. 

 Vibration Tolerance 

 Test Setup 

Like most highly sensitive testing instruments, the ODiSI 6 system is susceptible to 

environmental disturbances, most often vibration or motion of the sensor. Since the ODiSI 6 

operates on signals reflected from the sensor, environmental disturbances, usually vibration, 

can corrupt the measured data. It is very important to design tests that ensure that 

environmental disturbances do not affect the measurements.  In designing the testing, several 

vibration related items to keep in mind include: 

• Check for vibration from other machinery on the test floor 

• Monitor vibration coupling to the sensor from the load frame  

• Check for shaking of unbonded sensor fiber 

 Strain Test Setup 

The key to obtaining quality strain measurements is to ensure that the fiber sensor is properly 

attached to the test piece. The surface needs to be prepared (scuffed and cleaned with 

ethanol) and the fiber needs to be uniformly bonded down. Epoxy selection is also very 

important as it determines cure temperature, optimal temperature range for use, and the 

surface roughness of the test piece.   

For tests at elevated temperature that require thermal compensation of strain measurements, 

ensure that the compensation measurement device (unbonded fiber, thermocouple, or 

dummy gage) is in the same thermal environment as the strain sensor. 

See the Applying Strain Sensors document for more detailed instructions on mounting and 

positioning sensors, which can be accessed from the Help menu on the ODiSI 6. 

 Troubleshooting Dropouts 

The ODiSI 6 relies on a correlation of reference and measurement gage data to calculate the 

strain along the sensing fiber. Environmental disturbances such as mechanical vibration can 

lead to a degradation of the measurement data. Enough disturbance weakens the correlation 

sufficiently to make a strain or temperature calculations unreliable. In these situations, the 

software drops the unreliable strain measurement and replaces it with a NaN (not a number). 

If a high number of dropouts are observed along the sensing fiber, the distribution of dropouts 

over the sensing fiber’s length can help diagnose the source of the problem. 
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Table 9-1 Troubleshooting Dropouts 

Dropout Profile Symptom Resolution 

Dropouts are observed 
at a high frequency 
along the entire length 
of the sensing fiber 

The vibration correction 
algorithms cannot remove 
all vibration occurring in 
the remote optics module. 

Investigate remote module 
for excessive movement or 
contact with vibrating 
machinery. 

The connector of the 
sensing fiber to the 
standoff or the connector 
of the standoff to the 
instrument has a poor 
optical connection.  

Clean and reconnect 
optical connectors. 

 

 

The termination has been 
damaged causing a strong 
reflection to washout the 
sensor data. 

Investigate termination 
integrity and use index 
matching gel to reduce 
reflection at the interface. 

Dropouts increase in 
frequency along the 
length of the sensing 
fiber in a linear manner 

The sensing fiber is 
experiencing uniform 
vibration over the sensing 
length.  The effect is 
building along the sensing 
length. 

Reduce test parameters of 
the loading structure (i.e., 
load amplitude and 
frequency). 

Ensure test artifact is 
isolated from 
environmental 
disturbances. 

Dropouts vary in 
frequency randomly 
along the sensing fiber 

The sensing fiber is 
experiencing non-uniform 
motion over the sensing 
length. 

Ensure test artifact is 
isolated from 
environmental 
disturbances. 

Ensure unbonded fiber is 
secured and not moving 

No valid data observed 
after a location along 
the sensing fiber 

The optical fiber has 
broken at that location. 

Splice the sensor and 
rekey it if possible. 
Otherwise, sensor must be 
replaced. 

Dropout frequency is 
limited to areas of rapid 
strain transitions 

The strain change across a 
gage length is too great for 
the ODiSI 6 calculation. 

Attempt running the ODiSI 
6 in high resolution mode 
to decrease the gage 
length, effectively reducing 
the amount of strain 
variation across a given 
gage length. 
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Dropout Profile Symptom Resolution 

Dropout frequency is 
limited to areas of rapid 
strain transitions 

The strain change across a 
gage length is too great for 
the ODiSI 6 calculation. 

Rekey the sensor. 

Dropouts occur at high 
strains, more than 
12,000 microstrain 

The strain experienced is 
beyond the limits of the 
ODiSI 6. 

Rekey the sensor. 

 General Troubleshooting 

 The ODiSI 6 or Controller Does Not Power On 

Table 9-2 Troubleshooting No Power 

Cause(s) Solution(s) 

The ODiSI 6 and/or the 
controller is not plugged 
in or turned on (and the 
controller battery is 
dead, if applicable) 

The ODiSI 6 and the controller require separate power 
cords. Plug in the ODiSI 6 and/or the controller, or replace 
dead batteries with charged ones. Instructions for the 
controller battery are located in the provided controller 
manual. Make sure to turn on the ODiSI 6 power switch 
on the rear of the instrument, and the controller according 
to its instructions. 

Blown fuse 

Replace the fuse. For instructions, see “Replacing Fuses” 
in the Maintenance and Cleaning section in the Setup 
Guide located, which can be accessed from the Help 
menu on the ODiSI 6. 
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 Excessive Noise in Data 

Table 9-3 Troubleshooting Excessive Noise 

Cause(s) Solution(s) 

Mechanical vibration Move or shut down any sources of vibration. Isolate the 
ODiSI 6 from those sources. 

Dirty or loose fiber 
and/or bulkhead 
connections 

Clean all connections and reconnect the fiber 
connections. For instructions, see “Cleaning Connectors” 
in the Maintenance and Cleaning section in the Setup 
Guide, which can be accessed from the Help menu on the 
ODiSI 6. 

Subpar routing and/or 
orientation of standoff 
cable and/or remote 
module 

Reroute and reorient the standoff cable and remote 
module to minimize signal degradation and to arrive at a 
more ideal physical configuration. 

Cracks in bulkhead 
connector alignment 
sleeve 

Contact Luna Technologies at 1-866- LUNAOVA or 
solutions@lunainc.com for service. 

 

 No Data After Measurement 

Table 9-4 Troubleshooting No Data 

Cause(s) Solution(s) 

Incorrect graph range 
settings 

Rescale the plot axes. 

 

 Errors on Software Startup 

Table 9-5 Troubleshooting Software Setup 

Cause(s)  Solution(s) 

The USB cable 
connections might be 
loose 

Check the connections to ensure that the cable is 
connected properly to both the instrument and the 
controller. 

The instrument is not 
turned on 

Ensure that the instrument is plugged into the proper type 
of outlet and turn on the power switch. 

The software is in an 
unknown state 

Exit and restart the software. 

mailto:solutions@lunainc.com
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The hardware is in an 
unusable state and is not 
responding to the 
software 

Exit the software. Turn the instrument off and then back 
on again. Restart the controller and the control software. 

The USB cable is faulty Replace the cable 

Communication Error 

Turn computer off. 

Turn on ODiSI 6. 

Restart Computer. 

Laser error 
Power cycle the instrument and controller. Relaunch the 
software 
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10 Product Support Contact Information 

Contact Luna’s technical support staff with concerns or questions using one of the following 

methods. 

 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 

 

Headquarters: 3155 State Street 

   Blacksburg, VA  24060 

 

Main Phone:    1.540.961.5190 

Toll-Free Support: 1.866.586.2682 

Fax:   1.540.961.5191 

Email:   solutions@lunainc.com 

Website:  www.lunainc.com  
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