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Chapter 1 
 

System Overview 1 
 
 

Luna Technologies’ Optical Backscatter Reflectometer (OBR) is the industry’s first 
ultra-high resolution reflectometry device with backscatter-level sensitivity for 
interrogating components or systems. The OBR uses swept-wavelength coherent 
interferometry to measure minute reflections in an optical system as a function of 
length. This technique measures the full scalar response of the device under test 
(DUT), including both phase and amplitude information. 

 
 

 
 

Data is presented graphically, providing the user with unprecedented optical-module 
inspection and diagnostic capabilities. The data may be used to: 
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• Locate loss events—Monitor backscatter levels to isolate 

 

 

1 
losses due to bends, crimps, bad splices, etc. 

• “Look inside” devices—Use high resolution and sensitivity to 
interrogate individual components within a subsystem. 

• Track Polarization—Track changes in the state-of-polariza- 
tion as light propagates through an optical network. 

 
The Control Software 

The OBR control software includes an intuitive graphical interface (Figure 1-1). All 
controls, options, and measurement results are easily accessible from the single main 
window or the menu bar. The user selects which parameters are displayed from the 
pull-down menu at the top of either plot window. 

 
 

Caution Use of controls or adjustments or performance of 
procedures other than those specified herein may result 

               in hazardous radiation exposure and one or more safety 
protections may be impaired or rendered ineffective. 

 
 

The following parameters are calculated and displayed by the OBR control software: 
 

Time Domain Data (Upper or Lower Graph) 
• Amplitude (dB/mm) (For a complete definition, see “Time Domain 

Amplitude and Amplitude (dB)” on page 180). 
• Amplitude (dB) (See page 180). 
• Linear Amplitude (See page 181). 
• Phase Derivative (See page 182). 
• Polarization States (See page 181). 
• Magnitude Difference (See page 182) 

 
Frequency Domain Data (Lower Graph) 

• Return Loss (See page 168). 
• Linear Amplitude (See page 166). 
• Polarization States (See page 166 
• Group Delay (See page 169). 



Optical Backscatter Reflectometer 4600   3 
User Guide 

 

1 

Distributed Sensing Options (Lower Graph) 
 

The following time domain parameters are only available to users who purchase 
spectral shift or Distributed Sensing options with the OBR. 

 

• Magnitude Difference (See page 182) 
• Spectral Shift (See page 175). 
• Spectral Shift Quality (See page 190) 
• Temperature Change (See page 174). 
• Strain (See page 174). 
• Temporal Shift (See page 175). 

 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 

Figure 1-1. Control software main window. Some of the buttons and fields will be 
“grayed,” or inactive when the software starts. They become active when data is 
loaded or scanned into the software. 
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The control software also provides many tools for data acquisition, manipulation, 
and display. Data may be acquired in standard, spot, or fast scan in continuous or 
regular scan mode. Postprocessing allows the user to change the spatial resolution 

 

 

1 
without the need to redo the measurement. Graph windows support powerful zoom 
and cursor features. 

 
Time Domain Data 

By default, the upper graph displays the amplitude of the time domain data, which 
is equivalent to a traditional optical time domain reflectometry (OTDR) 
measurement. The user may also set the lower graph to display time domain data 
by using the pull down graph in the upper right hand corner of that graph. 

 

In the time domain, each optical interface within the device under test produces a 
peak. The time domain data can also be displayed in terms of length. This allows 
the user to quickly and reliably identify and locate reflections along the length of 
an optical system. The phase derivative of the time domain data can also be displayed 
in the upper plot window. The phase derivative corresponds to the instantaneous 
wavelength response of a device. This is particularly useful for devices designed to 
operate over narrow wavelength bands like DWDM (dense wavelength division 
multiplexed) filters. 

 

The return loss shown in the upper graph gives the single average loss value at each 
vertical cursor, for a quick pass/fail evaluation for each optical path or interface. 

 
Frequency Domain 

 

By default, the lower plot shows the linear amplitude of the frequency domain data, 
which corresponds to the insertion loss or return loss of the device under test. The 
lower plot can also display return loss, polarization states, or group delay. 

 

The frequency domain plot is calculated based on only the time domain data 
highlighted by the cursor in the plot window above. Therefore it is possible to 
analyze individual sections of a device or system and determine the amplitude and 
phase response of each interface separately, by highlighting their corresponding 
peaks in the time domain plot. This provides a powerful means for quickly and easily 
identifying faults and pinpointing their cause within a component, module, or 
subsystem. 
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Frequency Domain Resolution 
The duration of the impulse in the time domain determines the necessary step size 
for the group delay measurement. If the step is too large, information about the device 
is lost. If the step is too small, extraneous noise enters the measurement. Luna 
Technologies’ OBR software allows the user to select precisely the correct step size 
by setting the time domain window so that it includes only the device response. It 
is also possible to obtain group delay data for a variety of step sizes by changing 
the setting of the time domain window and recalculating the frequency domain data. 
There is no need to perform a new measurement. This contrasts traditional methods 
of group delay measurement, such as the modulation phase shift technique, where 
the user must guess at the appropriate step size and perform a new measurement to 
change that step size. 
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Chapter 2 
 
 
 

Assembly and Startup 
2 

The Optical Backscatter Reflectometer is shipped with everything needed to conduct 
device characterizations, including the measurement instrument and all supporting 
hardware, software, documentation, and cables. 

 

Read and follow all assembly and startup instructions before attempting to operate 
the Optical Backscatter Reflectometer. 

 

 
Warning The protection provided by the equipment may be impaired 

if the equipment is used in a manner not specified by the 
               manufacturer, resulting in serious injury or death. 

 
 

Components List 
The Optical Backscatter Reflectometer is shipped with either a laptop or a PC with 
monitor, keyboard and mouse. All other components shown below are shipped with 
each OBR instrument. 

 
 
 
 
 

Optical Backscatter Reflectometer 4600 instrument. 
 
 
 
 
 
 

One (1) USB cable to connect the OBR instrument to the PC 
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One (1) power cord for the OBR instrument. (Plus two (2) 
more, if you ordered the PC and monitor) 

 
 
 

2 
         OBR laptop PC (or desktop PC, shown below)

 

 

           Laptop power supply 
 
 
 
 
 
 

OBR desktop PC (or laptop PC, shown above) 
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17-inch flat panel monitor (with desktop only) 
 

2 
 
 

         Monitor-PC interface cable (with desktop only) 

     Keyboard (with desktop only) 

 

                Mouse (with desktop only) 
 

 
 
 
 

Gold reflector 
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This OBR 4600 User Guide 
 
 

2 
  

             Software recovery CD-ROM 

        Optical fiber connector cleaner 

 
 
 

Optical fiber bulkhead connector cleaners 
 
 
 
 
 

 
 
 
If components are missing or damaged, contact Luna Technologies toll free at 
866-586-2682 or by e-mail at support@lunatechnologies.com. 

mailto:support@lunatechnologies.com
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Setting up the OBR 

 
 

Important The instrument should always be fully assembled before 

                 turning power on to any of its components. 
 

To set up the OBR 2 
1 Remove all the OBR components from the shipping containers and 

verify that no components are missing. (See “Components List” on 
page 7.) 

 

2 For best performance, place the OBR on a stable surface, capable of 
supporting the weight of the entire unit. For the weight and dimensions 
of the unit, see Appendix A‚ “Specifications,” on page 213. 

 
 

Important Place the OBR away from walls or objects that will restrict 

                 the air flow through the fan duct on the back of the unit. 
 
 

3 Unpack and set up the desktop or laptop PC according the 
manufacturer’s instructions provided. If you purchased a desktop PC, 
connect the monitor, keyboard, and mouse to the PC, using the cables 
provided. For user-supplied PCs, see “Minimum PC Requirements” on 
page 204. 

 
 

Important Do not turn on to the PC yet. 
Do not connect the instrument to the PC until instructed. 

                Do not place the laptop on top of the instrument. 
 
 

4 If printouts are desired, connect a local printer to a printer port (parallel 
or USB) on the PC using the proper cable for the printer, according to 
the PC manufacturer instructions enclosed. For information on printing 
from the OBR software, see “Printing Graphs” on page 76. 
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5 If necessary, install the drivers for local or network printers that will be 

used for printing data sheets. 
 

Important Do not install any software on the OBR PC other than a 
printer driver or software supplied by Luna Technologies. 

               Third-party software installed on the PC may impair the 
proper function of the OBR. 

 
 

6 Optional: To connect the OBR to a network, connect a network cable 
(not provided) to the ethernet port on the PC. 

 

7 Do not connect the OBR instrument to the PC with the USB cable until 
instructed in the next section. 

 

8 On the front of the instrument, there is a white plastic cap installed to 
protect the source port. Leave this cap on when the instrument is not in 
use. To remove the cap for measurements, turn the white cap 
counterclockwise. 

 

9 Attach the power cords provided to the instrument and to the PC. To 
ensure safe operation, place the instrument to allow easy disconnection 
of the power cord. Note that the OBR requires surge-protected, grounded 
outlets. 

 
Initial Startup 

1 After full assembly above, turn on the PC (according to manufacturer’s 
instructions), allowing it to fully load up Microsoft® Windows® 7 or XP. 
(Note that the screen appearance shown in this User Guide may vary 
according to Windows®  version and options.) 

 

2 If you purchased a PC from Luna Technologies, it comes with the OBR 
control software already installed. If not, install the OBR software now. 
(From the Luna Technologies CD provided, open the OBR 4600 folder 
and run setup.exe, following on-screen instructions.) 

 

3 Ensure that the OBR is powered OFF. 
 

4 Connect the OBR to the PC using a standard USB cable (provided). 
 

5 Turn on the OBR using the power switch on the front panel. 
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6 All LEDs on the front panel of the instrument will turn on, then all but 

the Power LED will turn off. The Power LED will remain lit until the 
unit is powered off. 

 

7 The PC will automatically detect the device and display the “Found New 
Hardware Wizard” dialog window: 

 

                                                  2 
 
 

8 Select the “No, not this time” option and click the “Next” button to 
continue. A new window will be displayed: 
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9 Select the “Install from a list or specific location (Advanced)” option 

and click the “Next” button. 
 

10  A new window, similar to the one below, is displayed: 
 
 
 

2 
 
 
 
 
 
 
 
 
 
 
 
 
 

11  Select the “Search for the best driver in these locations” option and 
check the “Include this location in the search” checkbox. Click the 
“Browse” button to select the location of the driver. 

 

12  Browse to the location where the instrument software was installed (e.g. 
C:\Documents and Settings\All Users\Application Data\Luna 
Technologies\OBR v#.#) and then into the “USB_Drivers” sub- 
directory. Click “OK”. 

 

13  Another dialog box will alert the user to wait while the Wizard searches. 
When it becomes available, click the “Next” button to continue. 
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14  An alert dialog will be displayed: 

 
 
 
 
 
 

2 
 
 
 
 
 
 
 
 
 

15  Click the “Continue Anyway” button to proceed. A new window will 
be displayed: 

 
 

 
 

16  Click the “Finish” button to complete installation of the driver. 
 
 

Important It is helpful to make a note of which USB port you used 
for the OBR instrument. If the instrument is ever connected 

                to a different USB port, it may require that this driver 
installation procedure be completed again. 
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17  Start the control software by double-clicking the OBR desktop 
icon or by selecting OBR Software from the programs group in the 
Windows® Start menu. An initial window will appear for a few moments 
while the user interface is initialized. 

 
 

If the control software is started when the instrument is not 
powered on, a communication failure error message 
opens. However, the software can be used in desktop 

Important analysis mode when the instrument is not powered by 
clicking OK in the message box. 
To operate in normal mode (which is required for 
scanning), turn on the instrument and then restart the OBR 
software. 

 

 
Once the control software is running, the OBR is ready to Acquire Reference. (See 
“Instrument Configuration” on page 34, and “Calibrating the System” on page 35.) 
Any time the equipment stabilizes to a new ambient temperature (anywhere between 
10–40 ºC) the user may wish to perform another Reference Scan for greater 
accuracy. 
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Chapter 3 
 
 
 

Software Guide 
 
 

The control software is the primary interface between the user and the instrument. 
It provides all of the necessary tools to reference the system and to perform precise 
loss and reflection measurements of fiber-coupled optical devices. It also contains 
a variety of powerful features for data manipulation and display. 

 

This chapter provides an overview of the location and function of all controls and 
indicators included in the control software. Chapter 4‚ “Performing Measurements,” 
on page 33 provides greater detail on how to use the OBR to perform specific 
measurement tasks. Chapter 5‚ “Data Processing and Display,” on page 59 more 
fully describes how to process the data and manipulate plots. 

 
 
 
 
 
 

Important 

If the control software is started when the instrument is not 
powered on, a communication failure error message 
opens. However, the software can be used in desktop 
analysis mode when the instrument is not powered by 
clicking OK in the message box. 
To operate in normal mode (which is required for 
scanning), turn on the instrument and then restart the OBR 
software. 
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Window Features 

 
 
 
 
 
 
 
 
 
 

3 
 

 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 

Figure 3-1. OBR control software main window, with data loaded. Note that the 
upper vertical cursors are on, so loss calculations are shown in the upper graph. 
The sensing features and shift reference displayed in the Data Processing and 
Display Options areas are not available on all OBR units. The number of 
traces available also depends on OBR configuration. 

 
The main window is composed of 6 functional areas: 

 

1 The System Control area contains buttons to control the OBR 
instrument and set test parameters. 

 

2 The Data Processing area allows the user to enter the desired the spatial 
resolution and Integration Width. When Options > Sensing is enabled 
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(if purchased) the fields in this area change. (See “Distributed Sensing 
Measurements” on page 48.) 

 

3 The Display Options area allows the user to control which traces are 
being displayed, to move data within local memory, and to view the 
Details of each measurement loaded into memory. This will be further 
explained under “Displaying Multiple Traces” on page 59. 

 

4 A System Status Bar message will light up if saturation or overheating 
is detected. They are shown in the normal, “off” status in Figure 3-1 
above. If one of these lights, see “System Status Bar Messages” on 
page 203. 

 

5 The two Graph areas may contain plots of test data, as described in the 
next section. The upper graph displays time domain data, and the lower 
displays either time domain or frequency domain data. The pull-down 
menu at the top of each graph allows the user to select which parameter 
is displayed. Buttons to the lower left on each graph adjust plot axes, 
cursors, legend, and zoom. 

 

6 The Menu Bar contains additional commands for loading and saving 
data files, printing, performing reference scans, and for setting various 
measurement and display options. (See “The Menu Bar” on page 27.) 

 
System Control 

The System Control area of the main window contains fields and menus that control 
the OBR instrument and set test parameters, as shown on the left. If Extended Mode 
was purchased, the System Control will have one of two appearances, depending 
on the Options > Distance Range setting. 
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Figure 3-2. The System Control area in the main OBR software window, shown in 
Normal (left) and Extended (right) Distance Range modes. Also in the left 
example, Spot Scans have been enabled by turning on the Spot Scan Cursor. 

 
• The Center Wavelength (nm) field allows the user to set the center 

wavelength of a scan. To set this parameter, type in a number within 
the wavelength range of the instrument. 

• The Wavelength Range (nm) field allows the user to set the range 
of the scan. The wavelength range determines the number of nano- 
meters that will be analyzed during the next measurement. A drop- 
down list contains the range options available for the OBR model in 
use. This value cannot be changed when operating in Extended 
Range mode (see “Instrument Configuration” on page 34). 

• The Scan Range (nm) field shows the starting and ending wave- 
lengths that will be scanned, as determined by the center wave- 
length and wavelength range entered by the user (or by default) in 
the two fields above. 

• The Gain (dB) field allows the user to select the gain of the scan 
from a drop-down list of options. 

• Continuous Scan, when checked, causes the OBR to take repeated 
measurements. The graph displays are continuously updated after 
each measurement. This mode is started and stopped by pressing 
the Scan button. 

• Clicking the Scan button starts the measurement of the device 
under test. This same button is used to stop scanning when operat- 
ing in Continuous Mode. 
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• Clicking the Spot Scan button (as shown in the left side of Figure 

3-2) starts a spot measurement of the device under test. (See “Spot 
Scan Mode” on page 44.) This same button is used to stop a Spot 
Scan when operating in Continuous Mode. 

 
Data Processing 

The Data Processing area allows the user to enter Spatial Resolution and 
Integration Width settings, as shown on the left below. For more information, see 
“Spatial Resolution Calculations” and “Integration Width” on page 164. If the 
Distributed Sensing option was purchased, and Options > Sensing Enabled is ON 
(checked), the Data Processing area changes to allow setting of sensing parameters, 
as shown on the right below. (See “Distributed Sensing Measurements” on page 59.) 

 
 
 
 
 
 
 
 
 
 
 
 
 
 
 

Figure 3-3. The Data Processing area in the main OBR software window when 
Options > Sensing Enabled is OFF (left) or ON (right). 

 
Display Options 

The Display Options area allows the user to store data from the most recent scan 
to one of two or more traces, depending on your unit’s configuration. The data loaded 
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in a given trace may be graphed by clicking in the adjacent checkbox. It may be 
moved from Trace A to another trace by clicking a button in the Operations column. 

 
 
 
 
 
 
 
 
 

3 
 
 
 

Figure 3-4. The Display Options area in the main OBR software window. Only two 
traces will be available when the OBR is turned off (desktop analysis mode), 
and with some high resolution configurations. 

 
If the Distributed Sensing option was purchased, the last Trace will also be labeled 
as the Shift Reference (See “Distributed Sensing Measurements” on page 59) when 
Options > Sensing Enabled is On (checked). 
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Graphs 

Each Graph area contains controls for selecting the content of the graph and for 
manipulating how the graph is displayed. 

 
 
 
 
 
 
 

3 
 
 
 
 
 
 
 
 
 
 

Figure 3-5. The upper graph area in the main OBR software window. 
 

• The upper graph will display newly scanned or loaded data. 
• Two conditions allow data to appear in the lower graph: 

 

Standard Scan Mode: First, the vertical cursors must be turned on 
in the upper graph. Second, either Options > Display Options > Auto- 
Update Lower Graph must be turned on (checked), or the user must click 
the recalculate button   at the upper left of the upper graph. Controlling 
the content of the lower graph will be covered more fully under “Updating 
Lower Graph” on page 67. 

 

Spot Scan Mode: Data will also appear in the lower graph during continuous 
spot scans if the upper vertical cursors are on (see “To perform continuous 
spot-scan measurements” on page 46). 

 

• The Title Bar at the center top of each graph contains a pull-down 
menu allowing the user to select which parameter is graphed. These 
parameters are defined under “Standard Parameter Calculations” on 
page 179. 
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3 Figure 3-6. The parameters menu on the left is available for the upper graph. The 
menu on the right is the Time Domain menu for the lower graph area. The last 
five parameters will be gray (unavailable) in some models. By selecting Fre- 
quency Domain in the top right corner of the lower graph area, the menu 
shown in the center becomes available. 

 
• The pull-down menu  at the bottom of a time 

domain graph allows the user to select the value and units of the X- 
axis: Time (ns), Length (m), Length (ft), or Length (in). In the 
lower frequency domain graphs, the available X-axis units are 
Wavelength (nm), Frequency (GHz), and Frequency (THz). 
Note that the Y-axis units are determined by the parameter dis- 
played. 

• Buttons to the lower left of each graph let the user adjust plot axes, 
cursors, and zoom, and show or hide a legend. Table 3-1 describes 
the function of each button and gives a page number for further 
explanation. 

 
Table 3-1: Graph area buttons and their function. 

 

Button Description Page 

  
 

Sets the scale of the X-axis to display the full range of the data set. 

 
 

69 

  
 

Sets the scale of the Y-axis to display the full range of the data set. 

 
 

69 
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Button Description Page 

  

 
Sets the mouse cursor to a cross-hair that allows the user to drag 
graph cursors. 

 
 

72 

 Allows the user to select from the following zoom tools that appear 
in a pop-up menu. A blue border surrounds the selected tool. 

 
 
 
 
 
 
 
 
 
 

Allows the user to click and drag to define a 
“zoom window” in both the X and Y dimen- 
sions. 

• 

Allows the user to click and drag a zoom 
area in the X-axis only. This is the default 
tool active in each graph. 

• 

Allows the user to click and drag a zoom 
area in the Y-axis only. 

Returns the graph to the full scale of all data. 

Zooms in (magnifies) from the point where 
the cursor is located. 

• 

Zooms out from the point where the cursor is 
located. 

 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 

70 

  

 
Lets the user pan around the data in a graph window by clicking 
on the graph and dragging the cursor. 

 
 

74 
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Button Description Page 

 Toggles two vertical cursor lines on or off. Note that when these 
cursors are on in the upper graph, differential and return loss are 
calculated and displayed in the upper right legend. Also, the data 
points integrated to calculate loss are highlighted in contrasting 
colors. 

 

 
By default, with all cursor buttons, cursors are attached to Trace 
A. The user may attach them to another trace using the pull-down 
menu at the upper left corner of the graph. 

 

 
Note that with all the cursors, the X- and Y-coordinates are 
displayed in the upper right of the graph when any cursors are on. 

 
 
 
 
 
 
 

73 

  
 

Toggles two horizontal cursor lines on or off. 

 
 

73 

  
Toggles the plot legend on or off. The color, style, and width of a 
line may be changed in a menu accessed by clicking within the 
legend. (See “Changing graph style and color” on page 74.) 

 
 

74 

  
Toggles twin locked cursor on and off. Regardless of where these 
cursors are dragged, they will intersect the first graph at a data 
point. 

 
 

73 

  
Brings cursors into the viewed portion of the graph. By default, 
cursors appear at 10% and 90% of the X- or Y-axis range. They 
may be dragged by selecting the cross-hair cursor, . 

 
 

73 

 Moves the vertical cursors to the peak of the regions highlighted. 
This control only works properly with vertical cursors, when 
Options > Cursors > Show Integration Area is enabled 
(checked) [When Options > Sensing Enabled is on, this menu 
item becomes Options > Cursors > Show Sensing Area. See 
“Distributed Sensing Measurements” on page 48.] 

 
 
 

73 
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Button Description Page 

  
 

Allows the user to set the location of subsequent spot scans. 

 
 

45 

  
 

Locks the spot scan cursor onto the active cursor. 

 
 

45 

  
 

Saves the current graph as a .jpg image file. 

 
 

57 

 The center button recalculates the data in the lower graph area 
based on the data in the upper graph highlighted by the yellow (left) 
or orange (right) vertical cursor. These buttons appear in the upper 
left of the upper graph only when the vertical cursors are on in the 
upper graph. Clicking the left button will automatically recalculate 
the lower graph based on the yellow cursor in the upper graph if 
Options > Display Options > Auto-Update Lower Graph is 
checked. Otherwise, the user must click either the yellow or the 
orange button and then hit the recalculate (center) button. The pull- 
down menu to the left of these buttons shows which trace is being 
displayed in the lower graph. 

 
 
 
 
 
 

67 
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The Menu Bar 
The menu bar contains additional commands for performing reference scans and for 
setting various measurement and display options. Menu bar commands are organized 
into five menus. 

 
The File menu 

• Load Data File loads a binary data file (of the type “.obr”) previ- 
ously saved by the OBR. A dialog box appears allowing the user to 
select the file. 

• Save Data Files saves measurement data according to the selec- 
tions in the File > Select File Options dialog box. (See “To save 
data” on page 65 for more information.) 
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• Load Reference File allows the user to select a file from the hard 

drive to load into the shift reference. (See “Distributed Sensing 
Measurements” on page 59.) This feature is only available as a pur- 
chased option, and will otherwise be gray in the file menu. 

• Select File Options calls up a dialog box allowing the user to select 
the file type(s) for data saved. The user may select the file exten- 
sions for spreadsheets (.txt) and binary files (.obr). Only binary files 
may be reloaded into the OBR software. (See “Saving Data” on 
page 62 for more information.) 

• Save Software Options saves user-selected settings from the 
Options menu; these options are retained the next time the software 
is run. 

• Print Datasheet prints the two graphs as they are displayed to the 
default printer. (For more information, see “Printing Graphs” on 
page 76.) 

• Exit exits the OBR control software. 
 

The Edit menu 
• Cut may be used to cut user-selected numbers in fields and axes 

and paste them to the clipboard. 
• Copy copies selected numbers from a field or axis to the clipboard. 
• Paste pastes numbers from the clipboard to a field or axis value. 

 
The Options menu 

• Instrument Configuration calls up a dialog box where the user 
can select the device length range (in Normal Range mode) and the 
desired resolution. (See “Instrument Configuration” on page 34.) 

• Distance Range allows the user to select either Normal Range (30 
or 70 m) or Extended Range (up to 2 km) measurements. This 
menu item is gray if the user has not purchased the Extended 
Range option. The user should note that the spatial resolution will 
go down when operating in the Extended Range mode. (See the 
Specifications Sheet that came with your OBR unit for details.) 

• Resolution BW Units allows the user to select either picometers 
(pm) or gigahertz (GHz) as the resolution bandwidth units. The 
default setting is picometers. The resolution bandwidth is displayed 
in the lower right of the lower graph area, but only when the upper 
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vertical cursors are on and when the lower graph displays fre- 
quency domain data. Data resolution is further discussed under 
“Resolution Bandwidth Calculations” on page 177. 

• Data Decimation (Upper Graph) > Specify Level allows the user 
to select data decimation level, as explained under “Data Decima- 
tion” on page 75. 

• Display Options controls several display features: 
 

> Auto-Update Lower Graph, when checked, automatically recalculates 
the lower graph whenever new data is loaded or scanned, provided the upper 
vertical cursors are on. 

 

> Apply Spatial Resolution Filter turns on (checked) and off (unchecked) 
the time domain filter. (See “Spatial Resolution Calculations” on page 178.) 

 

> Apply Frequency Domain Window turns on (checked) and off 
(unchecked) the Frequency Domain Window. (See “Frequency Domain 
Windowing” on page 47.) 

 

> Autoscale Y Axes (Both Graphs) allows the user to turn on (default 
setting) and off autoscaling for the Y-axes in both graphs. When this option 
is selected, the plot axes automatically scale to include the entire data set 
on the Y-axes when a new measurement is performed. 

 

> Autoscale X Axis (Upper Graph) or (Lower Graph) allows the user to 
turn on and off autoscaling for the X-axis in the upper or lower graph. 

 

• Cursors > Show Integration Area, when checked (default set- 
ting), highlights the data points used to calculate the data for the 
lower graph. [In Distributed Sensing Mode (page 48), a purchased 
option, this menu item will read Options > Cursors > Show Sens- 
ing Area, though it will function the same.] When the Integration 
Area (or Sensing Area) is shown, return loss and differential loss 
are displayed in the upper right corner of the upper graph. 

• Spot Scan: 
 

> Logging Enabled turns on (checked) and off (unchecked) the automatic 
saving of data files during Continuous Spot Scanning. The directory and 
file prefix are set through the next menu item, Options > Spot Scan > Set 
Logging Options. 



30   Chapter 3 
Software Guide 

 

 

3 

 
>Set Logging Options calls up a dialog box where the user may set the 
directory and filename prefix for logged data. 

 

• Fast Scanning: 
 

> Fast Scanning Enabled turns on (checked) and off (unchecked) fast 
scanning. See “Fast Scan Mode” on page 44. 

 

> Set Fast Scan Rate calls up a dialog box for setting the scan rate, as 
described further under “Fast Scan Mode” on page 44. 

 

• Sensing: 
 

> Sensing Enabled turns on (checked) and off (unchecked) distributed 
sensing, if this option was purchased. Otherwise this menu item will be gray. 
(See “Distributed Sensing Measurements” on page 48.) 

 

• > Temperature and Strain Coefficients calls up a dialog box 
where the user can change the values used to convert from spectral 
shift to temperature change and strain. For more information, 
“Temperature Change and Strain Coefficients” on page 49. 

• Lower Graph: 
 

> One Plot, when checked, means one parameter at a time will be plotted 
in the lower graph. 

 

> Two Plots, when checked, brings up two parameter selection menus in 
the lower graph area. For more information, “Displaying Two Parameters 
in Lower Graph” on page 66. 

 

• Color Palette calls up a dialog box allowing the user to specify the 
colors for each graph. These changes may be saved for future times 
the software is used (by clicking Save), or only be applied to the 
current use of the software (by clicking Apply). Clicking Reload 
Defaults allows the user to go back to the original software set- 
tings. 

• Remote Interface Setup calls up a dialog box to set up remote con- 
figuration. For more information, see Chapter 7‚ “Controlling the 
OBR Remotely,” on page 119. 

 
The Tools menu 

• Turn Laser OFF or ON allows the user to turn the laser on or off 
from the OBR control software. 



Optical Backscatter Reflectometer 4600   31 
User Guide 

 

3 

 
• Calibrate calls up a dialog box which allows the user to specify the 

calibration settings and begin a calibration. (See “Calibrating the 
System” on page 35 for complete calibration instructions.) 

• Align Optics performs an alignment of the internal optics of the 
OBR. See “Aligning the OBR Optics” on page 34 for more infor- 
mation about system alignment. 

• Calibration Information calls up a screen with information on the 
laser calibration currently in use. 

• Specify Calibration Filenames allows the user to use the default 
calibration filename (obrCal_refl), or to uncheck this box and type 
in or select a new calibration filename. For further details, see “Cal- 
ibration Files” on page 36. 

• Reload Calibration Data reloads the most recent valid calibration 
data. This may be used when a calibration fails or is cancelled by 
the user. 

• Install New Feature Key calls up a dialog box where the user may 
enter a key string provided by Luna Technologies, in order to 
unlock a newly purchased software feature. 

• Reset Hardware allows the user to reset the OBR hardware with- 
out having to turn off the device. This should only be used in the 
rare event that the device becomes non-responsive. This command 
will close the software and thus requires the user to restart the OBR 
software. 

 
The Help menu 

• About OBR 4600 displays information about the current software 
version and contact information for Luna Technologies. 

• Version Information calls up a dialog box showing the OBR hard- 
ware version. This information is used by Luna Technologies for 
upgrading OBR hardware. 
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Chapter 4 
 
 
 

Performing Measurements 
 
 

Setting Up 
The front panel of the Optical Backscatter Reflectometer contains the power switch 
and the optical connector necessary to perform reflection measurements. 

4 
 
 
 

Indicator 
LEDs 

 
 
 
 
 

Power switch 
 

Optical Port (FC/APC Connector) 
 

Figure 4-1. The OBR 4600 instrument. 
 

Four LEDs indicate the state of the instrument: 
 

• The Power LED lights when the power is on. 
• Laser On lights after the laser has been turned on. 
• Scanning lights whenever the laser is scanning. 
• USB lights after a scan, while the OBR unit is sending data to the 

PC. 
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Aligning the OBR Optics 

In order to perform accurate measurements, the internal optics of the OBR must be 
properly aligned. The three conditions that require an alignment to be performed 
are listed below. 

 
Alignment must be performed... 

 

1 When the instrument is initially set up for the first time. 
 

2 Whenever the OBR is physically moved from one location to another. 
 

3 Whenever the indicator in the System Status Bar 
is visible. 

4 To align the OBR optics 
 

1 Ensure that the OBR unit is powered on and that the laser is on and ready. 
 

2 Select Tools > Align Optics. 
 

A dialog box appears instructing the user to disconnect devices. The user may 
opt to Cancel or click OK to continue. 

 

If OK is selected, alignment begins. A status bar shows the progress of the 
alignment. When the alignment is complete, the software returns to the main 
window. 

 

3 The user must next perform a calibration, as described below. 
 

Instrument Configuration 
Before calibrating the instrument, the user should select Options > Instrument 
Configuration. This calls up a dialog box (Figure 4-2) where the user can select 
the maximum device length for Normal Range measurements. (In Extended Range 
mode, selecting the maximum device length has no effect.) The user can also select 
the desired resolution level. 

 

The right side of this dialog box shows the Resultant Values, based on the length 
and resolution settings. With higher resolution data, only 2 traces are available. 
Length and resolution settings also determine the maximum wavelength range 
available, which is also shown in this box. 
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Figure 4-2. The Instrument Configuration dialog box allows the user to set the 4 
maximum device length and resolution, and shows the resultant wavelength 
range and number of traces available. 

 
Changing the desired resolution in the lower left pull-down menu (Figure 4-2) may 
require a software restart, depending on how much the settings change. However, 
a dialog box (Figure 4-3) will appear allowing the user to continue and close the 
software, or to cancel the resolution change. 

 
 
 
 
 
 
 
 
 
 
 
 
 
 

Figure 4-3. This dialog box appears if a change in resolution requires a software 
restart. The user can opt to continue (OK) or Cancel the resolution change. 

 
Calibrating the System 

The OBR system must be calibrated prior to performing measurements. The OBR 
calibration removes the effects of the measurement network to ensure that the 
measured data represent only the device under test. 
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Calibration Files 

The most recent calibration is stored in a file which is loaded by the control software 
upon start-up. If the software is unable to locate a calibration file, a dialog box will 
appear to alert the user that a calibration must be performed before a measurement 
can take place. In this event, the Scan button will be unavailable (gray) until a 
calibration has been performed. 

 
Conditions that Require Calibration 

In a typical laboratory or manufacturing environment, calibration should be 
performed at least once every 24 hours. The need to recalibrate is largely determined 
by the surrounding environmental conditions. If the temperature is fluctuating 
rapidly, it may be necessary to calibrate more than every 24 hours. If the surrounding 
temperature is very stable, a longer interval may suffice. 

 

Calibration should be performed whenever the surrounding temperature has changed 
by more than ±5 degrees C. And as already mentioned, the OBR must be calibrated 
after an alignment. 

 

In certain cases the control software will detect that the internal optics of the 
instrument have drifted, and it will alert the user via the System Status Bar indicator 

. When this occurs performing a calibration will typically suffice. 
 

Consideration Prior to Calibrating 
The maximum spatial resolution that can be achieved with the OBR is related to 
the wavelength range of the measurement according to 

 
λ1 λ2 

=  --------------- , 
∆z 

neff ∆λ 
 

where ∆z is the spatial resolution, nef f  is the effective index of refraction of the 
device under test, λ1  and λ2  are the start and end wavelengths of the scan, and 
∆λ = λ1 – λ2  . Thus, calibration over larger wavelength ranges will allow for the 
highest spatial resolution measurements. 
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The Calibration Procedure 

 
To calibrate the system 

 

1 Ensure that the OBR unit is powered on and that the laser is on and ready. 
The Laser On light on the front of the instrument comes on when the 
laser reaches operating temperature. 

 

2 Select Tools > Calibrate. 
 

The following dialog box appears: 
 
 
 

4 
 
 
 
 
 
 
 
 
 
 
 

Figure 4-4. Calibration Parameters dialog box. 
 

3 Type in the Center Wavelength appropriate for the device(s) to be 
tested following calibration. 

 

4 Select the desired Wavelength Range from the pull-down menu. 
 

Note that in order to perform measurements over a broader wavelength range 
than the one selected during calibration, it is necessary to recalibrate. 

 

5 Click Continue. 
 

The instrument performs several internal scans. Next a prompt appears 
instructing the user to connect the supplied reference fiber and reflector to the 
instrument. First follow step six. 

 

6 Before making connections, be sure to clean all fiber optic connectors. 
(See “Cleaning Connectors” on page 195.) 
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7 Align the connector key to fit in the groove in the bulkhead adaptor. 

Turn the screw ring around the connector clockwise until it is just 
tightened. 

 

8 Click OK. 
 

A dialog box appears as calibration proceeds. 
 

9 A prompt appears instructing the user to disconnect the reference fiber 
and reflector. After doing so, click OK. 

 

10  Click OK in the dialog box indicating that the instrument has been 
successfully calibrated. 

 

After calibrating, it is advisable to check if the calibration was successful, to ensure 
that the system will provide accurate data. 

 
Checking the Calibration 

1 Follow all the instructions above, under “To calibrate the system” on 
page 37. 

 

2 Reattach the gold reflector, after cleaning its connector. 
 

3 In the System Control area, enter a Center Wavelength and select a 
Wavelength Range from the pull-down menu. These settings must fall 
within the range of the calibration just performed or currently loaded. 

 

4 Click Scan. 
 

The instrument performs the measurement and the software displays the test data 
in the upper graph. 

 

5 From the parameters menu or Title Bar in the upper graph, select 
Amplitude. This may already be displayed, as it is the default setting. 

 

6 Turn on the vertical cursors in the upper graph by clicking . 
 

7 Select the cross-hair          tool, then click and drag the yellow cursor 
to about 1.0 m, the location of the gold reflector. 

 

8 Click the button, which moves the cursors to a local peak. 
 

9 In the Data Processing area, set Integration Width (or Sensing Range) 
to 0.2 m. 
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10  In the lower graph Title Bar area, click the yellow button, 

meaning that the lower graph will be calculated based on the upper, 
integrated segment surrounding the yellow cursor. 

 

11  Next hit the blue          recalculate button in the lower graph Title Bar 
area. 

 

12  Select Frequency Domain from the pull down menu at the upper right 
of the lower graph. 

 

13  From the lower parameters menu or Title Bar, select Return Loss. 
 

14  The resulting curve should be nominally flat, within the measurement 
accuracy of the instrument, with a mean value of about 0.0 to -1.0 dB. 
(For the return loss accuracy see the Specifications Sheet shipped with 
your OBR unit.) 

 

If the return loss curve is not nominally flat, perform a second calibration. If 
this fails to yield a nominally flat return loss curve, contact Luna Technologies 
toll free at 866-LUNAOVA (866-586-2682). 

 
Storing Multiple Calibrations 

Users may store more than one calibration file, covering different wavelength ranges. 
Note that users should only use calibration files created in the last 24 hours or so, 
as explained under “Conditions that Require Calibration” on page 36. 

 
To store or use multiple calibrations 

 

1  Select Tools > Specify Calibration Filenames. The dialog box below 
appears. 

 
 
 
 
 
 
 
 
 
 
 
 
 

Figure 4-5. Specify Calibration Filename(s) dialog box. 
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2 Click on the Use Default Calibration Filename(s) checkbox, leaving 

it unchecked, as shown above. The Calibration Filename field becomes 
accessible. 

 

3 Type in a new filename. Alternately, if other calibration files have been 
saved, the user may select a previously-saved calibration file from the 
pull-down list. The default calibration filename is obrCal_refl. 

 

4 Click OK. 
 

5 If you typed in a new calibration filename, next select Tools > Calibrate. 
Follow the instructions under “The Calibration Procedure” on page 37. 
The new calibration will then take effect. It will be stored under the 
filename entered in the Specify Calibration Filename(s) window 
shown above. 

 

—OR— 
 

If you selected an existing calibration file, you must select Tools > Reload 
Calibration Data. Or, if you wish to overwrite this existing filename with a 
new calibration, simply perform a new calibration. 

 

In either case, the OBR will not warn you if you are overwriting an existing 
calibration file. 

 

6 In order for the current calibration file to take effect when the OBR 
software is restarted, select File > Save Software Options. Otherwise, 
the default calibration file (obrCal_refl) will be loaded upon the next 
startup. 

 
 

Important 
Again: Renaming the calibration filename under Tools > 
Specify Calibration Filenames does not change the 
calibration file used by the OBR software. To do so, the 
user must next perform a new calibration, or select Tools 
> Reload Calibration Data. 

 
 

Acquiring Data 
The OBR has several options for data acquisition: Single Scan Mode and 
Continuous Scan Mode. Both modes can be performed at user-controlled speeds 
(see “Fast Scan Mode” on page 44) and in user-selected regions of the fiber under 
test (see “Spot Scan Mode” on page 44 and “Extended Range Spot Scan Mode” on 
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page 46). Each option performs a complete scalar measurement of the device (or 
section of the device, for Spot Scans) under test, and all parameters are available 
from measurements done in any mode. 

 
 

Important Before attaching any device, clean the fiber optic 
connector with the appropriate cleaner to guard against 

                errors. For instructions, see “Cleaning Connectors” on 
page 195. 

 
 

Single-Scan Mode 
The single-scan measurement represents the basic functionality of the OBR. In this 
mode the instrument performs a single sweep of the laser over the selected 
wavelength range, and acquires data for the device under test over that range. 

 
To perform a single-scan measurement 

 

1 Ensure that the OBR unit is powered on and that the laser is on and ready. 
The Laser On light comes on when the laser reaches operating 
temperature. Launch the OBR software. 

 

2 Be sure that the instrument has been aligned (see “To align the OBR 
optics” on page 34), configured (see “Instrument Configuration” on 
page 34), and calibrated (see “To calibrate the system” on page 37) 
within the recommended time period. 

 

3 Before connecting the device to the OBR, be sure to clean all fiber optic 
connectors. (See “Cleaning Connectors” on page 195.) 

 

4 Connect the device to the Source port on the front of the OBR. 
 

5 Enter an appropriate Center Wavelength in the System Control area 
(Figure 4-6). 

 

If the center wavelength entered falls outside the range of the instrument, the 
software replaces it with a value within the instrument’s range. (See the 
Specifications Sheet shipped with your OBR unit for standard instrument 
wavelength ranges.) 
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Figure 4-6. The System Control area in the main OBR software window, shown in 
Normal (left) and Extended (right) Distance Range modes. 

 
6 In Normal Range mode, select a Wavelength Range from the pull- 

down menu. If the desired scan range falls outside the range of the most 
recent calibration, either select a smaller scan range or recalibrate the 
OBR. 

 

In Extended Range mode, the Wavelength Range is set by the software, 
depending on the resolution set by the user (see “Instrument Configuration” on 
page 34). As mentioned earlier, Extended Mode is not available unless 
purchased as an option. 

 

7 In Extended Range mode, enter the DUT (Device Under Test) Length 
in meters. When measuring near the end of the range of DUT Length, 
it is important to enter an accurate DUT Length, ±20 m. At the 
beginning of the Distance Range, accuracy within 100 meters is 
sufficient. 

 

8 Check the Options > Display Options menu for functions to be applied 
to the scan, such as Data Decimation (see page 58) and Auto-Update 
Lower Graph. These options may also be applied to data after scanning. 
However, to apply Frequency Domain Windowing to the data, it must 
be turned on before scanning (see page 42). 

 

9 If Distributed Sensing options were purchased, you may wish to adjust 
the Options > Temperature and Strain Coefficients (see “Distributed 
Sensing Measurements” on page 48). 
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10  Click Scan in the System Control area (Figure 4-6). 

 

The instrument performs the measurement and the software displays the test data 
in the upper graph. 

 

Note that even if Options > Display Options > Auto-Update Lower Graph 
is off (unchecked), data may appear in the lower graph window from a previous 
scan. To update the lower graph based on the current time domain data, see 
“Updating Lower Graph” on page 67. 

 
Continuous Scan Mode 

Continuous scan mode takes advantage of the fast measurement speed of the OBR 
to monitor devices whose properties may change slowly with time. 

 
 

Important For accurate measurements, the device must change 
slowly enough that its properties remain constant while 

                data is acquired. 
 
 

Note that continuous scan mode will operate more quickly if the lower graph area 
is “turned off” by unchecking Options > Display Options > Auto-Update Lower 
Graph. To view this data after scanning, see “Updating Lower Graph” on page 67. 

 
To scan continuously 

 

1 Perform all but the last step of a the Single Scan mode above. Before 
clicking the Scan button, select Continuous Scan in the System 
Control area of the main window. 

 

2    Optional: To gain more speed, uncheck Options > Display Options > 
Auto-Update Lower Graph. 

 

3    Click Scan in the System Control area (Figure 4-6). 
 

4    The Scan button will turn gray during continuous scanning. 
 

The active graph window(s) will update after each scan. 
 

5 To stop scanning, either press the grayed Scan button again, or uncheck 
the Continuous Scan box above the Scan button. 
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Fast Scan Mode 

In both the Single Scan and Continuous Scan modes, the user may chose to increase 
the scanning rate from the default setting. Spot Scans (see below) may also be 
performed at a user-set scanning rate. 

 

The user should note that Fast Scanning increases the laser sweep rate to decrease 
measurement time. Fast Scanning is not appropriate for some applications with high 
return loss. The Fast Scan sweep rate can be set from 10 to 200 nm/sec. 

 
 
 
 

Note 

4 

In order to increase the laser sweep rate, the laser 
acceleration range must also be increased. This reduces 
the maximum available wavelength range to avoid low 
wavelength values. To achieve a larger wavelength range 
in Fast Scan mode, the user may need to recalibrate 
with a higher center wavelength. Calibrating the 
instrument while in Fast Scan mode will coerce the center 
wavelength to values that are valid for the Fast Scan mode. 

 

 
1 Before clicking Scan, select Options > Fast Scanning > Set Fast Scan 

Rate. In the dialog box shown below, set the scanning rate. 
 
 
 
 
 
 
 
 
 
 
 
 

2 Select Options > Fast Scanning > Fast Scanning Enabled. (A check 
mark in the menu indicates that Fast Scanning is On or Enabled.) 

 

3 Perform a Scan as instructed under “Single-Scan Mode” on page 41 or 
“Continuous Scan Mode” on page 43. 

 
Spot Scan Mode 

The Spot Scan mode allows the user to scan a one- to two-meter region of the DUT, 
allowing for shorter measurement times and smaller data files. Spot Scans may be 
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performed in both the Single Scan and Continuous Scan modes, at default or user- 
set scanning speeds. 

 
To perform a single spot-scan measurement 

 

1 If desired, select Options > Fast Scanning > Set Fast Scan Rate to 
set the scanning rate. 

 

2 A regular scan must be completed prior to performing a spot scan. 
Follow the instructions under “To perform a single-scan measurement” 
on page 41. 

 

3 Click the Spot Scan Cursor button: . Note that a Spot Scan button 
will now appear in the System Control area, as shown below. 

 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 

4 Select the cross-hair tool         , then click and drag the broad, orange 
Spot Scan Cursor to a region of interest in the data for a spot scan, 
and release the cursor. 

 

5 Click the Spot Scan button in the System Control area. The resulting 
Spot Scan will be displayed in Trace A in the upper graph area. 

 

6 Click the X-axis scale tool to display the full range of the data set. 
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To perform continuous spot-scan measurements 

 

1 Follow the instructions above for a single Spot Scan. In the System 
Control Area, click to enable Continuous Scan mode. 

 

2 Optional: If Data Logging is desired, select Options > Spot Scan > 
Logging Enabled. (A check mark in the menu indicates that Logging 
is On or Enabled.) 

 

Select Options > Spot Scan > Set Logging Options. In the dialog box which 
appears, browse to select the directory for logged data. Enter a file prefix and 
click OK. A separate data file will be saved for each Spot Scan in the selected 
directory. 

 

3 In order to display Continuous Spot Scans in the lower graph, turn the 
vertical cursors on in the upper graph. (See “To update the lower graph” 
on page 67.) Drag the yellow cursor to the Spot Scan region. 
Alternatively, you can press the spot scan lock button to lock the 
spot scan cursor to the active vertical cursor. (See “Spot Scan Cursor 
Unlocked or Locked Toggle Button:” on page 74.) 

 

4 Click the Spot Scan button to start continuous scanning. This button 
will turn gray during continuous scanning. Continuous Spot Scans will 
appear in the lower graph. 

 

5 To stop scanning, press the grayed Spot Scan button again 
 

Extended Range Spot Scan Mode 
Just as with spot scans in regular mode, this method of scanning provides measure- 
ment data over a sub-section (more than 85 m) of the extended range scan in a 
fraction of the time it takes to perform a standard extended range scan. The scan 
rate in this mode is set to 10 nm/s, with Fast Scanning currently disabled in this 
mode. Larger wavelength range scans are available when performing spot scans. This 
provides measurement data with a 4x increase in spatial resolution. The Extended 
Range mode allows the user to scan devices out to 2 kilometers in length. Extended 
Range Spot Scans may be performed in both the Single Scan and Continuous Scan 
modes. 
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To perform extended range spot-scan measurements 

 

1 Perform the first four steps of the single Spot Scan measurement (see 
“To perform a single spot-scan measurement” on page 45). Select 
Options > Distance Range > Extended (A check mark in the menu 
indicates that Extended Range is On or Enabled). As mentioned 
earlier, Extended Mode is not available unless purchased as an option. 

 

2 In Extended Range mode, a standard extended range scan must be 
performed prior to performing any extended range spot scans. See the 
instructions on performing a standard extended range scans (see “Single- 
Scan Mode” on page 41 which includes Extended Range scan 
instructions). 

 

3 In Extended Range mode, the Wavelength Range can be increased 
from the minimum available when performing spot scans in order to 
achieve higher resolution measurements. If the wavelength range 
selected is greater than the minimum available, the Scan button is 
disabled, allowing the user to only perform spot scans until the 
wavelength range is reduced. 

 

4 Click the Spot Scan button in the System Control area. Click the Spot 
Scan button to start continuous scanning. This button will turn gray 
during continuous scanning. The resulting Spot Scan will be displayed 
in Trace A in the upper graph area. If continuous scanning was selected 
then the Continuous Spot Scans will appear in the lower graph. 

 
Frequency Domain Windowing 

The OBR software provides the option to apply a Hanning window to the frequency 
domain data for new scans. The window is only applied to new data as it is scanned 
and will not affect data already loaded into other traces. Saved binary files retain 
this windowing. 

 

The frequency domain window setting is toggled on (checked) and off by using the 
menu selection Options > Display Options > Apply Frequency Domain Window. 

 

The Measurement Details dialog box (Figure 5-2 on page 61) shows whether or 
not the Frequency Domain Window was applied to the data. 
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Figure 4-7. Amplitude of a flat end face reflector. The Blue trace shows the data 
without the Frequency Domain Window applied. The White trace shows that 

applying the Frequency Domain Window makes the peak details more evident. 
 

Distributed Sensing Measurements 
If the user purchases this option, s/he can measure five distributed sensing 
parameters: spectral shift, spectral shift quality, temperature change, strain, and 
temporal shift. The user begins by performing a measurement at ambient state and 
storing this measurement in Trace E, the Shift Reference. After a strain or 
temperature perturbation is applied to some portion of the fiber under test (FUT), 
a second measurement is taken and compared to the reference measurement. For 
the theoretical background on these measurements, see “Optional Distributed 
Sensing Parameters” on page 187. 
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Important 

When calculating Sensing curves, the Sensing Range 
used must begin in a region of zero temperature or strain 
difference between the reference and measurement files. 
This is necessary to align the measurement files for 
spectral and temporal correlations. Similarly, Spot Scans 
must begin in a region of zero temperature or strain 
difference between the reference and measurement files. 
If the calculation area (i.e. integration width or spot scan 
region) does not begin in a region of zero strain or 
temperature difference, the correlation algorithms will fail. 
This can be witnessed by discontinuous sensing data and 
low (> 0.15) spectral shift quality. 4 

Temperature Change and Strain Coefficients 
The Temperature Change and Strain curves are generated by converting the 
Spectral Shift curve from values in GHz to degrees C or microstrain. This 
conversion is done using a 4th  order polynomial fit. The user may specify the 
coefficients for this conversion by selecting Options > Temperature and Strain 
Coefficients, which calls up the dialog box below. 

 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 

Figure 4-8. Select Options > Temperature and Strain Coefficients to call up this 
dialog box. The user-adjustable coefficients control how the software converts 
from Spectral Shift to Temperature Change or Strain. 

 
This window allows the user to specify the coefficients used for each individual trace, 
and the default coefficients to be used for new scans. When the window is first 
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opened, it shows the default coefficients. These coefficients will be used whenever 
a new scan is taken. 

 

The coefficients for each individual trace may be viewed or modified by using the 
Trace pull-down menu. A trace may have different coefficients from the default 
values. For example, if a file is loaded into Trace B, the coefficients for Trace B 
will be those stored in the binary file, not the default coefficients currently being 
used for new scans. Likewise, if the user changes the default coefficients after 
scanning data into Trace A, the Trace A coefficients will still be set to the values 
used when originally taking the scan. 

 

The default coefficients have been set for standard SMF 28 fiber. To calibrate these 
coefficients to another type of fiber, first measure the Frequency Shift of that fiber. 
Use external sensors to measure the actual scaling factors of your fiber. Then enter 
the correct coefficients under Options > Temperature and Strain Coefficients. 

 

The Change all traces to Default values button changes the coefficients for all of 
the traces to match the default values. This button is only visible when viewing the 
default coefficients. 

 
 
 

Important 

If a trace contains data loaded from a file, changing the 
coefficients for that trace does not change the file that was 
loaded. The new coefficients will be used to generate the 
Temperature Change and Strain curves during the 
current run of the software, but the coefficients stored in 
the file will remain the same unless the user resaves the 
binary file. 

 

 
The default coefficients are stored in the OBR software configuration file. If the 
Update software settings checkbox is checked, then pressing the OK button will 
save the new coefficients to the configuration file, as well as updating the values 
currently being used. (The default coefficients are also saved when the user selects 
File > Save Software Options from the main menu.) 

 

If the user presses the Cancel button, no changes are made to any of the coefficients, 
either the defaults or those for the individual traces. 

 

Changing the coefficients for a trace does not cause the lower graph curves to be 
immediately updated. If either the Temperature Change or Strain curve is being 
displayed in the lower graph, the user should press the recalculate button          to 
recompute the curve with the new coefficients. If any other curves are displayed, it 
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is not necessary to recalculate, as the coefficient values do not affect other curve 
types. 

 
Distributed Sensing Technique 

1 Turn Options > Sensing Enabled on, as indicated by a check mark by 
that menu item. 

 

2 By default, the OBR performs Sensing measurements at the fastest scan 
rate available for your instrument. To achieve this, the instrument is 
automatically switched to Fast Scan Mode. (See “Fast Scan Mode” on 
page 44.) If a slower scan rate is desired, select Options > Fast 
Scanning > Set Fast Scan Rate. In the dialog box that appears, set the 
scanning rate. 

 

Note that you do not need to select Options > Fast Scanning > Fast Scanning 
Enabled, because it is automatically enabled when Sensing is enabled. Upon 
turning off Options > Sensing Enabled, the instrument returns to the Scan Rate 
that was in use before enabling Sensing. 

 

3 Perform a measurement on the FUT under ambient conditions, without 
applied strain or temperature perturbation. (See “To perform a single- 
scan measurement” on page 41.) Move this data from Trace A to the 
Shift Reference, which is the last Trace in the list. For example, if five 
traces are available, click the button labeled A->E under the Operations 
column of the Display Options area. 

 

Alternatively, the user may load such data from the hard drive directly into Trace 
labeled Shift Reference as follows. Select File > Load Reference File. In the 
dialog box that appears, choose the desired Trace location, then browse for the 
file and click Open. 

 

4 Apply strain or a temperature perturbation to some point along the length 
of the FUT. Scan the fiber in the perturbed state. This data automatically 
loads into Trace A. 

 

5 Turn on the vertical cursors in the upper graph by clicking . 
 

6 Adjust the cursor locations in the upper graph as desired by selecting 
the cross-hair tool, then clicking and dragging a cursor. 

 

7 If Options > Cursors > Show Sensing Area is on (checked), the regions 
of the graph around the vertical cursors are highlighted. The Sensing 
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Area is the only segment that will appear in the lower graph. The user 
may change the width of the highlighted area (and lower graph X-axis) 
by entering a new Sensing Range in the Data Processing area. 

 

8 Make sure that the Sensing Area begins in a region of zero temperature 
or strain difference between the Reference and measurement files. (See 
Note under “Distributed Sensing Measurements” on page 48.) 

 

9 If Options > Display Options > Auto-Update Lower Graph is off 
(unchecked), click the blue recalculate button in the upper left of 
the lower graph. 

 

By default, the lower graph will be based on the data integrated by the left 
(yellow) cursor from the upper graph, as indicated by the yellow button to the 
left of the recalculate button. To see the data from the right (orange) cursor, click 
to the right of the recalculate button, then click the recalculate button again. 

 

10  Adjust the Gauge Length (in the Data Processing area of the main 
screen) as needed, according to the discussion below. The Gauge 
Length (see below) should always be smaller than the Sensing Range. 

 

11  Use the right pull-down menu to select Frequency or Time Domain, 
and the center pull-down menu to select the parameter displayed in the 
lower graph. 

 
Gauge Length 

The Rayleigh scatter profiles from the two data sets are compared in increments of 
fiber length  ∆z , as defined by the Gauge Length setting in the Data Processing 
area. The Gauge Length setting (in the Data Processing area) defines the width 
of the data block that will be used to cross correlate temporal shift and spectral shift. 
Thus the Gauge Length affects the spectral resolution and the signal-to-noise ratio 
of the measurement. There is, therefore, a relationship between the spectral 
resolution of the measurement and its accuracy in measuring the change in strain 
or temperature. Generally, the longer the segment used, the lower the shift 
measurement noise, meaning better temperature or strain accuracy and resolution. 

 

However, if the temporal or spectral shift varies appreciably over the Gauge Length 
width, the cross correlation peak may become spread out and difficult to detect, 
resulting in high noise levels. Thus in fiber sections where there is a strong 
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temperature or strain gradient, reducing the Gauge Length to a lower value may 
produce a more stable result. 

 
 
 

Note 

The Spatial Resolution filter (in the Data Processing 
area) does not apply to distributed sensing measurements. 
Instead, spatial resolution for distributed sensing 
measurements is controlled by the Gauge Length setting 
in the Data Processing area. To achieve the accuracies 
listed in the Specifications Sheet shipped with your 
instrument, set the Gauge Length to 2 cm. 

 
 
 

4 



54   Chapter 4 
Performing Measurements 

 

 

 
Distributed Sensing Examples 
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Figure 4-9. Control panel settings for a spectral shift measurement. Note that the 
Shift Reference is loaded (as indicated by the blue Details button for Trace E) 
but not displayed (the Active Traces check box is unchecked for Trace E). 

 
The temporal or spectral shifts are calculated for the area defined by the upper graph 
vertical cursor location and the Sensing Range setting in the Data Processing area. 
In Figure 4-9 above, the Sensing Range is set to 0.1 m, with the vertical cursor at 
3.3 m; thus the lower graph shows the data from 3.25 to 3.35 m. The data shows a 
spectral shift of approximately 5 GHz, measured with a 1 cm Gauge Length. (For 
further discussion, see “Gauge Length” on page 52.) 

 

To quantify the local spectral shifts due to a change in temperature or strain, the 
complex data sets are Fourier transformed back into the frequency domain. A vector 
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sum of these two spectra is then calculated to generate a polarization-independent 
spectrum associated with each fiber segment. 

 

An example of a small spectral shift for the data displayed in Figure 4-9 is shown 
in Figure 4-10 below. In this case the lower graph selection options were changed 
from Time Domain to Frequency Domain and from Spectral Shift to Return Loss, 
and the frequency axis scale was reduced to show close-up detail of the spectral 
signatures of Traces A (blue) and E (purple). Trace A appears as a similar version 
of Trace E, shifted in frequency by +5 GHz, consistent with the spectral shift result 
in Figure 4-9. 

 
 

4 
 
 
 
 
 
 
 
 
 
 

Figure 4-10. Close-up of a part of the spectrum for the yellow cursor in Figure 4-9. 
Trace A (blue) and Trace E (purple—the Shift Reference) exhibit similar 
features, but Trace A is shifted roughly 5 GHz to the right of Trace E. 

 
Figures 4-11 and 4-12 show temporal shift results for a different section of the FUT 
data shown in the upper window of Figure 4-9. The temporal shift displayed in Figure 
4-11 agrees well with the observed shift in the temporal return loss amplitude patterns 
for Traces A and E shown in Figure 4-12. 
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Figure 4-11.  Results of the cross correlation calculation for a section of the FUT in 
Figure 4-9, which shows roughly -0.8 fs Temporal Shift between perturbed 

and the Shift Reference, Trace E. 
Trace A 

 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 

Figure 4-12. The reflection Amplitude for the same temporal range as in Figure 4- 
11 for Trace A (blue) is shifted by roughly -0.8 fs to the left of the Shift 
Reference, Trace E (purple). 

 
The spectral shift and temporal shift for the same segment of fiber over which a 
constant strain is applied are shown in Figures 4-13 and 4-15. These plots illustrate 
that the temporal shift is a scaled integral of the spectral shift: where the spectral 
shift is zero, the temporal shift curve is flat, and where the spectral shift is large 
and steady, the temporal shift curve shows a steady upward slope. 
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Figure 4-13.  Spectral Shift result for a constant strain 
applied to a 32 mm length of fiber. 

 
 
 

 
 

Figure 4-14. Calculated Spectral Shift Quality result for the same source data and 
same length range as in Figure 4-9. 
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Figure 4-15.  Temporal shift results for the same source data 
and same length range as in Figure 4-13. 
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Chapter 5 
 
 
 

Data Processing and Display 
 
 

Once a measurement has been performed, the OBR control software provides many 
tools for manipulating and displaying measured data. Data stored in the local 
memory of the software can be used to display any of the parameters described under 
“Standard Parameter Calculations” on page 179. Data may be saved to a file in either 
a binary or spreadsheet format. Also included are powerful zoom and cursor features 
to enhance the usefulness of the display. 

Displaying Multiple Traces 5 
The OBR control software allows the user to store five data sets in active memory, 
or two sets in desktop analysis mode (i.e. when the OBR is off or disconnected). 
These memory locations are denoted Traces A through E. The most recent 
measurement is always stored in Trace A. 

 
 

Important New scans are automatically loaded into Trace A, 
overwriting any data there. To avoid losing data, see 

                “Moving Data in Local Memory” below, or “Saving and 
Loading Data Files” on page 62. 

 
 
Moving Data in Local Memory 

Data Trace A may be moved to Trace B by clicking the button labeled A->B under 
the Operations column of the Display Options area shown in Figure 5-1. Data may 
also be moved in a similar manner to Traces C, D or E. However, only two traces 
are available when operating in desktop analysis mode (i.e. when the OBR is off or 
disconnected). The original data in Trace A remains in A until new data is scanned 
by the instrument or loaded from the hard drive. 



60   Chapter 5 
Data Processing and Display 

 

 

 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 

Figure 5-1. The Display Options area in the main OBR software window. In the 
example, data has been loaded into Traces A and B, but only Trace A is being 
displayed, as indicated by the check boxes. 

5 Displaying Stored Data 
The control software can display any combination of Traces A through E 
simultaneously in the graph windows if the OBR is on and connected. By default 
the data in Trace A is plotted as a blue curve, Trace B is red, Trace C green, Trace 
D yellow, and Trace E pink. In the example in Figure 5-1 above: 

 

1 Trace A contains data, as indicated by the white name and checkbox 
and the blue Details buttons. Trace A is being graphed, as indicated by 
the filled-in checkbox. To clear this graph, click to clear the checkbox 
by Trace A. 

 

2 Trace B also contains data but is not being graphed. Clicking in the 
second checkbox adds Trace B to the graph window. 

 

3 Traces C has no data in it, as indicated by the grayed name and lack 
of a Details button. To overlay another plot, the user could move data 
into this trace using the A->C Operations button or by loading data 
from the hard drive. (See “Saving and Loading Data Files” on page 62.) 

 

4 If the headings for Traces C through E are not visible at all in the Data 
Management area, this indicates that the software is operating in 
“Desktop Analysis” mode. To make these traces available, the user 
would have to connect and turn on the OBR. 
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5 When data is loaded into local memory (by selecting File > Load Data 

File or by scanning) or moved within local memory (by clicking an 
Operations button), it is automatically displayed in the upper graph 
window. 

 
Trace Details 

Clicking a Details button in the Data Management area calls up the Measurement 
Details window shown in Figure 5-2. This window lists the type of measurement, 
the scan date, the reference date, the Gain setting, and whether the Frequency 
Domain Window was applied to the data. If the file has been loaded from the hard 
drive rather than scanned into Trace A, the file path will be listed. The user may 
type in a one-line Device Descriptor. The user may also use this dialog box to change 
the group index of one trace at a time. The Save and Close button is only available 
after new data has been entered into the Device Descriptor field or the Group Index 
field and after moving the cursor to a new location in the Measurement Details 
window. 

 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 

Figure 5-2. Measurement Details window. 
 

The user can also use the Group Index field in the lower right corner of the upper 
graph when the X-axis displays length, but this effects all of the data loaded into 
Traces A through E. (See “Adjusting Group Index” on page 75.) 
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When the upper graph X-axis displays length, the Group Index field shown below 
appears in the lower right corner. The user may enter the index appropriate for the 
device under test. 

 
Saving and Loading Data Files 

The OBR control software provides two options for saving data files. The first file 
type (.obr) is a binary data format that completely captures the measured data and 
stores it in a format that can be loaded back into the control software at a later time 
for further manipulation. The user may also save a smaller portion of the measured 
data, highlighted by one vertical cursor in the upper graph; these file names end in 
“_Segment.obr.” Binary segments may also be reloaded into the OBR software. 

 

The second file type is a text file in a tab-delimited spreadsheet format. Text files 
contain the data displayed in the upper (_Upper.txt) or lower (_Lower.txt) graphs 
at the time of saving. Data saved in the spreadsheet format cannot be loaded back 
into the control software. 

 

It is highly recommended that the binary data format be chosen over the spreadsheet 
format for data archives. The binary format stores all measurement information, 
whereas the spreadsheet format stores only a subset of the measured information. 
Furthermore, a spreadsheet file can always be generated from a binary file at a later 
date, but a binary file cannot be generated from a spreadsheet file. Finally, other 
data analysis software packages available from Luna Technologies accept only the 
binary data format produced by the OBR control software. 

 
Saving Data 

Depending on which options are set in the File > Select File Options dialog box 
(Figure 5-3), up to four files may also be saved each time File > Save Data Files 
is selected. As an example, if the user saves the data as Your_Filename, the four 
files would be: 

 

1 Your_Filename.obr is the complete binary file, which can be reloaded 
into the OBR software. 

 

2 Your_Filename_Segment.obr is a subset of the data displayed in the 
upper graph. This subset is the region integrated by the vertical cursor 
in the upper graph and displayed in the lower graph. These files may 
also be reloaded into the OBR software. 
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3 Your_Filename_Upper.txt is a spreadsheet file of all of the upper graph 

parameters selected in the File > Select File Options dialog box. 
 

4 Your_Filename_Lower.txt is a spreadsheet file of all of the lower graph 
parameters selected in the File > Select File Options dialog box. 

 
Important When File > Save Data Files is selected, the OBR 

software will overwrite any files with the filename specified, 
without warning the user. 

 
 

Make sure to update the lower graph, following instructions on page 67, as the 
segment saved will be the one displayed. 

 

Spreadsheet files cannot be reloaded into the OBR software. Therefore, a warning 
message will be displayed the first time the user saves data with the Save Full 
Measurement File box unchecked. This warning will not be displayed again until 
the user restarts the software. 
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To specify options for saving data 

 

1 Select File > Select File Options 
 

The Select File Options dialog box shown below opens. 
 

 
 
 
 
 
 
 
 
 
 
 
 
 

5 
 
 
 
 
 
 
 

Figure 5-3. Select Data File Options dialog box. WIth the setting shown, the full 
binary file and the lower graph spreadsheet file for two parameters will be saved. 

 
2 A binary file of the complete data will only be saved if the Save Full 

Measurement File box is checked. If Save Lower Graph Segment is 
checked, the software will also save a binary file of the data displayed 
in the lower graph. All of the data in that segment will be saved, not 
just the parameter displayed. This allows the user to save and manipulate 
smaller binary files. These Lower Graph Segment binary files may also 
be reloaded into the software. 
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3 To set the software to save spreadsheet text files whenever File > Save 

Data Files is selected, check the appropriate box(es) under Spreadsheet 
File Options. 

 
 

Important Spreadsheet files, of type “.txt,” cannot be reloaded into 

                 the OBR software. 
 
 

4 Click OK. 
 

The control software saves the selected options. 
 

To save data 
 

1 Update the lower graph as desired, following instructions on page 67. 
 

2 Select File > Save Data Files. 
 

A dialog box appears. 
 

3 Select the file destination and enter a file name. The file extension(s) 
will be added automatically according to the configuration set using File 
> Select File Options, as described above. 

 

4 Click Save. 
 

Loading Saved Data 
Only data saved in the binary format (.obr) can be loaded into the control software. 

 
To load a saved data file 

 

1 Select File > Load Data File from the pull-down menu. 
 

2 In the dialog box that appears, select the target memory location (Trace 
A-E) from the list. The LED for the selected Trace will be bright green. 
Hit enter or click Continue. 

 

3 In the next dialog box that appears, choose the desired file and click 
Open. 

 

The loaded data will appear in the upper graph area. To control the contents of 
the lower graph, see “Updating Lower Graph” on page 67. 
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Spreadsheet File Data 

The header of a spreadsheet file gives the following information: 
 

• Date and time data was acquired 
• Reference date and time 
• Device descriptor (The user may enter a descriptor after clicking 

the Details button in the Data Management area.) 
• Measurement Type 
• Group index 
• Gain 
• Spatial resolution 
• Frequency Domain Window status 
• Number of data points 
• Decimation 

 

Only the units and parameters selected (checked) in the File > Select File Options 
dialog box will be contained in a spreadsheet file. The parameter name and the units 
are given at the top of each spreadsheet column. 

 
Displaying Two Parameters in Lower Graph 

 

The user may display two parameters in the lower graph area by clicking on Options 
> Lower Graph > Two Plots. A check mark by this sub-menu item means Two 
Plots have been enabled. The lower graph will then display two parameter selection 
pull-down menus in the Title Bar, as shown in Figure 5-4 below. Note that there 
are also two X-axes, one for each parameter. Only the data in Trace A may be 
displayed in two plots. 
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Figure 5-4. The lower graph area can display two parameters at a time if Options > 
Lower Graph > Two Plots is enabled (checked). 

Manipulating Plots 5 
The OBR control software gives the user great control over the content and 
appearance of the data plots. This section covers parameter selection, 
zooming, scaling, and cursors. 

 
Updating Lower Graph 

The data in the upper graph automatically updates when data is scanned (into 
Trace A), moved, or loaded from memory. However, the lower graph will not 
update automatically unless Options > Display Options > Auto-Update Lower 
Graph is checked. As mentioned earlier, this is often left off (unchecked) to 
speed up scanning time. The lower graph will automatically update after a 
Continuous Spot Scan, provided the yellow vertical cursor is located within 
the Spot Scan region. (See “Spot Scan Mode” on page 44.) 

 
To update the lower graph 

 

1 Turn on the vertical cursors in the upper graph by clicking . 
 

2 By default, the vertical cursors are attached to Trace A. To attach the 
cursors to another trace, select a different trace from the pull-down menu 
in the Title Bar . 

3 Adjust the cursor locations in the upper graph as desired by selecting 
the cross-hair          tool, then clicking and dragging a cursor. 
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4 If Options > Cursors > Show Integration Area is on (checked), the 

regions of the graph around the vertical cursors are highlighted. This 
highlighted segment is the only data that will appear in the lower graph. 
Lower graphs of all traces will be based on this same segment of the 
X-axis. 

 

The user may change the width of the highlighted area (and lower graph X-axis) 
by entering a new Integration Width in the Data Processing area of the main 
window. 

 

Note: When Options > Sensing Enabled is on or checked (if purchased), the 
fields in the Data Processing area change. To control the width of the 
highlighted area in Sensing Mode, change the Sensing Range in the Data 
Processing area. The menu item for activating these highlighted areas around 
the vertical cursors becomes Options > Cursors > Show Sensing Area. 

 

5 Click the blue recalculate button in the upper left of the upper 
graph. 

 

By default, the lower graph will be based on the data highlighted around the 
left (yellow) cursor from the upper graph, as indicated by the yellow button to 
the left of the recalculate button. 

 

6 To see the data from the right (orange) cursor, click to the right of the 
recalculate button; the button will turn from gray to orange: 

. Then hit the recalculate button again. 
 

 
Note The recalculate button only appears in the top left 

of the upper graph when the vertical cursors are on in the 
                upper graph. 

 
 

7 To change the parameter displayed in the lower graph, follow the next 
set of instructions. 

 
Parameter Selection 

The user can control the content of the two graphs in the main window from a list 
of parameters in the Title Bars. By default, the upper graph displays amplitude (in 
dB/mm), but it can also display linear amplitude, polarization states, or amplitude 
(dB). The lower graph can also display these same parameters. 
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To change the content of a graph window 

 

1 Click on the Title Bar of the graph. A drop-down list of the available 
plot parameters appears. 

 
 
 
 
 
 
 
 
 
 
 
 
 
 

5 
Figure 5-5. Upper graph window showing the Title Bar pulled down 

for parameter selection. 
 

2 Click on the desired parameter from the list. 
 

The content of the graph changes, as do the title and the axis labels (if necessary). 
 

Scaling Plot Axes 
The OBR control software provides several ways for adjusting the scaling of the 
graph windows. 

 
Autoscaling 

 

Autoscaling refers to the automatic adjustment of plot axes so that all of the data 
fits in the graph window. 

 

By default, the graph windows will autoscale the Y-axis when new data is scanned 
or loaded from memory. To toggle autoscaling on and off for either graph area, select 
Options > Display Options > Autoscale Y Axes (Both Graphs) or Autoscale X 
Axis (Upper or Lower Graph). A check mark next to these selections indicates 
that autoscaling is turned on. Note that the lower graph X-axis scale is based on the 
highlighted section of a vertical cursor in the upper graph. 
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At other times, the user may rescale each plot axis independently by using the 
autoscale buttons for the X-axis and the Y-axis , located in the lower left 
corner of each graph window. 

 
Manual scaling 

 

The plot axes may be scaled manually by double-clicking on either the lowest or 
highest value labeled on the axis and typing in a new value. To accept the new value, 
press enter or click anywhere in the screen. 

 

Note that by using this method it is possible to flip the graph so that increasing values 
on the X-axis run from right to left, and increasing values on the Y-axis run from 
top to bottom. Typically this is to be avoided, so be sure to enter appropriate values. 

 
Using zoom tools 

 

There are six available zoom tools, which are accessible by clicking the zoom menu 
button located in the lower left corner of each graph window. 

 

When this button is clicked, a pop-up window containing the six zoom tools opens: 
 
 
 
 
 
 
 
 
 
 
 

Figure 5-6. Zoom tools pop-up menu. A blue border surrounds the selected tool. 
 

The zoom window tool: 
This tool allows the user to zoom in on a rectangular region of the graph window. 

To use this tool, first select it from the zoom menu button. Then click in the graph 
window and hold the mouse button to define one corner of the rectangular region. 
Then drag the mouse cursor and note that a dotted box appears with corners defined 
by the original click position and the current mouse cursor position. Drag the box 
around the desired region of the graph window and release the mouse button. Both 
the X- and Y-axis scales adjust so that the selected region fills the entire graph 
window. 
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The X-axis zoom tool: 

 

This tool allows the user to zoom in on a region of the X-axis only, without adjusting 
the Y-axis scale. This is the default tool active in each graph when the software is 
opened. 

 

To use this tool, first select it from the zoom menu button. Then click in the graph 
window and hold the mouse button to define one edge of the desired X-axis region. 
Drag the mouse cursor to the other edge of the desired region and note that a fixed 
vertical dotted line appears where the original click occurred, and another follows 
the mouse cursor. When the cursor is positioned at the other edge of the desired 
region, release the mouse button. The X-axis scale adjusts to show only the selected 
region. 

 
The Y-axis zoom tool: 

 

This tool allows the user to zoom in on a region of the Y-axis only, without adjusting 
the X-axis scale. 

 

To use this tool, first select it from the zoom menu button. Then click in the graph 
window and hold the mouse button to define one edge of the desired Y-axis region. 
Drag the mouse cursor to the other edge of the desired region, and note that a fixed 
horizontal dotted line appears where the original click occurred, and another follows 
the mouse cursor. When the cursor is positioned at the other edge of the desired 
region, release the mouse button. The Y-axis scale adjusts to show only the selected 
region. 

 
The return to full zoom tool: 

 

Selecting this button from the zoom menu returns the graph to the full scale of all 
data. 

 
The zoom in tool: 

 

This tool allows the user to zoom in (magnify) the graph from the point where the 
cursor is clicked. 

 

To use this tool, first select it from the zoom menu button. Then click once to magnify 
once; or click, hold and release to magnify several times at the cursor location. 

 
The zoom out tool: 

 

This tool allows the user to zoom out from the point where the cursor is clicked. 
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To use this tool, first select it from the zoom menu button. Then click once to zoom 
out once; or click, hold and release to zoom out several times at the cursor location. 

 
Using Cursors, Legends and Other Buttons 

 
Cursors 

 

The OBR software offers three types of cursors. By default, vertical cursors and twin 
locked cursors appear at 10% and 90% of the X-axis range. Horizontal cursors appear 
at 10% and 90% of the Y-axis range. To move the cursors, select the cross-hair        , 
then click, drag, and release the cursor. 

 

The cursors are attached to Trace A by default. To attach cursors to a different trace, 
select that trace from the  pull-down menu. 
When any of the cursors are on, a legend appears in the upper right corner giving 
the exact location of the cursors in the units currently selected. The legend also 
indicates the distance between the two cursors (dX for vertical cursors, dY for 
horizontal cursors, and dX and dY for twin locked cursors). 

 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 

Figure 5-7. Upper graph showing the amplitude data with vertical cursors appearing 
at the default location. The legend at the upper right gives the precise location 
of the cursors and the distance between them (dX in this case). The legend also 
displays the return loss at each cursor and the differential loss between the two 
cursors. Note that the data points integrated to calculate differential loss are 
highlighted in contrasting colors 
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Vertical cursors: 

 

Clicking this button toggles two vertical cursors on or off. Note that when these 
cursors are on, the data points integrated to calculate return loss and differential loss 
are highlighted in contrasting colors, and the results are displayed in the upper right 
legend. This highlighted region may be turned off by unchecking Options > Cursors 
> Show Integration Area. [Or, in optional Sensing Mode (page 48), Options > 
Cursors > Show Sensing Area.] This highlighted or integrated region determines 
the X-axis of the lower graph. 

 

The number of points integrated may be increased (or decreased) by entering a larger 
(or smaller) number in the Integration Width field in the Data Processing area of 
the main window. [In Sensing Mode, the width of the integration area is controlled 
by the Sensing Range field in the Data Processing area.] 

 

For an explanation of how differential loss is calculated, see “Return Loss and 
Differential Loss” on page 178. 

 

As mentioned above, select the cross-hair tool to move cursors. 
 

Horizontal cursors: 
 

Clicking this button toggles two horizontal cursors on or off. 
 

Twin locked cursors: 
 

Clicking this button toggles twin locked cursors on and off. Regardless of where 
these cursors are dragged, they will intersect the graph at a data point on the first 
trace displayed. So to use twin locked cursors on Trace C, for example, deselect 
Traces A and B in the checkboxes in the Data Management area. 

 
Bring cursors to center: 

 

Clicking this button brings the active cursors into the viewed portion of the graph. 
 

Move cursors to peak: 
 

Clicking this button moves the two vertical cursors to the peaks of the regions 
highlighted by each cursor. Simply click on this button when the vertical cursors 
are on. 
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Spot Scan Cursor: 
 

Clicking this button turns on the spot scan cursor. 
 

Select the cross-hair tool to move the spot scan cursor to a region of the data 
where you desire a spot scan. See “Spot Scan Mode” on page 44 for more details. 

 
Spot Scan Cursor Unlocked            or Locked            Toggle Button: 

 

Clicking the first button (showing the unlocked icon) locks the spot scan cursor to 
the active vertical cursor. The button icon with then change to a closed lock: 

 

Clicking this button again will unlock the spot scan cursor from the active cursor. 
The icon changes to display the current state of the cursors. 

 

See “To perform continuous spot-scan measurements” on page 46 for more details. 

5 Save graph as image file: 
Clicking this button in the upper (or lower) graph area prompts the user to save the 
current upper (or lower) graph as a .jpg image file. 

 
The pan tool: 

 

This tool lets the user pan around the data in a graph window. To use this tool, first 
select it from the button menu, then click on the graph and drag the cursor. 

 
The recalculate buttons: 

 

See “Updating Lower Graph” on page 67 
 

Legend 
 

A plot legend can be displayed by clicking the          button in the graph window. 
 

Changing graph style and color 
 

The user may change the color or line style of an individual graph by first turning 
on the legend. Next, click inside the legend to call up a menu which allows the user 
to select line color, style, and width. 
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Adjusting Group Index 

When the upper graph X-axis displays length, the Group Index field shown below 
appears in the lower right corner. The user may enter the index appropriate for the 
device under test. 

 
 
 
 

Figure 5-8. The Group Index field, which appears 
to the lower right of the upper graph. 

 
 
 

Important 

Changing the group index in the box shown above 
changes the group index for all the data loaded into 
memory, Traces A through E. In order to change the 
group index of only one trace, click the Details button of 
that trace and change the group index in the details dialog 
box. (see “Trace Details” on page 61) 5 

The group index scales the X-axis length values according to 
 

z =  ----c---- t  , 2ng 
 

where z is the spatial dimension (X-axis) of the device under test, c is the speed of 
light in a vacuum, t is time, and ng  is the group index of refraction of the device 
under test. 

 
Data Decimation 

Selecting Options > Data Decimation (Upper Graph) > Specify Level calls up 
the dialog box shown below (Figure 5-9). Here the user can select the number of 
data points displayed in the upper graph, up to 524,288 points. 
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Figure 5-9. The Specify Decimation Level dialog box 
allows the user to set the number of data points displayed. 

 
Decimation makes the graphs much less “noisy” and quicker to display. Note that 
files saved in the binary (.obr) format contain the raw data, undecimated. Text files 
(.txt) may be reduced in size by selecting a smaller number of points to display before 
saving. The upper section of a text file notes the data decimation factor. 

 
Adjusting Spatial Resolution 

The user may change the Spatial Resolution value in the Data Processing are of 
the main screen. If the Spatial Resolution is set below the minimum achievable 
resolution, the software will coerce it to the actual minimum value and thus the data 
is unfiltered. Setting the control above this value will cause the data to be box-car 
filtered with the user-specified bin size equal to the Spatial Resolution. For an 
explanation of how this filter is calculated, see “Spatial Resolution Calculations” 
on page 178. 

 
Printing Graphs 

The user may print both graphs currently displayed by selecting File > Print 
Datasheet. The control software prints to any printer defined as the default 
Microsoft® Windows® printer. The graphs will print with the current filter and axis 
settings. The legends and cursors will not appear in the printout. 
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Chapter 6 
 
 
 

LightPath Analysis Software Guide 
 
 

LightPath Analysis (LPA) software may be purchased for use with the OBR. This 
software can quickly and easily verify the performance characteristics of fiber optic 
components, modules and cable assemblies for quality control purposes. LightPath 
Analysis software compares devices to tolerance values in either a “golden” 
Reference Trace or a Parameter Configuration File. 

 

The user begins by adjusting the tolerance values in the Parameter Configuration 
File or in the golden Reference Trace for future pass/fail comparisons. Then the 
software can perform automated testing, comparing the device or component under 
test to the user-created standard. 

The software identifies three key features for comparison: Peaks, Drops, and Fibers 6 
(fiber segments). Other software features include: 

 

• Automatic pass/fail visualization 
• Return loss qualification vs. length 
• Insertion loss qualification vs. length 
• Automatic event mapping 

 

Each detected Feature (Peak, Drop, or Fiber) is compared to the Parameter 
Configuration File or to the Reference Trace, and marked as passing or failing 
based on their similarity to the tolerated values. The entire trace is accepted as 
passing if all expected features are present and fall within the desired tolerances for 
return loss, insertion loss, and location. 

 
LightPath Analysis Tutorial 

This tutorial walks the user through adjusting the default Parameter Configuration 
File and creating a Reference Trace using Luna Technology sample files. Later 
sections describe how to create these files from your own devices, and how to use 
these standards to pass or fail test data. Many of the LPA commands and tools also 
exist in the OBR software and are described in Chapter 3, beginning on page 17. 
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If your system did not come with the LightPath Analysis software preinstalled, 
contact Luna Innovations Incorporated for installation files and instructions. Make 
sure there is no other software running, including the OBR software. Start the 

software from the Windows® Start menu, or by clicking the desktop icon . A 
splash screen displays the software name, version, and date until the main screen 
(Figure 6-1) loads. 

 

The LightPath Analysis software comes installed with a default parameter file 
(lpa_default_params.ini) and the three example data files (device1.obr, device2.obr, 
and device3.obr) that are used in this tutorial. These files are all located in the same 
directory as the LightPath program file (LPA.exe). Normally, this will be the folder 
C:\Documents and Settings\All Users\Application Data\Luna 
Technologies\LightPath Analysis v#.#. 

 
 
 
 
 

6 
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Figure 6-1. LightPath Analysis software main screen. 
 

Adjusting a Parameter Configuration File 
From the main menu, select Setup > File Configuration. The Specify File Paths 
window appears, as shown in Figure 6-2, allowing the user to set the Reference 
Trace Folder, Parameter Configuration File, and Base Folder for Output Data. 
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Figure 6-2. Selecting Setup > File Configuration from the main window 
calls up the Specify File Paths window. 

 
New data traces can be compared either to a Reference Trace or to a set of default 
parameters held in a Parameter Configuration File. By default, the software is 
configured to use the parameter configuration file lpa_default_params.ini, located 
in the folder where the software was installed (C:\Documents and Settings\All 
Users\Application Data\Luna Technologies\LightPath Analysis v#.#). 

 

The Compare to Reference Trace option is unchecked by default, (meaning the 
data will be compared to the Parameter Configuration File), and no Reference 
Trace Folder is specified. 

 

The Base Folder for Output Files is set to C:\LPA_Data. All saved traces will be 
saved into subfolders located in this folder. Usually, a different Base Folder will 
be specified for each part number being tested, and the results for each individual 
part tested will be saved into a subfolder within that Base Folder. For instructions, 
see “Saving LightPath Files” on page 86. 

 

In the future, you can use the browse button to find other files and folders. 
But for this tutorial, press Cancel to retain the default settings. 

 
Loading a File 

 

One would normally begin setting up the LPA software by clicking Scan in the 
System Control area of the main screen, and then adjusting tolerance levels in this 
file to create a Reference Trace. But this tutorial will use a pre-scanned file to teach 
how to create a Reference Trace. 
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Select File > Load Data File from the menu; browse and open the file device1.obr, 
located in C:\Documents and Settings\All Users\Application Data\Luna 
Technologies\LightPath Analysis v#.#. The software will display a Processing dialog 
while generating the LightPath data. This may take several seconds. 
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Figure 6-3. Data from the file device1.obr is being compared 
to the Parameter Configuration File lpa_default_params.ini. 

 
Data Display 

 

When the loading process has completed, the software displays the Amplitude plot 
of the data in the upper graph (Figure 6-3). The lower graph shows a simplification 
of the trace data, broken into the Peak, Drop, and Fiber segments that were detected 
during processing. 

 

Each feature type is represented by a different shape in the lower graph. Fiber 
segments are represented by two horizontal lines, indicating the input and output 
level at the front and rear end of the segment. Peaks and Drops also have horizontal 
lines at the input and output levels, with a vertical line at the midpoint of the segment 
representing the extent of the peak or drop. Peaks are depicted with a vertical line 
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going from the input level to the return loss. Drops are depicted with a vertical line 
going from a floor of -115 dB to the input level. 

 

The color of each feature indicates whether it passed or failed, compared to the values 
in the Reference Trace or Parameter Configuration File. Peaks and Fiber 
segments are shown as green (pass) or red (fail). Drop segments are shown as blue 
(pass) or purple (fail), to make them stand out visually from the peaks. 

 

An indicator in the top right of the lower graph shows whether all segments have 
passed their individual tolerances                         , or if some failing segments were 
found in the trace                      

 
Changing Data Processing Parameters and Tolerances 

 

Several parameters affect the feature detection algorithm—i.e. how the software 
passes or fails a feature in the data. The user may adjust the parameters so that all 
desired features for a particular device are detected, and random noise disregarded. 

 

In this comparison of device1.obr data to the default Parameter Configuration File, 
notice that the two peaks near the 2.0 m point are combined into a single feature in 
the lower graph. The processing parameters in the Parameter Configuration File 
can be adjusted so that these are detected as two distinct peaks. 

 

Select Setup > Data Processing Parameters from the main menu to show the 
Parameter Specifications window (Figure 6-4). This displays the Parameters used 
to delineate trace segments and the Tolerances used to mark them as passing or 
failing. 
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Figure 6-4. In the Parameter Specifications window, the user can adjust the 6 
parameters and general tolerances used by the Parameter Configuration File 
or the Reference Trace to separate and to pass or fail features. 

 
The name of the current Parameter Configuration File is shown in the 
Configuration File Path box at the top of the window. 

 

Press the question button          next to any parameter or tolerance setting to display 
a graphic explaining the how each value affects the processing. The data processing 
parameters are discussed in more detail under “Description of Processing Parameters 
and Tolerances” on page 97. 

 

In the Peak Processing Parameters section on the left, change the value of the 
Feature Extract Length (m) from 0.100 to 0.050. This will cause the algorithm to 
generate features with smaller widths, and should cause the two peaks at 2.0 meters 
to generate two features instead of being combined into a single peak in the lower 
graph. (For further explanation, see “Feature Extract Length (m)” on page 100.) 

 

To see how this change affected the lower graph, press the Apply button 
at the bottom of the window. The current trace will be reprocessed with the new 
Feature Extract Length, and any new traces that are scanned or loaded will be 
compared to the new value. However, if a new reference or parameter configuration 
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file is loaded, or if the software is closed, the unsaved values will be lost. This may 
be useful for some situations (such as this tutorial, or to briefly view the affect of 
a change), but has the risk of losing tolerance or processing parameter values. 

 

Thus in general, the user would click the Save                button in the Parameter 
Specifications window after making parameter or tolerance changes. This calls up 
a dialog box allowing the user to select an existing Parameter Configuration File 
or to name a new one. 

 
Why a Feature Failed 

 

The Trace Comparison window displays a detailed comparison of the detected 
features and the tolerance values used to evaluate their pass/fail status. To access 
this window, press the Compare button at the lower left in the main window. Note 
that the graph shown is the same as the lower graph in the main window. 
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Figure 6-5. The user may view the Trace Comparison window by clicking 
the Compare button in the lower left of the main window. 

 
The trace currently loaded in the LPA software is always being compared to a 
standard: either a Parameter Configuration File (as in this case), or a Reference 
Trace. The name of this standard for comparison—lpa_default_params.ini—is 
shown in the Reference Trace File Folder area at the upper left. Because the 
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software is using a Parameter Configuration File for comparisons, there is no data 
in the Reference Trace Event Listing grid. (Once a Reference Trace is specified, 
this grid will contain data, as shown in Figure 6-10 on page 92.) 

 

The Trace File Folder area shows the location of the trace being evaluated, in this 
case the currently loaded data held in a temporary directory. The features detected 
in the current trace are shown in the Trace Event Listing grid. This grid shows the 
Type, Return Loss, Insertion Loss, Location, and Result (Pass or Fail) for each 
feature. (Note that all fiber segments are listed with a return loss of 0 dB.) 

 

The Feature Tolerance Detail area at the left displays the tolerated minimum and 
maximum loss and location values for the feature highlighted in the Trace Event 
Listing grid. If a feature fails any given tolerance setting, that setting will show in 
red in the Feature Tolerance Detail area. You may see the Feature Tolerance 
Details of a different feature by clicking on it in the Trace Event Listing grid. 

 

The highlighted feature in the Trace Event Listing grid is bold in the Feature 
Highlight graph. You can also highlight a specific feature in the graph by toggling 
on (clicking) the vertical cursor control and then the cross-hair tool. Once 
the cursor is a cross-hair, you can click and drag over the graph to highlight each 
feature. The cursor will sit at the center or splice location of the selected feature. 

 

Select several different features, using either the graph cursor or the Trace Event 
Listing grid, and view the Feature Tolerance Detail values to understand why each 
feature passed or failed. 

 

Note the sign convention for Loss (insertion loss): a drop from the input level to 
the output level is reported as a positive value. A gain is reported as a negative value, 
or a “negative loss.” The fiber segments in Features 11, 13, and 15 all have gains 
and report negative values. 

 

For the example file device1.obr, the peaks in Features 4, 8, and 10 have return 
losses greater than the maximum value of -65 dB. Features 6 and 10 have an 
insertion loss greater than the maximum of 2.0 dB. The fiber segments in Features 
11 and 13 have insertion losses less than the minimum of -0.1 dB. 

 

Press Close to exit the Trace Comparison window. Next we will show how to 
change the Parameter Configuration File so that these failed features will pass. 

 
Editing General Tolerances 

Select Setup > Data Processing Parameters. This returns you to the Parameter 
Specifications window (Figure 6-4). In the General Tolerances area, change the 
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(RL) Peak Tolerance (dB) value from -65 to -50. This will allow the peaks in 
Features 4 and 8 to pass. 

 

You may click Apply to see that these peaks are now shown in green, for passing. 
Then return to the Parameter Specifications window by selecting Setup > Data 
Processing Parameters again. 

 

Change the (IL) Splice Loss Tolerance (dB) value from 0.1 to 0.6. This will allow 
the Features 11 and 13 (fibers) to pass. (Splice Loss Tolerance determines both 
the maximum and minimum insertion loss values for fiber segments. Min Loss will 
now have a value of -0.6, so Features 11 and 13 will no longer have loss values 
less than the minimum.) 

 

Click Apply to see that these drops are now shown in green (passing) rather than 
red (failing). Features 6 and 10 should now be the only failing features. 

 
Saving LightPath Files 

When you first scan or load a trace, the LightPath data files are saved to a temporary 
folder. The files can be saved to a permanent folder to be viewed later or to create 

6 a reference trace.
 

Press the Save LightPath Files button—near the bottom left of the main window— 
to save the current trace's data. The Enter Device Descriptor dialog appears 
(Figure 6-6), allowing the user to enter a short description of the device. This name 
is used to create a subdirectory in the folder that was specified as the Base Folder 
for Output Files in the Specify File Paths window (Figure 6-2 on page 80). 

 

Enter the name “golden” to save the data to the folder C:\LPA_Data\golden, and 
press OK. 

 

 
 
 
 
 
 
 
 
 
 
 
 

Figure 6-6. Clicking the Save button in the main window calls up 
the Device Descriptor window. 
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Changing from a Configuration File to a Reference File 

Now that we have made changes to the tolerances in a data file, we can save that 
file as the new Reference. Select Setup > File Configuration from the main menu 
to view the Specify File Paths window (Figure 6-2). Click the Compare to 
Reference Trace checkbox. Click the Reference Trace Folder browse button and 
select the folder C:\LPA_Data\golden from the Specify Folder Containing 
Reference Trace window (Figure 6-7). Note that you are selecting the folder itself, 
and not a specific file in the folder. 
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Figure 6-7. The Specify Folder Containing Reference Trace window appears 
after clicking the browse button in the Specify File Paths window. 

 
Use the Select Cur Dir button to select the folder once you have navigated to it. 
This returns you to the Specify File Paths window. Uncheck the Use General 
Tolerances checkbox. 

 

A Reference Trace contains both general tolerance values (like the ones in the 
Parameter Configuration File) and tolerances that are specific to each individual 
feature. This box can be checked to use the General Tolerances instead of the 
feature-specific tolerances. (It is usually desirable to use the feature-specific 
tolerances with a Reference Trace, but comparing to general tolerances is sometimes 
useful.) 
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Click OK to accept the new configuration. The current trace will be reprocessed. 
No changes will be seen at this time, however, because the trace is being compared 
to itself. 

 
Editing Feature-Specific Tolerances 

The main advantage of using a Reference Trace instead of General Tolerance 
values is that each individual feature can have its own tolerance range. To assign 
these values, select Setup > Feature-Specific Tolerance from the main menu, which 
opens the Tolerance Specification window (Figure 6-8). 
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Figure 6-8. Selecting Setup > Feature-Specific Tolerance from the main menu 
calls up the Tolerance Specification window above. 

 
This window shows a detailed view of each of the segments found in the Reference 
Trace. The Feature Listing grid shows the actual Return Loss, Loss (i.e. insertion 
loss) and Location for each feature. These Target values are also shown in the area 
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at the lower right, along with the tolerated minima and maxima. Note that the upper 
of the three regions is blank for fiber sections, which have a Return Loss of zero. 

 

The Min and Max values to the sides of the Targets represent the range of values 
that will be considered passing for this particular feature. Any Min or Max values 
that have been exceeded will appear in red. 

 

In our example, all of the Min and Max values are currently based on the General 
Tolerances used when last evaluating the trace. Press the View Summary button 
to view all of the feature details in one window, the Feature Tolerance Summary 
(Figure 6-9). 
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Figure 6-9. The user may view this Tolerance Summary by clicking 
the View Summary button in the Tolerance Specifications window (Figure 6-8). 

 
Notice that the Return Loss Maximum for each peak is set to -50, the value you 
set as the Peak Tolerance for the Parameter Configuration File, using in the 
Parameter Specifications window shown in Figure 6-4 on page 83. However, we 
left the Drop Tolerance at -68 in the Parameter Specifications window, as 
confirmed in the Feature Tolerance Summary above. 

 

Click the Close button to exit the Feature Tolerance Summary window. 
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The minimum and maximum values should be set so that all segments of the 
Reference Trace pass, and with a wide enough range so that all segments of any 
good trace would be expected to pass. 

 

The pull-down menu in the Tolerance Specification window graph (Figure 6-8) can 
be used to change the display. The Feature Highlight option shows all of the feature 
segments. The High Resolution Data option shows the amplitude plot for whichever 
feature was highlighted in the Feature Listing grid. 

 

Note that no amplitude data is stored for fiber segments. The message No Data to 
Display will be shown if a fiber segment is selected with the High Resolution Data 
graph active. 

 

Use the pull-down menu to change the graph back to Feature Highlight. The feature 
data is shown, scaled to the actual width of that feature. Press the X-axis 
autoscale button to show the entire feature graph. 

 

The minimum and maximum values can be set numerically from the Tolerance 
Specification window. The Use +/- Tolerance checkboxes change the Min and Max 
value for a particular item (Return Loss, Insertion Loss, or Location) based on 
the Target value and a Tolerance value. 

 

Select Feature 6 and click the Use +/- Tolerance checkbox to the left of the Min 
Loss (dB) control. The Min Loss (dB) and Max Loss (dB) controls are now disabled 
and their values have been changed 2 dB below and above the Loss Target (dB) 
value. 

 

The Tolerance (dB) control is now enabled. Change its value to 1.0 and observe 
that the Min Loss (dB) and Max Loss (dB) values are changed to be 1.0 dB below 
and above the Loss Target (dB) value. 

 
 

Hint 
If you wanted to change the Tolerance ranges for 
Loss another Feature to +/- 1.0 from the Loss 
Target, simply highlight that Feature in the Feature 
Listing while the +/- Tolerance checkbox is still 
checked. 

 

 
Uncheck the Use +/- Tolerance checkbox. The Min Loss (dB) and Max Loss (dB) 
controls are now enabled again. The values are still set to 1 dB above and below 
the target value, but their values can now be changed if desired. 
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The Apply General Tolerances button in the lower left region sets all minimum 
and maximum values to match the general tolerances held in the reference trace file. 
Press the Apply General Tolerances button and observe that the Min Loss (dB) 
and Max Loss (dB) values have returned to their original values. (For details on 
view and modifying the General Tolerances of the Reference Trace, see “Editing 
a Reference Trace: Processing Parameters and General Tolerances” on page 94.) 

 

Make the two failing features pass by changing the Max Loss (dB) value for Feature 
6 to 3.0, and the Max Loss (dB) value for Feature 10 to 7.0. Click Save. 

 

The new tolerance values are written to the files in the golden folder, and the current 
trace is reprocessed using these new values. Since the trace data is still the same as 
that in the golden Reference Trace, the lower graph should show all features as 
passing. 

 
Comparing a New Trace to the Reference 

After loading and modifying a Reference Trace, you would generally proceed to 
scanning data, which would automatically be compared to the Reference Trace. But 
for this tutorial, we will load another *.obr file similar to the one used above to create 
the Reference Trace. 

 

Select File > Load Data File from the menu; browse and open the file device2.obr, 
located in C:\Documents and Settings\All Users\Application Data\Luna 
Technologies\LightPath Analysis v#.#. The new trace should be similar to the first, 
but may differ slightly. If you set the Loss tolerances as directed above, all the 
features should be marked as passing. 

 
Viewing Segment Details 

 

Press the Compare button to view the Trace Comparison window (Figure 6-10). 
Note that because you have loaded a Reference Trace Event Listing now contains 
data. (Earlier in the tutorial we were comparing to a Parameter Configuration File, 
so this grid was empty.) The Reference Trace File Folder field in the upper left 
shows the current Reference Trace (C:\LPA_Data\golden). 
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Figure 6-10. The Trace Comparison window, with the graph pull-down menu set to 
High Resolution Data. The Reference data shows in blue, and the loaded 
trace shows in red. 

 
Select several different features using either the Event Listing grids or the vertical 
cursors with the cross-hair tool. Use the pull-down menu to select show the High 
Resolution Data, which will compare two features with more detail. The Reference 
data is shown in blue, and the loaded trace in red. View the High-Resolution Data 
for all the peak and drop features. (Remember that no High-Resolution Data is 
saved for fiber segments.) 

 

Press the Close button at the lower left to exit the Trace Comparison window. In 
the main window, click the Save LightPath Files button in the lower left. Enter 
device2 as the descriptor and then click OK. This data will be saved to the folder 
C:\LPA_Data\device2. This data can be used later as a Reference Trace, or can be 
used as documentation of how the particular device compared to the Reference 
Trace. 
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Comparing a Failing Trace to the Reference 

Load the file device3.obr (File > Load Data File). This file is similar to device1.obr 
but shows an extra peak around 0.54 meters. Press the Compare button to view the 
Trace Comparison window. 

 

The Reference Trace Event Listing and Trace Event Listing entries are ordered 
so that matching features are aligned. The extra peak and fiber segment in 
device3.obr are shown in Trace Event Features 6 and 7, which have no 
corresponding entries in the Reference Trace Event Listing. If a trace had missing 
features, they would be displayed as features in the Reference Trace Event Listing 
with no corresponding features in Trace Event Listing. 

 

Select each of the features to verify that the extra peak and fiber are the only failing 
features. In the Feature Tolerance Detail area on the left, the extra features should 
show as failing (red) both in Feature Type and Location. Note that the Min and 
Max Loss values for the extra features have been compared to the Reference Trace’s 
General Tolerance values, since there is no reference feature to compare them to. 
When Feature 6 of device3.obr is shown as High Resolution Data (using the graph 
pull-down menu), only red data is displayed, since there is no Reference Trace 
(blue) data saved at that location. 

 
Comparing Traces Using the Trace Comparison Window 

From the Trace Comparison window, one can open and compare other files without 
using the File > Load Data File command or the Setup > File Configuration 
command in the main window. Comparing other files in the Trace Comparison 
window only changes the Reference Trace or compared data temporarily. When this 
window is closed, the software returns to the data loaded using the File > Load Data 
File command, and to the Reference Trace chosen in the Specify File Paths window 
(Figure 6-2 on page 80). 

 

To compare the current Reference to a different trace, press the browse button to 
the right of the Trace File Folder control and select the directory 
C:\LPA_Data\device2. This compares the reference file to the device2 files created 
earlier in the tutorial. All features should be again be marked as passing. 

 

Similarly, you can use the Reference Trace File Folder browse button to select a 
different Reference for comparison to the current trace. By using both controls to 
select two different folders, any reference or evaluation trace can be compared to 
another. (However, it is of limited use to compare two traces unrelated to either the 
current reference or the currently loaded trace.) 
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Press the Close button to exit the Trace Comparison window. Note that the loaded 
trace is still device3.obr, and the lower graph data is not reprocessed. 

 

Press the Save LightPath Files button to save the LightPath data for device3.obr. 
Enter device3 as the descriptor for new data folder, and press OK. 

 
Editing a Reference Trace: Processing Parameters and General 

Tolerances 
Above under “Editing Feature-Specific Tolerances” on page 88, you learned how 
to edit feature-specific tolerances in the Reference Trace. Reference files also 
contain processing parameters and general tolerance values like those in the 
Parameter Configuration File. These values can be modified to affect the way 
features are detected, and to change general tolerances. 

 

Select Setup > Data Processing Parameters from the main menu. The Parameter 
Specifications window is shown again (Figure 6-4 on page 83), this time displaying 
the parameters and tolerances contained in the Reference Trace file “golden.” 

 

The Processing Parameters and General Tolerances for the golden reference are 
currently the same values (contained in lpa_default_params.ini) that were in use 
when the trace was saved. These values can be changed so that future traces being 
compared to the Reference Trace file “golden” will be processed using a different 
set of parameters and tolerances. 

 

Changing the General Tolerances for a Reference Trace will change the tolerance 
values used to evaluate extra features. For example, changing the value of (IL) Loss 
Tolerance (dB) to 3.5 would cause the extra feature in device3.obr to pass based 
on (insertion) Loss (although it would still fail for being a feature not present in the 
Reference Trace). More importantly, these are the values that would be used if both 
the Compare to Reference Trace and Use General Tolerances checkboxes were 
selected in the Specify File Paths window (Figure 6-2 on page 80). 

 

Change the Processing Parameters in a Reference Trace with caution, because new 
traces will be processed differently from the way the original Reference Trace was 
processed. For example, changing the Feature Extract Length (m) back to 0.1 
would collapse the two peaks at 1.6 and 1.9 m back into a single feature when 
processing any new data. This would make it impossible for any new trace to match 
the Reference, which would still retain the two distinct peaks. 
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The Reference Trace Processing Parameters should be changed only to correct a 
situation in which good devices are failing because of mismatched features caused 
by random but acceptable variations between devices. 

 
 
 

Important 

Ideally, many devices should be tested before a 
Reference Trace is settled upon, to make sure that the 
Processing Parameters being used will result in a 
consistent set of features for every good device tested. It 
should then be unnecessary to modify the Reference 
Trace later. 

 

 
Press Cancel to exit the Parameter Specifications window without modifying the 
Reference file. 

 
Setting the Maximum Device Length 

Sometimes there may be trailing noise present in a trace after all of the actual 
features. Differences in this noise level may cause the LightPath Analysis software 
to conclude that a trace has failed, even though all of the desired features are within 
the correct limits. In these cases, it is advantageous to specify a Maximum Length 
beyond which no features will be compared. 

 

To specify this value, select Setup > Data Processing Parameters from the main 
menu. Verify that C:\LPA_Data\golden is still the selected Reference Data Folder 
at the top of the Parameter Specifications window (Figure 6-4 on page 83). In the 
Device Length section at the lower left, check the Use Maximum Length checkbox 
and change the value of Maximum Length to 5.0. Press Apply to re-evaluate the 
current trace (still device3.obr) without re-saving the Reference. The trace will be 
reprocessed but will only display up to the last feature within 5.0 meters. 

 
 

Note Although the Maximum Length is set to 5.0, the last Peak 
ends at just over 2 meters. The software omits the trailing 

                Fiber segment, showing only the data up to the end of the 
last Peak or Drop. 

 
 

The Trace Comparison window (Figure 6-10 on page 92) will also show only the 
features occurring before the Maximum Length. 

 

The Maximum Length value can also be modified through the Tolerance 
Specification window (Figure 6-8 on page 88) Select Setup > Feature-Specific 
Tolerances from the main menu. Click in the Use Maximum Length checkbox just 
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below the Feature Listing grid, then type in the desired maximum. Notice that all 
trace segments are shown in the Tolerance Specification window. This aids in 
correctly setting the Maximum Length. 

 

Change the Maximum Length value back to 0.0 and uncheck the Use Maximum 
Length checkbox. Press the Apply button to reprocess the trace without saving the 
changes to the Reference Trace. The trace will be reprocessed and will now show 
all features. 

 
Resetting the Default Parameters 

Since some of the default processing values were changed in this walk-through, take 
the following steps to return them to their original values before using this tutorial 
again. 

 

From the main menu, select Setup > Data Processing Parameters to view the 
Parameter Specifications window. Press the Select New Reference button at the 
top left to load a different Reference or Parameter Configuration File. Select the 
file lpa_default_params.ini located in the folder C:\Documents and Settings\All 
Users\Application Data\Luna Technologies\LightPath Analysis v#.#. 

 

In the Peak Processing Parameters section, change the Feature Extract Length 
from 0.05 back to 0.1. In the General Tolerances section, change the (RL) Peak 
Tolerance value from -50 to -65, and change the (IL) Splice Loss Tolerance value 
from 0.6 to 0.1. 

 

Press the Save button. Select the file lpa_default_params.ini and press Save. 
 

Note that the data is not reprocessed, because the software is still using the golden 
trace as the Reference. Selecting a new Reference in the Parameter Specifications 
window or in the Tolerance Specification window only selects a new file to edit, 
and does not change the file being used for processing. The Reference or Parameter 
Configuration File used for processing can only be changed using the Specify File 
Paths window (Figure 6-2 on page 80). 

 

To reset lpa_default_params.ini as the file used to process traces, select Setup > 
File Configuration from the main menu to view the Specify File Paths window, 
and uncheck the Compare to Reference Trace checkbox. Make sure that 
lpa_default_params.ini is listed as the Parameter Configuration File and press 
OK. 
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Suggested Setup and Use 

As already discussed, the LightPath Analysis software is designed to compare 
devices to an ideal Reference Trace for quality control purposes. Ideally, the 
Reference Trace and all test scans for a given device or component should be stored 
in the same base folder, with the Reference Trace in a “golden” subfolder, and test 
results stored in subfolders labeled with the serial number of the test device. 

 

The suggested setup is procedure is as follows: 
 

1 Select Setup > File Configuration. In the Specify File Paths window 
(Figure 6-2 on page 80), change the Base Folder for Output Files to 
the name or model number of the part to be tested. 

 

2 Scan several devices to determine the processing parameters required 
to achieve a consistent feature list across multiple devices. Determine 
the desired and achievable tolerance levels. 

 

3 Select Setup > Data Processing Parameters from the main menu. Set 
the parameters and tolerances in the Parameter Specifications window 
(Figure 6-4 on page 83) 6 

4 Scan an ideal device, and save its results to the golden subfolder. Select 
Setup > File Configuration and select this trace as the reference. 

 

5 Modify the Feature-Specific Tolerances for the golden trace to match 
the test requirements in the Tolerance Specification window (Figure 6- 
8 on page 88). 

 

6 Scan test devices. Note the pass/fail result of each device. Save the 
LightPath files for each device, using the device's serial number as the 
subfolder name. 

 
Description of Processing Parameters and 

Tolerances 
This section describes the various processing parameters and tolerances, and their 
affects on the feature detection algorithm. The explanatory graphs below may also 

 

be viewed from the software by clicking the question button next to any 
parameter or tolerance setting in the Parameter Specifications window (Figure 6- 
4 on page 83). 
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Characteristic Length (m) 

A window is passed across a raw data set to find the “rolling median” of that data. 
The width of the window is defined as a number of points corresponding to the 
Characteristic Length specified by the user. This calculation of the rolling median 
is performed in order to locate the peaks (i.e. upward events) within the data set. 

 

As this value is increased, the median algorithm will tend to smear the events of a 
given data set, making it less able to distinguish between events (i.e. the median 
will not transition quickly enough). As this value is decreased, the median will react 
too quickly to events in the given data set and will tend to track each transient event. 

 

Default Value: 0.1 meters 
 

Closely Related To: Peak Detect Ratio 
 
 
 
 
 
 

6 
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Drop Length (m) 

The Drop Length is similar to the Characteristic Length discussed above, in that 
it is the length of a window used to calculate a rolling median of the data set. 
However, the Drop Length is used to resolve drops in the raw scatter data by 
comparing the rolling median value obtained from this calculation with the rolling 
median value calculated using the Characteristic Length. The Drop Length value 
must be significantly smaller than the value specified for the Characteristic Length, 
or a drop may not be detected. 

 

Default Value: 0.02 meters 
 

Closely Related To: Drop Detect Ratio, Drop Tolerance 
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Feature Extract Length (m) 

Once a Peak or other feature is detected by the software, a segment of data is 
extracted around that location for further processing. The length of this segment is 
specified by the Feature Extract Length parameter specified by the user. 

 

Primarily, this parameter is used for processing of Peak features that are found in 
the data set. However, this value is also be used as the area over which to calculate 
the Return Loss of all features. It is used in determining whether the Drop 
Tolerance and Peak Tolerance criteria are violated by each feature. 

 

If two peaks are found close to each other and the extracted segments around those 
peaks overlap, the peaks are combined into a single feature. 

 

Default Value: 0.1 meters 
 

Closely Related To: Peak Dead Zone, Peak Tolerance, Drop Tolerance 
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Peak Detect Ratio (lin) 

The Peak Detect Ratio is the ratio of the raw data value to the calculated median 
value that denotes a peak at that location. This ratio is calculated at each data point. 
Calculated ratios that are above this specified value are recorded as Peaks. 

 

Calculation: raw data amplitude / median value 
 

Default Value: 40 
 

Closely Related To: Characteristic Length 
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Peak Dead Zone (m) 

The Peak Dead Zone is the length within the scatter data set in which the software 
will not look for another Peak while processing an extracted segment around a Peak. 

 

Default Value: 0.005 meters 
 

Closely Related To: Feature Extract Length 
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Drop Detect Ratio (lin) 

The Drop Detect Ratio is the ratio between the raw scatter data and the median 
value. The ratio between these two values is calculated at all data points and a drop 
is detected when the calculated value is greater than this criteria. 

 

Calculation: raw data amplitude / median value 
 

Default Value: 1.5 
 

Closely Related To: Drop Size, Drop Tolerance 
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Integration Length (m) 

The Integration Length parameter is the length of the data set over which the 
integrated power is calculated for the purpose of detecting the location of splice 
losses in the data. It is also the length used when performing the same calculations 
to find the insertion loss across all artifacts that were determined to be Peaks. 

 

Default Value: 0.5 meters 
 

Closely Related To: Splice Loss Tolerance, Loss Tolerance 
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Return Loss Type 

The software can use two methods to calculate Return Loss: 
 

• Measured Return Loss: The actual power reflected from an event as 
detected by the OBR. If Insertion Loss has occurred before a Return 
Loss, the power reflected from that event is reduced. The Measured 
Return Loss includes this reduction. 

 

• Absolute Return Loss: The amount of loss reflected from an event in 
the absence of Insertion Loss up to that event. The Absolute method 
shows Return Loss data as if each connection was attached directly to 
the front of the OBR, with nothing before it. 

 

You may change the Return Loss calculation method in the Parameter 
Specifications window (Figure 6-4 on page 83). 

 
Why is there an asterisk before the RL value? 

 

When the vertical cursors are on in the main window, the Return Loss of a 
highlighted feature will be displayed in the upper right of the graph. Sometimes there 
will be an asterisk (*) before this value, meaning that the Rayleigh scatter just before 
that event was not sufficiently flat to allow accurate Absolute Return Loss 
calculation. 

 

An asterisk may also be placed before the Return Loss value if the gain is set low 
enough that the Rayleigh scatter cannot be detected properly. 
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Peak Tolerance (dB) 

The Peak Tolerance value is equivalent to the Maximum Return Loss allowed by 
all artifacts in the data set. If the return loss of any artifact surpasses this tolerance, 
it will be shown to fail. 

 

Default Value: -65 dB 
 

Closely Related To: Feature Extract Length, Peak Dead Zone 
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Drop Tolerance (dB) 

The Drop Tolerance is equivalent to the Maximum Return Loss that is allowable 
for any Drop detected in the scatter data. The return loss of a Drop is calculated 
by integrating the power of an area centered around the feature that has a length 
equivalent to the Feature Extract Length. 

 

Default Value: -68 dB 
 

Closely Related To: Feature Extract Length 
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Loss Tolerance (dB) 

The Loss Tolerance is the maximum allowable insertion loss across any interface 
in the data set. 

 

Default Value: 2.0 dB 
 

Closely Related To: Splice Loss Tolerance, Integration Length 
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Splice Loss Tolerance (dB) 

The Splice Loss Tolerance is the maximum allowable insertion loss for splices 
found in a data set. 

 

Default Value: 0.2 dB 
 

Closely Related To: Loss Tolerance, Integration Length 
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Location Tolerance (m) 

The Location Tolerance is the maximum distance a feature may be from its expected 
location (based on the Reference or golden trace location) and still be considered 
passing. 

 

Default Value: 0.1 m 
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Maximum Length (m) 

Features after the Maximum Length will not be displayed, when this item is checked 
in the Parameter Specifications window (Figure 6-4 on page 83) or the Tolerance 
Specification window (Figure 6-8 on page 88). Only the last Peak or Drop before 
this length will be displayed. 

 

Default Value: 0.0 m 
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Remote Commands 
 

All of the remote commands available in the OBR control software (See Chapter 7‚ 
“Controlling the OBR Remotely,” on page 119) are also available in the LightPath 
Analysis software, except the following: 

 

CONF:COEF 

CONF:COEF? 

SYST:COPY 

FETC:FDTL? 
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Remote Commands Unique to LPA 

 

FETCh:NUMberofFeatures? 
 

Usage: FETC:NUMF? 
Description: Queries the number of features present in the current 

LightPath trace. 
Response: Returns a number indicating the number of features in the 

trace. Returns an error message if no trace data has been 
loaded. 

Example: FETC:NUMF? 
15 
The response indicates that the current trace has 15 features. 

 
FETCh:FEATures 

 

Usage: FETC:FEAT? 
Description: Retrieves the LightPath features for the current trace. 
Response: A table listing the details for each trace feature. The first 

line is a header listing the names of each column. The 
remaining lines list the values for each feature. Lines are 
separated by newline characters, and columns by tab 
characters. 

Example: CONF:FEAT? 
Feature\tType\tRet Loss\tIns Loss\tLocation\tRet Loss 
Min\tRet Loss Max\tIns Loss Min\tIns Loss Max\tLocation 
Min\tLocation Max\tPass/Fail 
Feature 1\tFiber\t0\t0.0045922\t-1.00003\t0.568596\t- 
200\t200\t-0.6\t0.6\t-1.10003\t-0.381055\tPass 
Feature 2\tPeak\t-77.1366\t0.0945949\t- 
0.4314\t0.100805\t-200\t-50\t-2\t2\t-0.531477\t- 
0.331477\tPass 
Feature 3\tFiber\t0\t-0.0347541\t-0.330557\t0.280291\t- 
200\t200\t-0.6\t0.6\t-0.381055\t0.000424449\tPass 
… 
(\t indicates a tab character) 
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FETCh:PASSed? 

 

Usage: FETC:PASS? 
Description: Queries whether the current LightPath trace has passed. 

That is, is all of the features have passed. 
Response:         Returns a 1 if all features have passed, or 0 if one of more 

features have failed. Returns an error message if no trace 
data has been loaded. If the response is 0, the FETC:FEAT? 
query can be used to determine which of the features has 
failed and why. 

Example: FETC:NUMF? 
1 
The response indicates that all of the features have passed. 

 

FETCh:GeneralTOLerances? 
 

Usage: FETC:GTOL? 
Description: Queries the general tolerances contained in the current 

reference trace or parameter file. 
Response: Returns the Peak, Drop, Loss, Splice Loss, and Location 

Tolerances for the current reference or parameter file. 
Example: FETC: GTOL? 

Peak Tolerance: -50 
Drop Tolerance: -68 
Loss Tolerance: 2 
Splice Loss Tolerance: 0.6 
Location Tolerance: 0.1 

 

CONFigure:ConfFiGuration? 
 

Usage: CONF:CFG? 
Description: Queries the current LightPath configuration. 
Response: Strings indicating the current reference trace directory, 

default parameter file, “using reference” setting, “using 
general tolerances” setting, and base output folder. 

Example: CONF:CFG? 
Reference directory: C:\LPA_Data\golden 
Default params: C:\LPA\LPA_default_params.ini 
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Use reference: 1 
Use general tolerances: 0 
Base folder: C:\LPA_Data 
The response shows the current reference trace directory 
and the default parameter filename. The “Use Reference:1” 
response indicates that the reference trace is being used 
(instead of the default parameters file). The “Use general 
tolerances: 0” response indicates that the feature specific 
tolerances are being used (instead of the general tolerances.) 
The “Base folder” response shows the directory where 
LightPath data will be saved. 

 

CONFigure:ConfFiGuration 
 

Usage: CONF:CFG {refDir, defParamFile, useRef, useGenTol, 
baseFolder} 

Description: Sets the current LightPath configuration. 
The parameter refDir specifies the directory containing the 
reference trace. The name must be in quotes if it contains 
any spaces. If this parameter is specified as “”, the current 
reference trace will be retained. 
The parameter defParamFile specifies the default parameter 
filename. The name must be in quotes if it contains any 
spaces. If this parameter is specified as “”, the current 
parameter file will be retained. 
The parameter useRef specifies whether acquired traces are 
compared to the reference trace or to the default parameter 
file. A value of 1 indicates that the reference trace should 
be used. A value of 0 indicates that the default parameter 
file should be used. 
The parameter useGenTol specifies whether acquired traces 
are compared to a reference trace's general tolerances or to 
its feature-specific tolerances. A value of 1 indicates that the 
general tolerances should be used. A value of 0 indicates 
that the feature-specific tolerances should be used. This 
parameter is not meaningful if setting useRef to 0. 
The parameter baseFolder specifies the base folder where 
LightPath data files will be saved. 
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Response: None 
Example: CONF:CFG C:\LPA_Data\myref, C:\LPA\myparams.ini, 1, 

0, C:\LPA_Data 
Sets the reference trace to “C:\LPA Data\myref” and the 
default parameter file to “C:\LPA\myparams.ini”. Specifies 
that the reference trace should be use, and that the feature 
specific tolerances should be used. 
CONF:CFG “”, “C:\test\myparams.ini”, 0 
Sets the default parameter file to “C:\LPA\myparams.ini”, 
and specifies that the default parameter file should be used 
to evaluate traces. The reference trace directory, base folder, 
and useGenTol setting are not changed. 
CONF:CFG “”, “”, 1, 0 
Specifies that traces should be evaluated using the current 
reference trace and the feature-specific tolerances. The 
reference trace, default parameter file, and output base 
folder are not changed. 

 

CONFigure:REFerencetrace? 
 

Usage: CONF:REF? 
Description: Queries the current LightPath reference trace. 
Response: The current reference trace directory. 

This information can also be obtained using the 
CONF:CFG? query. Since querying the reference trace is a 
more common operation, it is provided its own query for 
convenience. 

Example: CONF:REF? 
C:\LPA_Data\golden 
Indicates that “C:\LPA_Data\golden” is the current 
reference trace. Note that this response does not indicate 
that the reference trace (rather than the default parameter 
file) is being used to evaluate traces. That information can 
be determined using the CONF:CFG? query. 
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CONFigure:REFerencetrace 

 

Usage: CONF:REF {refDir} 
Description: Sets the current LightPath reference trace, and sets the 

LightPath software to evaluate traces using the reference 
trace rather than the default parameter file. 
If the refDir parameter is not a fully qualified path, it is 
assumed to be subdirectory in the Base Folder—the 
directory where LightPath data files are saved. 
Note that this could be also be accomplished using the 
command CONF:CFG {refDir, “”, 1}. 
Since changing the reference trace is a more common 
operation, it has its own command for convenience. 

Response: None. 
Example: CONF:REF C:\LPA_Data\golden 

Sets the reference trace to “C:\LPA_Data\golden” and 
configures the software to use it (rather than the default 
parameter file) to evaluate traces. 
CONF:REF myRef 
Sets the reference trace to the “myRef” subdirectory in the 
Base Folder. If this folder is “C:\LPA_Data”, then the 
reference trace is set to “C:\LPA_Data\myRef”. The 
software is also configured to use this reference (rather than 
the default parameter file) to evaluate traces. 

 

SYSTem:SaVeLightPathtrace 
 

Usage: SYST:SVLP {deviceName} 
Description: Saves the current LightPath trace. 

The deviceName parameter specified a new subdirectory in 
the Base Folder where the LightPath files should be saved. 
(The name of the base folder can be obtained by using the 
CONF:CFG? query.) 

Response: None. 
Example: SYST:SVLP device2 

Saves the LightPath files to the directory “[Base 
folder]\device2”. 
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If the base folder is “C:\LPA_Data”, then the files are saved 
to “C:\LPA_Data\ device2”. 
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Chapter 7 
 
 
 

Controlling the OBR Remotely 
 
 

This chapter provides information about controlling the Optical Backscatter 
Reflectometer remotely, using GPIB or TCP/IP commands. This section assumes that 
the user already has some familiarity with either GPIB or TCP/IP. For detailed 
information about GPIB, see IEEE 488.2 standards documents; for information about 
TCP/IP, see the IEEE 802 standards documents. 

 

Nearly all functions that can be performed using the graphical interface of the control 
software can also be performed remotely. This includes setting scan parameters, 
performing measurements, filtering data, loading and saving data files, as well as 
receiving data over the remote interface. However, continuous mode is not available 
with remote operation. 

 

For higher speed remote operation, TCP/IP is recommended over GPIB. 

Prerequisites for Remote Control Setup 7 
 

1 Be familiar with the use of GPIB or TCP/IP commands and the OBR 
control software before attempting to control the OBR remotely. 

 

2 Network cabling must comply with IEEE 488.2 requirements for GPIB 
operation, or with IEEE 802 requirements for TCP/IP operation. 

 

3 Some OBR functions require several minutes to complete. Adjust GPIB 
or TCP/IP time-outs for your application accordingly. 

 

4 Each device in the GPIB network must have a unique GPIB address, 
typically from 1 to 30. The network controller is typically assigned an 
address of 0. 

 

5 Be aware of the IP address of the OBR PC in order to use TCP/IP remote 
control. 
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Remote Control Setup Configuration 

The remote interface type, board address and port number can be configured using 
the OBR menu selection Options > Remote Interface Setup. The following dialog 
box appears: 

 

 
 
 
 
 
 
 
 
 
 
 
 

Figure 7-1. The remote interface setup dialog box. 
 

If Enable Remote Interface is checked, it is on. The pull-down menu allows the 
user to select either GPIB or TCP/IP remote interface. TCP/IP is the default interface. 
The second field is used to set either the GPIB address or the ethernet port number. 
By default, both the GPIB address and the ethernet port number are set to “1”. 

 

The GPIB board name is set to “GPIB0” by default. 
 

For suggestions on remote setup using TCP/IP, see “Setting Up a TCP/IP Console” 
on page 161. 

 
Remote Control Commands for the OBR 

This section gives a description of every remote control command available with 
the OBR control software. The commands are organized by function. For an 
alphabetical listing of each command, see Table 7-1, “Alphabetical Summary of 
GPIB and TCP/IP Commands,” on page 163. 

 

Each of the commands listed below may be used for either GPIB or TCP/IP interface. 
The OBR control software accepts all mandatory IEEE 488.2 commands for GPIB, 
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but only responds to the commands described in this section. The OBR does not 
accept TCP/IP commands that are not listed in this document. 

 
 

Important The OBR control software does not support multiple 
commands on a line, separated by semicolons. Enter each 
command on a separate line. 

 

 
IEEE 488.2 defines commands as being either sequential or overlapped. Sequential 
commands cause the instrument to ignore other remote control commands until each 
command has completed. Overlapped commands let the device respond to incoming 
commands before pending commands completely execute. The OBR processes only 
sequential commands. 

 

All commands are case-sensitive, and must be entered exactly as they appear in this 
chapter. 

 

Examples of how to use these commands with Visual Basic®  code are given under 
“Example Visual Basic Code” on page 155. 

Remote control commands are classified by types: 

• Standard Commands 
• System Control Commands 
• Configuration Commands 
• Data Capture and Retrieval Commands 

 
Standard Commands 

These are mandatory commands required by IEEE 488.2. For consistency, they are 
also accepted by the OBR when operating with TCP/IP. These commands are 
generally not necessary for performing measurements with the OBR. For more 
information about these commands, see the IEEE 488.2 standards documents. 

 

*QUIT 
Usage: *QUIT 
Description: Ends a remote session, allowing the OBR to go back to local 

control mode. 
Response: None. 
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*CLS 

Usage: *CLS 
Description: Clears the status register. 
Response: None. 

 

*ESE 
Usage: *ESE {n} 
Description: Sets the value (0–255) of the Status Enable register. 
Response: None. 

 

*ESE? 
Usage: *ESE? 
Description: Retrieves the current value (0–255) of the Status Enable 

register. 
Response: Returns a number ranging from 0 to 255. 

 

*ESR? 
Usage: *ESR? 
Description: Retrieves the value of the Event Status register. 
Response: Returns a number ranging from 0 to 255. 

 

*IDN? 
Usage: *IDN? 
Description: Retrieves the OBR's identification string. 
Response: Returns a string identifying the model, manufacturer, and 

firmware level for the device. 
 

*OPC 
Usage: *OPC {0|1} 
Description: Enables (1) or disables (0) the "operation complete" event 

notification. 
Response: None. 
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*OPC? 

Usage: *OPC? 
Description: Queries the OBR to determine if the operation is complete. 
Response:  Returns "1" if the previous operation has been completed; 

"0" if the previous operation is still processing. 
 

*RST 
Usage: *RST 
Description: Instructs the OBR to reset all parameters to the power-on 

defaults. 
Response: None. 

 

*SRE 
Usage: *SRE {n} 
Description: Sets the value (0–255) of the Service Request Enable 

register. 
Response: None. 

 

*SRE? 
Usage: *SRE? 
Description: Retrieves the current value of the Service Request Enable 

register. 
Response: Returns the value (0–255) of the Service Request Enable 

register. 
 

*STB? 
Usage: *STB? 
Description: Retrieves the value of the Status Byte register. 
Response: Returns the value (0–255) of the Status Byte register. 

 

*WAI 
Usage: *WAI 
Description: Prevents the OBR from executing any further commands or 

queries until all pending operations have been completed. 
Response: None. 
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*TST? 

 

Usage: *TST? 

Description: Performs a self-test query. 

Response: None. 
 

System Level Commands 
 

SCAN 
Usage: SCAN 
Description: Tells the OBR to execute an optical Scan based on the 

configured system parameters. Depending on the 
wavelength range (CONF:RANG) setting and Scan Rate 
(CONF:RATE), this command may take up to several 
minutes to complete. 

Response: None. 
Note: It is advisable to use the *OPC? query until it returns a “1,” 

to verify that the Scan has been completed. 
It is also advisable to use the SYST:ERR? query after each 
SCAN command and before attempting to retrieve the data 
with FETC queries. This will reveal any errors that occurred 
during the Scan. 

 

SYSTem:SPOTscan 
Usage: SYST:SPOT {center, centerUnits} 
Description: Tells the OBR to execute an optical Spot Scan based on the 

configured system parameters. A Spot Scan is performed 
over the same wavelength range (CONF:RANG) that would 
be used for a regular Scan (triggered by the SCAN 
command), but only a portion of the data is returned. The 
data returned is centered around the x-axis location 
“center,” in units “centerUnits.” Values for “centerUnits” 
are: 0 for time (ns), 1 for length (m), 2 for length (ft), 3 for 
inches (in), or 4 for millimeters (mm). 

Response: None. 
Example: SYST:SPOT 1.5, 1 

This command performs a spot scan centered around 1.5 m. 
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SYSTem:ON? 

Usage: SYST:ON? 
Description: Queries whether the OBR is on. 
Response: Returns "1" if the system is on, "0" if it is off. 

 

SYSTem:WARM? 
Usage: SYST:WARM? 
Description: Queries if the laser is at operating temperature. 
Response: Returns the digit “1” if the laser is at operating temperature, 

or “0” if it is not at operating temperature. 
 

SYSTem:WarmupTIMeremaining? 
Usage: SYST:WTIM? 
Description: Retrieves the time remaining on the system one hour warm- 

up timer. 
Response: Returns the current warm-up time left in minutes. 

If the OBR instrument and PC have warmed-up for the 
specified hour, this command will return zero, “0”, meaning 
no warm-up time is left. 

Note: It is always recommended to query the warm-up timer 
before calibrating and taking measurements. The OBR must 
be at a stable temperature in order to consistently perform 
accurate measurements according to published 
specifications. 

 

SYSTem:VERsion? 
Usage: SYST:VER? 
Description: Queries the software version. 
Response: Returns a string containing the OBR software version. 
Example: 2.0.1 

 

SYSTem:LASEr 
Usage: SYST:LASE {0|1} 
Description: Turns the laser on (1) or off (0). 
Response: None. 
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SYSTem:LASEr? 

Usage:  SYST:LASE? 
Description: Queries the laser state. 
Response: Returns “1” if the laser is on, or “0” if the laser is off. 

 

SYSTem:ReaDY? 
Usage: SYST:RDY? 
Description: Queries if the OBR is ready to Scan. 
Response: Returns “1” if the OBR is ready to Scan, or “0” if it is not. 

 

SYSTem:ERRor? 
Usage: SYST:ERR? 
Description: Retrieves the error code for the most recent remote 

operation. 
Response: Returns a numeric error code. A code of 0 indicates no error; 

i.e. the last command or query completed successfully. Any 
non-zero number indicates that an error has occurred. A 
description of the error may be retrieved with the query 
SYST:ERRD? 

 

SYSTem:ERRorDescription? 
Usage: SYST:ERRD? 
Description: Retrieves the detailed error description for the most recent 

remote operation. 
Response:         Retrieves a string explaining the results of the most recent 

operation. The total length of the error message will be less 
than 512 bytes. Two examples of error messages are: 

Examples: Group index set to 1.5 
Not a valid trace: W 
Missing parameter: <center wavelength> 

 
SYSTem:ALIGn 

Usage: SYST:ALIG 
Description: Aligns the optics. 
Response: None. 
Notes: This process may take several minutes. Adjust the time-outs 

for your application accordingly. 
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SYSTem:ALIGn? 

After a successful alignment, the system will automatically 
perform calibration. 
Poll for *OPC? to determine when this operation has 
completed. 

Usage: SYST:ALIG? 
Description: Queries the OBR if the optics are aligned. 
Response: Returns “1” if the optics are aligned, or “0” if they are not. 
Note: This command is only valid immediately following a 

system calibration (SYST:CAL). 
 

SYSTem:CALibration 
Usage: SYST:CAL 
Description: Calibrates the system. 

A gold reflector must be connected to the OBR before 
issuing this command. 

Response: None. 
Notes: This process may take several minutes to complete, so 

adjust application time-outs accordingly. 
Poll for *OPC? to see whether the operation is completed. 

 

SYSTem:CALibration? 
Usage: SYST:CAL? 
Description: Queries the system calibration status. 
Response: Returns “1” if the system is in calibration or “0” if it is not. 
Note: The validity of calibration is checked with every scan. If it 

is determined that the calibration is no longer valid, then this 
status switches to “0.” In this case, the user may either 
recalibrate by using the SYST:CAL command described 
above, or reload the previous calibration using the 
SYST:RLDC command below. 

 

SYSTem:WCLF? 
Usage: SYST:WCLF? 
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Description:      Queries whether the wavelength calibration failed during 

the previous scan. It is analogous to the “Wavelength Cal 
Failed” warning light that appears in the OBR software. 

Response: Returns 1 if the wavelength calibration failed, or 0 if it did 
not. Note that this only applies to scans started remotely 
(using the SCAN or SYST:SPOT commands), not scans that 
were performed using the local Scan button. 

Example: SYST:WCLF? 
This query returns the value 1 or 0, depending on whether 
the wavelength calibration failed or not. 

 

SYSTem:ReLoaDCalibration 
Usage: SYST:RLDC 
Description: Reloads into memory the calibration file set by 

SYST:CALF (described below). 
Response: None. 
Note: The user may send this command if SYST:CAL? returns a 

“0,” indicating that the calibration failed. Alternately, the 
user may recalibrate using the or SYST:CAL command 
described above. 

 

SYSTem:CALibrationFile 
Usage: SYST:CALF {0, filename} 
Description: Sets the name of the calibration file. If the filename is not 

specified, this command sets calibration file to the default 
filename, obrCal_refl. 
Because this command is used for other Luna systems, the 
user must specify zero (0) with this command for a 
reflection calibration. 

Response: None. 
Example: SYST:CALF 0, c_band 

This instructs the OBR to use the "c_band" calibration file. 
SYST:CALF 0 
This instructs the OBR to use the default calibration file, 
obrCal_refl. 
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SYSTem:CALibrationFile? 

Usage: SYST:CALF? 0 
Description: Retrieves the name of the calibration file. 

Because this command is used for other Luna systems, the 
user must specify zero (0) with this command to retrieve 
the calibration filename. 

Response: Returns the name of the calibration file currently in use. 
 

SYST:SAT? 
Usage: SYST:SAT? 
Description: Queries whether the detectors were saturated during the 

previous scan. It is analogous to the “Detectors saturated, 
reduce gain” warning light that appears in the OBR 
software. 

Response: Returns 1 if the detectors were saturated, or 0 if the detectors 
were not saturated. Note that this only applies to scans 
started remotely (using the SCAN or SYST:SPOT 
commands), not scans that were performed using the local 
mode Scan button. 

Example: SYST:SAT? 
This query returns the value 1 or 0, depending on whether 
the detectors were saturated or not. 

 

SYSTem:LOAD 
Usage: SYST:LOAD {"filename.obr", trace} 
Description: Loads the external file specified in quotes as a source of data 

reference for the measurement. 
If the file format is not correct, an error flag will be set. The 
cause of the error can be determined by using the 
SYST:ERRD? query. 

Response: None. 
Example: SYST:LOAD “c:\SavedFiles\test.obr”, C 

Loads the data contained in the file “test.obr” into Trace C. 
Notes: The entire file path must be in quotes, and the file type 

".obr" must be specified. The trace is specified as a single 
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SYSTem:SAVE 

letter: A, B, C, D or E. If no trace is specified, the specified 
file will be loaded into Trace A. 

Usage: SYST:SAVE {“filename.obr”, trace} 
Description: Saves the specified trace data as a binary file using the 

specified filename. The file name must be in quotes, and 
the file type ".obr" must be specified. If no trace (A-E) is 
specified, the data in Trace A will be saved. 

Response: None. 
Note: An error flag will be set if no data is available to save. The 

cause of error can be determined by using the SYST:ERRD? 
or SYST:ERR? query. 

Example: SYST:SAVE “C:\SavedFiles\TR.obr”, D 
Saves the data from Trace D into the file “TR.obr.” 

 

SYST:SaveSEGment 
Usage: SYST:SSEG {“filename”, trace} 
Description:      Saves as a binary file the segment of the trace defined by 

the Integration Area [or, in purchased Sensing Mode (see 
page 48), the Sensing Area]. This is analogous to selecting 
“Save Lower Graph Segment” when saving a file from the 
main software. 

Response: None. 
Example: CONF:XUNI 1 

INTC 3 
INTW 1.5 
SYST:SSEG “c:\myfile.obr”, A 
Defines an Integration Area (or Sensing Area) of 1.5 
meters centered at 3 meters, and saves that data to a file 
named C:\myfile.obr. 

 

SYSTem:SAVText 
Usage: SYST:SAVT {"filename.txt", trace, domain, graphType, 

units, spatialResolution} 
Description: Saves the specified trace (A, B, C, D or E) data as a 

spreadsheet or text file using the specified filename. The file 
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name must be in quotes, with the file type “.txt” inside the 
quotes as well. If no trace is specified, Trace A will be 
saved. 
Domain can be set to 0 for time domain, or 1 for frequency 
domain. 
GraphType can take values from 0 to 8, depending on the 
domain specified, as shown in the table on page 145. 
However, parameters 5 through 8 are only available when 
purchased as a separate option. 
Units for the time domain can be set to 0 for time (ns), 1 
for length (m), 2 for length (ft), 3 for inches (in), 4 for 
millimeters (mm). 
Units for the frequency domain can be set to 0 for 
wavelength (nm), 1 for frequency (GHz), or 2 for frequency 
(THz). 
SpatialResolution sets the spatial Resolution Bandwidth 
(mm). 

Response: None. 
Example: SYST:SAVT “C:\SavedFiles\measData.txt”, E 

Saves the data from Matrix E into the file “measData.txt.” 7 
SYSTem:COPY 

Usage: SYST:COPY {source, destination} 
Description: Copies data from the source trace to the destination trace. 
Response:  None. 
Example: SYST:COPY A, C 

Copies the data from Trace A to Trace C. 
 

SYSTem:ACQuired? 
Usage: SYST:ACQ? 
Description: Queries whether data has been acquired. 
Response: Returns "1" if data has been acquired by the OBR, "0" if not. 

 

SYSTem:GET? 
Usage: SYST:GET? {trace} 
Description: Queries whether data is loaded in the specified trace (A- 

E). If no trace is specified, Trace A will be assumed. 
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Response: Returns “1” if data is loaded into the specified trace, “0” 

if data is not loaded into that trace. 
 

SYST:LAST? 
Usage: SYST:LAST? 
Description: Queries the last remote command or query processed by the 

device. This query can be used to determine whether a 
command was received and processed. 

Response: Returns the name of the last remote command or query 
processed by the device. 

Example: CONF:INTW 1.5 
SYST:LAST? 
This query returns “CONF:INTW”. Note that SYST:LAST? 
only returns the name of the last command and does not 
report any parameters included with the command. 

 
Configuration Commands 

 

CONFigure:CenterWaveLength 
Usage: CONF:CWL {centerWavelength} 
Description: Sets the Center Wavelength (nm). The wavelength 

parameter must be within the operating range of the 
instrument. 

Response: None. 
Notes: Setting the center wavelength will cause the start and end 

wavelengths to be adjusted to match the new center 
wavelength and the wavelength range set using the 
CONF:RANG command. 
If the center wavelength and Scan Range settings for a 
measurement fall outside the most recent calibration, the 
wavelength settings will be coerced to fit within the most 
recent calibration. 

 

CONFigure:CenterWaveLength? 
Usage: CONF:CWL? 
Description: Retrieves the current Center Wavelength in nanometers. 
Response: Returns the current Center Wavelength in nanometers. 
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CONFigure:STARt 

Usage: CONF:STAR {startWavelength} 
Description: Sets the start wavelength for the scan in nanometers. The 

wavelength parameter must be within the operating range 
of the instrument. 
If the start wavelength falls outside the limits of the 
instrument, the command is accepted, but the start 
wavelength will be coerced to the nearest wavelength within 
the OBR’s limits using the current setting of Wavelength 
Range. 

Response: None. 
Notes: Setting the start wavelength will cause the center and end 

wavelengths to be adjusted to match the new start 
wavelength and the wavelength range set using the 
CONF:RANG command. 

Example: CONF:STAR 1525.0 
This command sets the starting wavelength to 1525.0 nm. 

 

CONFigure:STARt? 
Usage: CONF:STAR? 
Description: Retrieves the current start wavelength in nanometers. 
Response:  Returns the current start wavelength in nanometers. 
Example:  CONF:STAR? 

This query returns a message in the form “1525.00.” 
 

CONFigure:END? 
Usage: CONF:END? 
Description: Queries the OBR for the current ending wavelength. 
Response: Returns the current ending wavelength in nanometers. 
Example: CONF:END? 

This query returns a message in the form “1590.00” nm. 
 

CONFigure:RANGe 
Usage: CONF:RANG {scanRange} 
Description: Sets the Scan Range in nanometers. The OBR only allows 

scan ranges that have a number of data points equal to a 
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power of two, so the actual value of the Scan Range will 
be set to the valid value closest to scanRange. 

Response: None. 
Notes: If the center wavelength and scan range settings for a 

measurement fall outside the most recent calibration, the 
wavelength settings will be coerced to fit within the most 
recent calibration. 

Examples: CONF:RANG 5.0 sets the Scan Range to the valid range 
closest to 5.0 nm. 

 

CONFigure:RANGe? 
Usage: CONF:RANG? 
Description: Queries the OBR for the current Scan Range in nanometers. 
Response: Returns the current Scan Range in nanometers, in the form 

“20.0.” 
Examples: “CONF:RANG?” returns the Scan Range in nanometers. 

 

CONFigure:INTegrationWidth 
Usage: CONF:INTW {integrationWidth} 
Description: Sets the OBR Integration Width in the units set by 

CONF:XUNI (page 139). 
[In optional Sensing mode (page 48), the CONF:INTW 
command sets the Sensing Range, also in the units set by 
CONF:XUNI. Alternatively, you may use the CONF:SRAN 
command (see below) to set the Sensing Range.] 

Response: None. 
Notes: The Integration Width (or Sensing Range), along with the 

Integration (or Sensing) start (CONF:INTS) or center 
(CONF:INTC) set commands, defines the area that will be 
used for data capture and retrieval commands such as 
FETC:MEAS. All frequency domain values are based on 
this Integration Width (or Sensing Range) and start or 
center. Setting the Integration Width (or Sensing Range) 
to 0 indicates that the entire measurement area should be 
used for such commands. 
Setting the Integration Width (or Sensing Range) will 
cause the Integration (or Sensing) center to be adjusted to 
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match the new Integration Width (or Sensing Range) and 
the Integration (or Sensing) start set using the CONF:INTS 
command. 

 

CONFigure:INTegrationWidth? 
Usage: CONF:INTW? 
Description: Retrieves the OBR Integration Width in the units set by 

CONF:XUNI (page 139). 
[In optional Sensing mode (page 48), this returns the 
Sensing Range, also in the units set by CONF:XUNI. 
Alternatively, you may use the CONF:SRAN? command 
(see below) to retrieve the Sensing Range.] 

Response: Returns the OBR Integration Width (or Sensing Range) 
in meters. 

 

CONFigure:DistanceRANge 
Usage: CONF:DRAN {distanceRange} 
Description: Sets the OBR Distance Range to Normal (0) or Extended 

(1) range (page 28). 
Response: None. 

 

CONFigure:DistanceRANge? 
Usage: CONF:DRAN? 
Description: Retrieves the OBR Distance Range (page 28). 
Response: Returns the Distance Range, either zero (0) in the Normal 

Range or one (1) in the Extended Range. 
 

CONFigure:DeviceUnderTestLength 
 

Usage: CONF:DUTL {length} 
 

Description: Sets the DUT length to the value specified in meters for 
Extended Range mode. This command has no effect on 
Normal Distance Range scans. 

 

Response: None. 
 

Example: “CONF:DUTL 4.3125” sets the length of the DUT to 
4.3125 m. 
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CONFigure:DeviceUnderTestLength? 

 

Usage: CONF:DUTL? 
 

Description: Queries the current DUT length (in meters) for Extended 
Range mode. 

 

Response: Returns the current DUT length in meters. 
 

CONFigure:SensingRANge 
Usage: CONF:SRAN {sensingRange} 
Description: In optional Sensing mode (page 48), sets the OBR Sensing 

Range in the units set by CONF:XUNI (page 139). 
[Note that CONF:INTW will perform the same function in 
Sensing mode.] 

Response: None. 
Notes: The Sensing Range, along with the Sensing start 

(CONF:INTS) or center (CONF:INTC) set commands, 
defines the area that will be used for data capture and 
retrieval commands such as FETC:MEAS. All frequency 
domain values are based on this Sensing Range and start 
or center. Setting the Sensing Range to 0 indicates that the 
entire measurement area should be used for such 
commands. 
Setting the Sensing Range will cause the Sensing center 
to be adjusted to match the new Sensing Range and the 
Sensing start set using the CONF:INTS command. 

 

CONFigure:SensingRANge? 
Usage: CONF:SRAN? 
Description: Retrieves the OBR Sensing Range in the units set by 

CONF:XUNI (page 139). 
[The user may also use the CONF:INTW? command to 
perform the same function.] 

Response: Returns the OBR Sensing Range in meters. 
 

CONFigure:INTegrationStart 
Usage: CONF:INTS {integrationStart} 
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Description: Sets the OBR Integration Area start in the units set by 

CONF:XUNI (page 139). 
[In Sensing mode, this sets the Sensing Area start, also in 
the units set by CONF:XUNI.] 

Response: None. 
Note: Setting the Integration (or Sensing) start will cause the 

Integration (or Sensing) center to be adjusted to match the 
new Integration (or Sensing) start and the Integration 
Width (or Sensing Range) set using the CONF:INTW 
command. 

 

CONFigure:INTegrationStart? 
Usage: CONF:INTS? 
Description: Retrieves the OBR Integration (or Sensing) Area start in 

the units set by CONF:XUNI (page 139). 
Response: Returns the OBR Integration (or Sensing) Area start. 

 

CONFigure:INTegrationCenter 
Usage: CONF:INTC {integrationCenter} 
Description: Sets the OBR Integration (or Sensing) Area center in the 

units set by CONF:XUNI (page 139). 
Response: None. 
Note: Setting the Integration (or Sensing) Area center will cause 

the Integration (or Sensing) Area start to be adjusted to 
match the new Integration (or Sensing) Area center and 
the Integration Width (or Sensing Range) set using the 
CONF:INTW command. 

 

CONFigure:INTegrationCenter? 
Usage: CONF:INTC? 
Description: Retrieves the OBR Integration (or Sensing) Area center 

in the units set by CONF:XUNI (page 139). 
Response: Returns the OBR Integration (or Sensing) Area center in 

the units set by CONF:XUNI. 
 

CONFigure:GaugeLENngth 
Usage: CONF:GLEN {gaugeLength} 
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Description: Sets the gauge length in cm. This is the new name for 

CONF:SRES {sensingResolution}. The CONF:SRES 
command is still supported, but may be discontinued in the 
future. 

Response: None 
Examples: CONF:GLEN 1.5 

Sets the gauge length to 1.5 cm. 
 

CONFigure:GaugeLENngth? 
Usage: CONF:GLEN? 
Description: Queries the gauge length. This is the new name for 

CONF:SRES? {sensingResolution}. The CONF:SRES? 
query will continue to be supported, but may be 
discontinued in the future. 

Response: Returns the gauge length in cm. 
Example: CONF:GLEN? 

This query returns the gauge length in cm. 
 

CONFigure:SensorSPAcing 
Usage: CONF:SSPA 
Description: Sets the Sensor Spacing in cm. The sensor spacing was 

previously tied to the Sensing Resolution value, and both 
were set by the CONF:SRES command. It is now a separate 
value with its own command. 

Response: None. 
Example: CONF:SSPA 2.0 

Sets the Sensor Spacing to 2.0 cm. 
 

CONFigure:SensorSPAcing? 
Usage: CONF:SSPA? 
Description: Queries the Sensor Spacing. 
Response: Returns the Sensor Spacing in cm. 
Example: CONF:SSPA? 

This query returns the sensor spacing in cm. 
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CONFigure:SensingRESolution and CONF:SRES? 

Note: Being replaced by the command CONF:GLEN and 
CONF:SSPA (above). 

 

CONFigure:XaxisUNIts 
Usage: CONF:XUNI {units} 
Description: Sets the X-axis units being used to specify the Integration 

(or Sensing) Area. These are the units that will be used by 
the CONF:INTW, CONF:INTS, and CONF:INTC 
commands and queries to report or set the Integration 
Width (or Sensing Range), start, and center. The units 
parameter must have one of the following values: 
0 : nanoseconds 
1 : meters 
2 : feet 
3 : inches 
4 : millimeters 

Response: None 
Example: CONF:XUNI 0 

CONF:INTW? 
Response: 15.010384 
The CONF:XUNI command sets the x-axis units to 
nanoseconds. This means that the CONF:INTW? response 
should be interpreted as 15.01 nanoseconds, and that any 
CONF:INTW, CONF:INTS, or CONF:INTC commands 
should specify their units in nanoseconds. 

 

CONFigure:XaxisUNIts? 
Usage: CONF:XUNI? 
Description: Queries the X-axis units being used to specify the 

Integration Width (or Sensing Range). These are the units 
that will be used by the CONF:INTW, CONF:INTS, and 
CONF:INTC commands and queries to report or set the 
Integration (or Sensing) width, start and center. 
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Response:         Returns a number indicating the x-axis units used to define 

the Integration (or Sensing) Area. The possible responses 
are: 
0 : nanoseconds 
1 : meters 
2 : feet 
3 : inches 
4 : millimeters 

Example: CONF:XUNI? 
Response: 1 
CONF:INTW? 
Response: 1.5 
The CONF:XUNI? response of 1 means that x-axis units are 
meters (See “CONFigure:XaxisUNIts?” on page 139). This 
means that the CONF:INTW? response should be 
interpreted as 1.5 meters, and that any CONF:INTW, 
CONF:INTS, or CONF:INTC commands should specify 
their units in meters. 

 

CONFigure:RATE 
Usage: CONF:RATE {sweepRate} 
Description: Sets the laser sweep rate in nm/sec, allowing for Fast Scan 

Mode. The default sweep rate is set by the device EEPROM 
and is usually 10 nm/sec. The rate can be set as high as 200 
nm/sec. If the user-specified sweepRate is higher or lower 
than allowed, CONF:RATE will set the sweep rate to the 
closest possible value. The CONF:RATE? query can be 
used to retrieve the actual rate that was set. Higher sweep 
rates allow faster measurements, but higher sweep rates may 
result in less accurate measurements for a device with a high 
return loss. 

Response: None 
Example: CONF:RATE 100 

This command sets the laser sweep rate to 100 nm/sec. 
 

CONFigure:RATE? 
Usage: CONF:RATE? 
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Description: Queries the laser sweep rate. 
Response: Returns the current laser sweep rate in nm/sec. 
Example: CONF:RATE? 

This query returns the laser sweep rate in nm/sec. 
 

CONFigure:GRouP 
Usage: CONF:GRP {groupIndex} 
Description: Sets the OBR Group Index. 
Response: None. 

 

CONFigure:GRouP? 
Usage: CONF:GRP? 
Description: Retrieves the OBR Group Index. 
Response: Returns the OBR Group Index. 

 

CONFigure:RESolutionGhz? 
Usage: CONF:RESG? 
Description: Retrieves the Resolution Bandwidth in GHz. 
Response: Returns the Resolution Bandwidth in GHz. 

CONFigure:RESolutionPicometers? 7 
Usage: CONF:RESP? 
Description: Retrieves the Resolution Bandwidth in picometers. 
Response: Returns the Resolution Bandwidth in picometers. 

 

CONFigure:SpatialResolutionBandWidth 
Usage: CONF:SRBW {spatialResolution} Description:
 Sets the spatial Resolution Bandwidth (mm). 
Response: None. 

 

CONFigure:SpatialResolutionBandWidth? 
Usage: CONF:SRBW? 
Description: Retrieves the spatial Resolution Bandwidth in millimeters. 
Response:  Returns the spatial Resolution Bandwidth in millimeters. 

 

CONFigure:SpatialResolutionFilterWidth 
Usage: CONF:SRFW {filterWidth} 
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Description: Sets the Spatial Resolution Filter width (ns). 
Response:  None. 

 

CONFigure:SpatialResolutionFilterWidth? 
Usage: CONF:SRFW? 
Description: Retrieves the Spatial Resolution Filter width in 

nanoseconds. 
Response: Returns the Spatial Resolution Filter width in 

nanoseconds. 
 

CONFigure:GAIN 
Usage: CONF:GAIN {gain} 
Description: Sets the gain vector index. 
Response: None. 

 

CONFigure:GAIN? 
Usage: CONF:GAIN? 
Description:  Retrieves the gain vector index. 
Response: Returns the gain vector index. 

 

CONFigure:SpatialresolutionFILter 
Usage: CONF:SFIL {0|1} 
Description: Sets the Spatial Resolution Filter, or smoothing filter, flag 

on (1), or off (0). 
Response: None. 
Note: Data can be filtered after a scan. 

 

CONFigure:SpatialresolutionFILter? 
Usage: CONF:SFIL? 
Description: Retrieves the Spatial Resolution Filter flag. 
Response: Returns “1” if the Spatial Resolution Filter flag is on, “0” 

if it is off. 
 

CONFigure:FrequencydomainWINdow 
Usage: CONF:FWIN {0|1} 
Description: Sets the frequency domain window flag, indicating whether 

or not a frequency domain window is applied to new 
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measurements. A value of 0 (do not apply window) or 1 
(apply window) must be specified as a parameter. 

Response: None 
Example: CONF:FWIN 1 

This command causes the frequency domain filter to be 
applied to all new measurement scans. 

 

CONFigure:FrequencydomainWINdow? 
Usage: CONF:FWIN? 
Description: Queries the frequency domain window flag, indicating 

whether or not a frequency domain window is applied to 
new measurement scans. 

Response: Returns a value of 0 (window is not applied) or 1 (window 
is applied). 

Example: CONF:FWIN? 
This query returns 0 or 1. 

 

CONFigure:COEFficients 
Usage: CONF:COEF {trace, t0, t1, t2, t3, t4, s0, s1, s2, s3, s4} 
Description: Sets the temperature and strain coefficients used to generate 

the Temperature Change and Strain curves. Either a trace 
(“A” through “E”) or the word (“DEFAULT”) must be 
specified as the first parameter. Specifying a trace sets the 
coefficients for that trace. Specifying “DEFAULT” sets the 
default coefficients that will be used for new measurements. 

Response: None 
Example: CONF:COEF DEFAULT, 0, -0.75, 0.05, 0.01, 0.00, -0.1, 

-0.2, -0.3, -0.4, -0.5 
Sets the default temperature coefficients to {0, -0.75, 0.05, 
0.01, 0.00}, and the default strain coefficients to {-0.1, 
-0.2, -0.3, -0.4, -0.5}. 

 

CONFigure:COEFficients? 
Usage: CONF:COEF? {trace, or “DEFAULT”} 
Description: Queries the temperature and strain coefficients used to 

generate the Temperature Change and Strain curves. Either 
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a trace (“A” through “E”) or the word (“DEFAULT”) must 
be specified as a parameter. 

Response: Returns the coefficients defined for the specified trace, or 
the default coefficients that will be used for new 
measurements. There are five temperature coefficients 
labeled t0 through t4, and five strain coefficients labeled s0 
through s4. All values are prefaced by their label and 
separated by tab characters. 

Example: CONF:COEF? A 
This query returns a message in the form 

t0: 0.000000           t1: -0.801388          t2: 0.000000 
t3: 0.000000           t4: 0.000000           s0: 0.000000 
s1: -6.668000          s2: 0.000000           s3: 0.000000 
s4: 0.000000 

 
Data Capture and Retrieval Commands 

 

FETCh:FREQuency? 
Usage: FETC:FREQ? {trace} 
Description: Queries the OBR for the starting frequency and the 

increment size, both in units of GHz. 
Response: Returns the starting frequency and increment size, separated 

by a comma. 
If no trace is specified, the values for Trace A will be 
returned. If a successful scan has not been made before this 
query, the OBR responds with “Trace A (B, etc.) contains 
no data.” 

Example: FETC:FREQ? B 
This query returns a message in the form 
“193414.488699,0.001214,” meaning the starting frequency 
for Trace B is 193414.488699 GHz and the frequency 
increment size/sample spacing is 0.001214 GHz. 

 

FETCh:FSIZe? 
Usage: FETC:FSIZ? {trace, domain, graphType, decimate} Trace 

is specified as a single letter: A, B, C, D or E. Domain 
can be set to 0 for time domain, or 1 for frequency 
domain. 
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graphType Graph/Parameter Name 

Time Domain (domain = 0) Values 

0 Amplitude 

1 Linear Amplitude 

2 Polarization States 

3 Phase Derivative 

4 Amplitude (dB) 

5 Spectral Shift (only on some units) 

6 Temporal Shift (only on some units) 

7 Strain (only on some units) 

8 Temporal Shift (only on some units) 

Frequency Domain (domain = 1) Values 

0 Return Loss 

1 Linear Amplitude 

2 Polarization States 

3 Group Delay 

 

 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 

7 
 

 
 
 
 
 

GraphType can take values from 0 to 8, as shown above. 
However, parameters 5 through 8 are only available when 
purchased as a separate option. The assignment of 
graphType depends on which domain is specified. (Note 
that this list of values for graphType may be retrieved using 
the FETC:GNAM? query, below.) 
Decimate can be set to 1 to use decimation, or 0 to return 
all points. 

Description: Retrieves the size of the data arrays; i.e. the number of data 
samples to expect from the FETC:MEAS? queries. 
All parameters must be specified. 
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This query should be called before performing the 
FETC:MEAS? command if the controller program needs to 
pre-allocate space for the data. 

Example: FETC:FSIZ? A, 0, 0, 1 
This command returns the data array size of Trace A’s time 
domain amplitude data, with data decimation on. 

Response: The response is an integer indicating the number of data 
samples to expect from the FETC:MEAS? queries. 
If a successful scan has not been made before this query, 
the OBR responds with “Trace A (B, etc.) contains no data.” 

 

FETCh:GraphNAMe? 
Usage: FETC:GNAM? 
Description: Retrieves the available graph names for all numeric values 

of graphType for both time and frequency domain. This 
allows the user to see what curve is associated with what 
graphType value when calling FETC:MEAS? and other 
commands that use the graphType parameter. 

Response: The query returns the list of values of graphType for each 
domain, as shown above under FETC:FSIZ?, beginning on 
page 145. 

 

FETCh:GraphSTRings? 
Usage: FETC:GSTR? {domain, graphType, xUnits} 
Description: Retrieves the graph title or name, the Y-axis label, and the 

X-axis label for the specified domain, graphType, and 
xUnits. 
Domain can be set to 0 for time domain, or 1 for frequency 
domain. 
GraphType can take values from 0 to 4 or 8, as shown in 
the table beginning on page 145. The assignment of 
graphType depends on which domain is specified. 
xUnits for the time domain can be set to 0 for time (ns), 1 
for length (m), 2 for length (ft), 3 for inches (in), or 4 for 
length (mm). 
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xUnits for the frequency domain can be set to 0 for 
wavelength (nm), 1 for frequency (GHz), or 2 for frequency 
(THz). 

Response: Returns the curve name or title on the first line, Y-axis label 
on the second line, and the X-axis label on the third line. 
The returned strings can be used to properly label a graph 
plotted with values obtained from the FETC:MEAS? and 
FETC:XAXI? queries. 

Examples: FETC:GSTR? 0, 0, 1 
Returns graph title, Y-axis label, and X-axis label in the 
form: 
Amplitude 
Amplitude (dB/mm) 
Length (m) 

 

 
FETC:GSTR? 1, 3, 0 
Returns: Group 
Delay Group 
Delay (ns) 
Wavelength (nm) 

 

FETCh:MEASurement? 
Usage: FETC:MEAS? {trace, domain, graphType, decimate} 

Trace is specified as a single letter: A, B, C, D or E. 
Domain can be set to 0 for time domain, or 1 for frequency 
domain. 
GraphType can take values from 0 to 4 or 8, as shown in 
the table above. The assignment of graphType depends on 
which domain is specified. These values are listed in the 
table above, beginning on page 145. 
Decimate can be set to 1 to use decimation, or 0 to return 
all points. 

Description: Retrieves the Y-axis data for the specified parameters. The 
portion of the data that is returned is determined from the 
Integration (or Sensing) Area previously specified with 
the CONF:INTW, CONF:INTS, and CONF:INTC 
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commands. If the Integration Width (or Sensing Range) 
is set to 0, then the Y-axis data is returned for the entire 
measurement area. 
This query is usually preceded by the FETC:FSIZ? query 
to determine the number of data points that will be returned. 
All parameters must be specified. 

Response: Returns a series of numbers representing the Y-axis data 
points for the requested area. 
The data are returned as an array with each element in 
floating point format with ten significant digits and possible 
exponent field of the form [?]d.ddddddddd[e[?]ddd]. 
If space needs to be allocated for the receiving buffer, the 
amount required for each element is 18, including a carriage 
return as the delimiter. 
The number of points is the same as the value obtained by 
sending the FETC:FSIZ? request with the same parameters. 
The string "///" is returned after the last data point to indicate 
that the response is complete. 
If a successful scan has not been made before this query, 
the OBR responds with “Trace A (B, etc.) contains no data.” 

Example: FETC:MEAS? C, 1, 3, 1 
Retrieves the Y-axis data for Trace C’s frequency domain 
phase derivative data, with decimation on. 
-101.101531 
-102.912509 
-99.7946707 
... 
-102.621305 
-72.7263532 
/// 

 
FETCh:XAXIs? 

Usage: FETC:XAXI? {trace, domain, units, decimate} 
Trace is specified as a single letter: A, B, C, D or E. 
Domain can be set to 0 for time domain, or 1 for frequency 
domain. 
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Units for the time domain can be set to 0 for time (ns), 1 
for length (m), 2 for length (ft), 3 for length (in), or 4 for 
length (mm). 
Units for the frequency domain can be set to 0 for 
wavelength (nm), 1 for frequency (GHz), or 2 for frequency 
(THz). 
Decimate can be set to 1 to use decimation, or 0 to return 
all points. 

Description: Retrieves the X-axis data for the specified parameters. 
All parameters must be specified. 

Response: Returns a series of numbers representing the X-axis data 
points for the requested area. The number of points is the 
same as the value obtained by sending the FETC:FSIZ? 
query with the same parameters. The string "///" is returned 
after the last data point to indicate that the response is 
complete. 
The data are returned as an array with each element in 
floating point format with ten significant digits and possible 
exponent field of the form [?]d.ddddddddd[e[?]ddd]. 
If space needs to be allocated for the receiving buffer the 
amount required for each element is 18, including a carriage 
return as the delimiter. 
If a successful scan has not been made before this query, 
the OBR responds with “Trace A (B, etc.) contains no data.” 
The cause of error can be retrieved by using the 
SYST:ERRD? query. 

Example: FETC:XAXI? C, 1, 0, 1 
This query returns the frequency domain X-axis data from 
Trace C, in nanometers, decimated, in the form: 

1509.97 
1509.99 
... 
1525.01 
1525.02 
/// 

 

FETCh:MeasurementDETails? 
Usage: FETC:MDET? {trace} 



150   Chapter 7 
Controlling the OBR Remotely 

 

 

7 

 
Description: Queries the OBR for current measurement Details for trace 

specified. The trace is specified as a single letter: A, B, C, 
D or E. 

Response: Returns a string of information (shown below) about the 
specified (A-E) or default (A) trace. 
If no trace is specified, the measurement Details for Trace 
A will be returned. If a successful scan has not been made 
before this query, the OBR responds with “Trace A (B, etc.) 
contains no data.” The cause of error can be retrieved by 
using the SYST:ERRD? query. 

Example: FETC:MDET? 
This query returns a message in the form: 

Trace: A  
Starting frequency (GHz): 193414.488699  
Frequency increment (GHz): 0.001214  
Segment size: 2097152  
Starting time (ns): -55.000141  
Time increment (ns): 0.000393  
Measurement type: 0  
Group index: 1.500000  
Time stamp: 1/20/2005 16:23:43  
Filename: C:\obr data\Jan20_10m.obr  
Device descriptor: Network switch 

 

FETCh:RAW? 
Usage: FETC:RAW? {trace} 

Trace is specified as a single letter: A, B, C, D or E. 
Description: Retrieves the raw S and P data for the specified trace. 

The portion of the data that is returned is determined from 
the Integration Width (or Sensing Range) previously 
specified with the CONF:INTW, CONF:INTS, and 
CONF:INTC commands. If the Integration Width (or 
Sensing Range) is set to 0, then the data is returned for the 
entire measurement area. 

Response:         Returns a series of four tab-separated numbers, each set of 
numbers representing the S and P values for a single point. 
The number of points is the same as the value obtained by 
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sending the FETC:RSIZ? request with the same trace 
parameter. 
The values for each point are formatted as: 
{S real <tab> S imaginary <tab> P real <tab> P imaginary} 
The string "///" is returned after the last data point to indicate 
that the response is complete. 
If no trace is specified, the data for Trace A will be returned. 
If a successful scan has not been made before this query, 
the OBR responds with “Trace A (B, etc.) contains no data.” 

Example: FETC:RAW? C 
Returns the S and P data for Trace C in the form: 
-6.27743856e+066  -6.27743856e+066  -6.27743856e+066   -6.27743856e+066 
-6.27743856e+066  -6.27743856e+066  -6.27743856e+066   -6.27743856e+066 
... 
-6.27743856e+066  -6.27743856e+066  -6.27743856e+066   -6.27743856e+066 
-6.27743856e+066  -6.27743856e+066  -6.27743856e+066   -6.27743856e+066 
/// 

 

FETCh:RawdataSIZe? 
Usage: FETC:RSIZ? {trace} 
Description: Retrieves the size of the raw S and P data for the specified 

trace. This is the number of data points that will be returned 
by the FETC:RAW? query using the current Integration 
Area [or in purchased Sensing Mode (page 48), the 
Sensing Area] as specified by the CONF:INTW, 
CONF:INTS, and CONF:INTC commands. 

Response: Returns the size of the raw S and P data for the specified 
trace. 
If no trace is specified, the data size for Trace A will be 
returned. If a successful scan has not been made before this 
query, the OBR responds with “Trace A (B, etc.) contains 
no data.” 

 

FETCh:FrequencydomainDETail? 
Usage: FETC:FDET? {trace, graphType, decimate} 

Trace is specified as a single letter: A, B, C, D or E. 
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GraphType can take values from 0 to 4, as shown in the table 
beginning on page 145. Only the frequency domain values 
of graphType are used in this command. 
Decimate can be set to 1 to use decimation, or 0 to return 
all points. 

Description: Retrieves additional detail for the frequency domain curves. 
Response: Returns integrated insertion loss (dB) for graphType = 0, 

and average delay (ns) for graphType = 1 or 2. 
 

FETCh:WaveLength? 
Usage: FETC:WL? {trace} 

Trace is specified as a single letter: A, B, C, D or E. 
Description: Retrieves the starting wavelength (nm) for the specified 

trace. 
Response: Returns the starting wavelength, in nanometers, for the 

specified trace. If no trace is specified, the starting 
wavelength for Trace A is returned. If a successful scan has 
not been made before this query, the OBR responds with 
“Trace A (B, etc.) contains no data.” 

 

FETCh:WaveLengthCenter? 
Usage: FETC:WLC? {trace} 

Trace is specified as a single letter: A, B, C, D or E. 
Description: Retrieves the center wavelength (nm) for the specified 

trace. 
Response: Returns the center wavelength, in nanometers, for the 

specified trace. If no trace is specified, the center 
wavelength for Trace A is returned. If a successful scan has 
not been made before this query, the OBR responds with 
“Trace A (B, etc.) contains no data.” 

 

FETCh:WaveLengthEnd? 
Usage: FETC:WLE? {trace} 

Trace is specified as a single letter: A, B, C, D or E. 
Description: Retrieves the ending wavelength (nm) for the specified 

trace. 
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Response: Returns the ending wavelength, in nanometers, for the 

specified trace. If no trace is specified, the ending 
wavelength for Trace A is returned. If a successful scan has 
not been made before this query, the OBR responds with 
“Trace A (B, etc.) contains no data.” 

 

FETCh:INTegrationLoss? 
Usage: FETC:INTL? {trace} 

Trace is specified as a single letter: A, B, C, D or E. 
Description: Retrieves the loss of the current Integration Area [or in 

purchased Sensing Mode (page 48), the Sensing Area] for 
the specified trace. The Integration (or Sensing) Area is 
the area previously specified by the CONF:INTW, 
CONF:INTS, and CONF:INTC commands. 

Response: Returns the loss in dB for the current Integration (or 
Sensing) Area of the specified trace. If no trace is 
specified, the loss for Trace A is returned. If a successful 
scan has not been made before this query, the OBR responds 
with “Trace A (B, etc.) contains no data.” 

 

FETCh:TimedomainINCrement? 
Usage: FETC:TINC? {trace} 

Trace is specified as a single letter: A, B, C, D or E. 
Description: Retrieves the time increment of the Time Domain Window 

X-axis in nanoseconds (ns). 
Response: Returns the time increment of the Time Domain Window 

X-axis in nanoseconds. If no trace is specified, the time 
increment for Trace A is returned. If a successful scan has 
not been made before this query, the OBR responds with 
“Trace A (B, etc.) contains no data.” 

Example: FETC:TINC? 
This query returns a message in the form “0.000567” ns. 

 

FETCh:TIMeStart? 
Usage: FETC:TIMS? {trace} 

Trace is specified as a single letter: A, B, C, D or E. 
Description: Retrieves the start time for the specified trace. 
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Response: Returns the start time in nanoseconds for the specified trace. 

If no trace is specified, the start time for Trace A is returned. 
If a successful scan has not been made before this query, 
the OBR responds with “Trace A (B, etc.) contains no data.” 

 

FETCh:TIMEnd? 
Usage: FETC:TIME? {trace} 

Trace is specified as a single letter: A, B, C, D or E. 
Description: Retrieves the end time for the specified trace. 
Response:         Returns the end time in nanoseconds for the specified trace. 

If no trace is specified, the end time for Trace A is returned. 
If a successful scan has not been made before this query, 
the OBR responds with “Trace A (B, etc.) contains no data.” 

 

FETCh:LENgthStart? 
Usage: FETC:LENS? {trace} 

Trace is specified as a single letter: A, B, C, D or E. 
Description: Retrieves the start length for the specified trace. 
Response: Returns the start length in meters for the specified trace. If 

no trace is specified, the start length for Trace A is returned. 
If a successful scan has not been made before this query, 
the OBR responds with “Trace A (B, etc.) contains no data.” 

 

FETCh:LENgthEnd? 
Usage: FETC:LENE? {trace} 

Trace is specified as a single letter: A, B, C, D or E. 
Description: Retrieves the end length for the specified trace. 
Response: Returns the end length in meters for the specified trace. If 

no trace is specified, the end length for Trace A is returned. 
If a successful scan has not been made before this query, 
the OBR responds with “Trace A (B, etc.) contains no data.” 

 
Example Visual Basic Code 

This section provides sample code in Visual Basic to explain how the OBR behaves 
when accessed remotely. Users can write their own applications in Visual Basic using 
the sample code given below for multiple types of parameters. Note: Visual Basic 
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is used only as an example, and users may use other programming languages of their 
choosing. 

 
Notes: 

 

• The device GPIB handle is "OBRGpibHandle" 
 

• To open an OBRGpibHandle use: OBRGpibHandle% = ildev 
(BOARD_INDEX, PRIMARY_ADDR, SECONDARY_ADDR, 
TIMEOUT, EOTMODE, EOSMODE) 

 

• To clear an OBR GpibHandle use: ilclr OBRGpibHandle%. 
 

• To close an OBR GpibHandle use: ilonl OBRGpibHandle%, 0. 
 

• To write to the instrument board use: ilwrt OBRGpibHandle%, 
OBRCommand, Len(OBRCommand). 

 

• To read the response from the instrument use: ilrd OBRGpibHandle%, 
Response, Len(Response). 

 

• To check response size use: ibcntl. 
 

Sending Commands without Parameters 

Public Sub DoScan() 7 
 

Const OBRCommand = "SCAN" 
ilwrt OBRGpibHandle%, OBRCommand, Len(OBRCommand) 

End Sub 

Sending Commands with Single Numeric Parameters 
 

Public Sub SetStartWL(ByVal WL As Double) 
' check input parameter 

 
If (WL < 0) Then 

Exit Sub 
End If 

 
Dim OBRCommand As String 

 
OBRCommand = "CONF:STAR" & CStr(WL) 
ilwrt OBRGpibHandle%, OBRCommand, Len(OBRCommand) 
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End Sub 

 
Sending Commands with Single String Parameters 

Public Function CommandSystemLoadFile(ByVal FilePath As String) 

Dim OBRCommand As String 
OBRCommand = "SYST:LOAD " & FilePath 
ilwrt OBRGpibHandle%, OBRCommand, Len(OBRCommand) 

End Function 

Sending Commands with Multiple Parameters 
 

Public Sub GetDataSize(ByVal Trace As String 
ByVal Domain  As Integer 
ByVal GraphType As Integer 
ByVal Decimate As Integer) 

Dim OBRCommand As String 
 

OBRCommand = “FETC:FSIZ?” & Trace & “, “ & CStr(Domain) & _ 
", " & Cstr(GraphType) & ", " & CStr(Decimate) 

ilwrt OBRGpibHandle%, OBRCommand, Len(OBRCommand) 

7 End Sub
 

Sending Queries which return Numeric Results 
 

Public Function QueryOperateComplete() As Integer 
 

Const OBRCommand = "*OPC?" 
ilwrt OBRGpibHandle%, OBRCommand, Len(OBRCommand) 
Response = "" 
ilrd OBRGpibHandle%, Response, Len(Response) 

 
If ibcntl < Len(Response) And ibcntl > 0 Then 

Response = Left(Response, ibcntl) 
End If 

 
If IsNumeric(Response) Then 

QueryOperateComplete = CInt(Response) 
Else 

QueryOperateComplete = 0 
End If 
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End function 

 
Sending Queries which return Double Results 

 
Public Function QueryConfigureIntW() As Double 

 
Const OBRCommand = "CONF:INTW?" 
ilwrt OBRGpibHandle%, OBRCommand, Len(OBRCommand) 
Response = "" 
ilrd OBRGpibHandle%, Response, Len(Response) 

 
If ibcntl < Len(Response) And ibcntl > 0 Then 

Response = Left(Response, ibcntl) 
End If 

 
If IsNumeric(Response) Then 

QueryConfigureIntW = CDbl(Response) 
Else 

QueryConfigureIntW = 0 
End If 

 
End function 

 
Sending Queries which return Two Double Results 

 
Public Sub QueryFrequency(ByRef Frequency As Double, ByRef 
Increment As Double) 

 
Dim TabPos As Integer 
Dim TempStr As String 
Const OBRCommand = "FETC:FREQ?" 
ilwrt OBRGpibHandle%, OBRCommand, Len(OBRCommand) 
Response = "" 
ilrd OBRGpibHandle%, Response, Len(Response) 

 
If ibcntl < Len(Response) And ibcntl > 0 Then 

Response = Left(Response, ibcntl) 
End If 

 
TabPos = InStr(1, Response, vbTab) 
If (TabPos = 0) Then 

Exit Sub 
End If 

 
TempStr = Left(Response, TabPos - 1) 
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If IsNumeric(TempStr) Then 

Frequency = CDbl(TempStr) 
Else 

Frequency = 0 
End If 

TempStr = Right(Response, Len(Response) - TabPos) 

If IsNumeric(TempStr) Then 
Increment = CDbl(TempStr) 

Else 
Increment = 0 

End If 
 

End Sub 
 

Sending Queries which return String Results 
 

Public Function QueryID() As String 
 

Const OBRCommand = "*IDN?" 
ilwrt OBRGpibHandle%, OBRCommand, Len(OBRCommand) 
Response = "" 
ilrd OBRGpibHandle%, Response, Len(Response) 

 
If ibcntl <= Len(Response) And ibcntl > 0 Then 

QueryID = Left(Response, ibcntl) 
Else 

QueryID = "" 
End If 

 
End function 

 
Sending Queries which return Arrays of Double Results 

Sample Basic for the “FETC:MEAS?” commands depends on the FetchData 
subroutine: 

 
 

Public OBRGpibHandle As Integer 
 

Const ElementLength = 18 
 

Const ArraySize = 1024 ' Size of read buffer 
 

Dim Response As String * ArraySize ' fixed-length string 
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Private Sub FetchData(ByVal OBRQuery As String, ByRef _ DataArray() 
As Double, ByVal DataSize As Long) 
' DataArray is 1D array, that is, (0 To DataSize - 1) 

 
On Error Resume Next 

 
Dim PrevCRPos As Long, CurCRPos As Long 
Dim DynamicResponse As String, TempStr As String 
Dim ArrayIndex As Long 
Dim ExitLoop As Boolean 

 
If DataSize <= 0 Then 

Exit Sub 
End If 

 
' Send Query 
ilwrt OBRGpibHandle%, OBRQuery, Len(OBRQuery) 

 
' Allocate Buffer Dynamically 
DynamicResponse = Space(DataSize * ElementLength) 

 
' Receive Data 
ilrd OBRGpibHandle%, DynamicResponse, Len(DynamicResponse) 

 
If ibcntl <= Len(DynamicResponse) And ibcntl > 0 Then 

DynamicResponse = Left(DynamicResponse, ibcntl) 
Else 

Exit Sub 
End If 

 
PrevCRPos = 1 
ArrayIndex = 0 
ExitLoop = False 

 
Do 

CurCRPos = InStr(PrevCRPos, DynamicResponse, vbCr) 
 

If (CurCRPos = 0) Then 
CurCRPos = Len(DynamicResponse) + 1 
ExitLoop = True 

End If 
 

TempStr = Mid(DynamicResponse, PrevCRPos, CurCRPos - 
PrevCRPos) 
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If IsNumeric(TempStr) Then 

DataArray(ArrayIndex) = CDbl(TempStr) 
Else 

DataArray(ArrayIndex) = 0 
End If 

 
PrevCRPos = CurCRPos + 1 
ArrayIndex = ArrayIndex + 1 
If ArrayIndex = DataSize Then 

ExitLoop = True 
End If 

Loop Until ExitLoop = True 
 

End Sub 

 
Command Errors 

When a command is ill-formed, such as when a required parameter is omitted, the 
OBR ignores the command. 

 

Use the SYST:ERRD? query to retrieve the most recent error description. 
 

Execution Errors 
 

Execution errors indicate problems during the execution of a valid command, and 
may happen when: 

 

• The instrument fails to communicate to the control computer 
because of a problem with the instrument or cable connections. 

• A command is given in an improper sequence; for example, a 
FETC:MEAS? query is sent before a scan has been performed. 

 

Like command errors, execution errors can only be retrieved if the controlling 
computer queries the OBR using the SYST:ERRD? query. 

 
Setting Up a TCP/IP Console 

Use the following steps to install a TCP/IP remote controller for the OBR instrument: 
 

1 Copy the executable file named “SendCmd.exe” from the supplied CD 
to the local hard drive (usually the C:\ drive) of the host computer. 

 

2 Run SendCmd.exe from the DOS command prompt. 
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3 Enter commands in the following format: 

 
C:\SendCmd [CmdStr] [IPaddr] [PortNum] [Comment] 

 

where 
 

• [CmdStr] is the remote control command to be sent to the OBR. 
• [IPaddr] is the IP address of the OBR PC. 
• [PortNum] is the port number where OBR instrument is listen- 

ing (port number is ‘1’ by default, but this can be configured 
using pull down menu Options > Remote Interface Setup). 

• [Comment] is an optional comment to be passed with the com- 
mand. 

 
Notes: 

 

• Accessing the local machine does not require [IPaddr]. This option 
allows the console application to run on the OBR PC. 

 

• The argument [IPaddr] can be a system name or an IP address of a 
machine where the OBR software is running. 

 

• To ascertain the IP address of the OBR PC, select Run from the Win- 
dows® Start menu. Type in “ipconfig” in the text box and click OK. 
The IP address should be listed in the screen that opens. Or, the user 
may call “ipconfig” from the DOS command line to get the IP address. 

 

• When accessing OBR remotely using TCP/IP, make sure to provide the 
port number. The OBR will be listening and responding at port 1 by 
default. The remote controller should use the same port number as the 
OBR. 

 

• Commands, queries, and arguments must be in quotes if they contain 
spaces. 

 

Example: 
 

SendCmd "FETC:MEAS? C, 1, 0, 1" 
 

• To avoid problems in the parsing of commands, each optional argument 
must be replaced with "" in the command line if you do not want to give 
some optional arguments. 

 

• The results of a command or query can be redirected to a file using "> 
Filename" or “>> Filename” at the end of the command. 
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Examples: 

 
SendCmd "FETC:MEAS? A, 0, 0, 1" > testdata.txt 
SendCmd "FETC:MEAS? B, 0, 0, 1" >> testdata.txt 

 

• The argument [Comment] may be up to 512 bytes in size and must be 
entered in quotes. If no comment is entered, a the default comment will 
appear, giving a general description of the command or query. Com- 
ments are generally used to record the type of data when results of a 
command are saved to a file. 

 

• Multiple commands may be grouped together in scripts. 
 

Examples: 
 

systemSetup.sh is a shell script that runs all commands as a batch. 
{ 

SendCmd SYST:ALIG 10.1.1.69 1 
SendCmd “CONF:CWL 1550.0,1” 10.1.1.69 
SendCmd “CONF:RANG 80,1” 10.1.1.69 1 
SendCmd “CONF:AVGS 5,1” 10.1.1.69 1 
SendCmd SYST:CAL 10.1.1.69 1 
SendCmd SYST:ERR? 10.1.1.69 1 

} 
acqMeasurement.sh is a shell script that runs all commands as a 
batch. 

{ 
SendCmd "CONF:STAR 1525.00" 10.1.1.69 1 
SendCmd "CONF:RANG 40" 10.1.1.69 1 
SendCmd SCAN 10.1.1.69 1 
SendCmd FETC:GD? 10.1.1.69 1 > C:\40nmScan\acquireGD.txt 
SendCmd FETC:CD? 10.1.1.69 1 > C:\40nmScan\acquireCD.txt 
SendCmd FETC:PMD? 10.1.1.69 1 > C:\40nmScan\acquirePMD.txt 

} 
 

• All commands are case sensitive in this application, but the user may 
write applications without case sensitivity. 

 

• Note that some of the OBR commands (SYST:CAL 0, SCAN) may 
require a large amount of time to run. When writing a host or controller 
application, make sure to allow enough delay for these commands. 
After executing one of these commands, check to see if the operation is 
complete using the query *OPC?. 
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IEEE 488.2 standard commands  

*CLS Clears the status register. 122 

*ESE {n} Sets the value (0–255) of the Status Enable register. 122 

*ESE? Queries the current value of the Status Enable register. 122 

*ESR? Queries the value of the Status Event Status register. 122 

*IDN? Queries the OBR for its identification string. 122 

*OPC {0|1} Sets the event bit in the Standard Event Status register, 
enabling (1) or disabling (0) “operation complete” event 
notification. 

 
122 

*OPC? This query returns "1" if the previous operation has been 
completed; "0" if the previous operation is still processing. 

 
123 

*QUIT Ends a remote session, allowing the OBR to go back to local 
control mode. 

 
121 

*RST Instructs the OBR to reset all parameters to the power-on 
defaults. 

 
123 

*SRE {n} Sets the Service Request Enable register to n, where n = 0- 
255. 

 
123 

 

 
Alphabetical Command Summaries 

The table below provides summaries of GPIB and TCP/IP commands, listed 
alphabetically by command. For detailed information about each command, see 
“Remote Control Commands for the OBR” above, beginning on page 120. All 
commands are given in their truncated form, and are case-sensitive. They must be 
entered exactly as they appear in this chapter. 

 

 
Important The OBR control software does not support multiple 

commands on a line, separated by semicolons. Enter each 
                command on its own separate line. 
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*SRE? Queries the current value of the Service Request Enable 
register. 

 
123 

*STB? Queries the value of the Status Byte register. 123 

*TST? Performs a self-test query. 124 

*WAI Prevents the OBR from executing any further commands or 
queries until all pending operations have been completed. 

 
123 

Configuration commands Page 

CONF:COEF Sets the temperature and strain coefficients used to generate 
the Temperature Change and Strain curves. 

 
143 

CONF:COEF? Retrieves the temperature and strain coefficients used to 
generate the Temperature Change and Strain curves. 

 
144 

CONF:CWL 
{centerWavelength} 

Sets the Center Wavelength (nm).  
132 

CONF:CWL? Retrieves the OBR for the current Center Wavelength (nm). 132 

CONF:DRAN Sets the OBR distance range. 135 

CONF:DRAN? Retrieves the OBR distance range. 135 

CONF:DUTL Sets the DUT length to the value specified in meters for 
Extended Range mode. 

 
136 

CONF:DUTL? Queries the current DUT length for Extended Range mode. 136 

CONF:END? Queries the OBR for the current ending wavelength (nm). 133 

CONF:FWIN { 0 | 1 } Sets the frequency domain window flag. 143 

CONF:FWIN? Retrieves whether or not a frequency domain window is 
applied to new measurement scans. 

 
143 

CONF:GAIN Sets the gain vector index. 142 

CONF:GAIN? Retrieves the gain vector index. 142 

CONF:GLEN 
{gaugeLength} 

Sets the gauge length in cm.  
138 

CONF:GLEN? Retrieves the gauge length in cm. 138 
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CONF:GRP Sets the OBR Group Index. 141 

CONF:GRP? Retrieves the OBR Group Index. 141 

CONF:INTC Sets the OBR integration center in the units set by 
CONF:XUNI (page 139). 

 
137 

CONF:INTC? Retrieves the OBR Integration (or Sensing) Area center in 
the units set by CONF:XUNI (page 139). 

 
138 

CONF:INTS Sets the OBR Integration (or Sensing) Area start in the units 
set by CONF:XUNI (page 139). 

 
137 

CONF:INTS? Retrieves the OBR Integration (or Sensing) Area start in the 
units set by CONF:XUNI (page 139). 

 
137 

CONF:INTW Sets the OBR Integration Width (or Sensing Range) in the 
units set by CONF:XUNI (page 139). 

 
134 

CONF:INTW? Retrieves the OBR Integration Width (or Sensing Range) in 
the units set by CONF:XUNI (page 139). 

 
135 

CONF:RANG 
{scanRange} 

Sets the Scan Range in nanometers.  
133 

CONF:RANG? Queries the OBR for the current Scan Range (nm). 134 

CONF:RATE Sets the laser sweep rate in nm/sec. 140 

CONF:RATE? Queries the laser sweep rate in nm/sec. 141 

CONF:RESG? Retrieves the Resolution Bandwidth in GHz. 141 

CONF:RESP? Retrieves the Resolution Bandwidth in picometers. 141 

CONF:SFIL Sets the Spatial Resolution Filter, or smoothing filter flag on 
(1), or off (0). Data can be filtered after a scan. 

 
142 

CONF:SFIL? Retrieves the Spatial Resolution Filter flag. 142 

CONF:SRAN In optional Sensing mode (page 47), sets the OBR Sensing 
Range in the units set by CONF:XUNI (page 132). 

 
136 

CONF:SRAN? Retrieves the OBR Sensing Range in the units set by 
CONF:XUNI (page 132). 

 
137 

CONF:SRBW Sets the spatial Resolution Bandwidth (mm). 141 
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CONF:SRBW? Retrieves the spatial Resolution Bandwidth in millimeters. 141 

CONF:SRFW Sets the Spatial Resolution Filter width (ns). 142 

CONF:SRFW? Retrieves the Spatial Resolution Filter width in 
nanoseconds. 

 
142 

CONF:SSPA Sets the Sensor Spacing in cm. 138 

CONF:SSPA? Retrieves the Sensor Spacing in cm. 139 

CONF:STAR 
{startWavelength} 

Sets the startWavelength (nm) for the scan.  
133 

CONF:STAR? Queries the OBR for the current start wavelength (nm). 133 

CONF:XUNI Sets the x-axis units being used to specify the Integration (or 
Sensing) Area. 

0 : nanoseconds 
1 : meters 
2 : feet 
3 : inches 
4: millimeters 

 
 
 
 

139 

CONF:XUNI? Queries the x-axis units being used to specify the Integration 
(or Sensing) Area. 

0 : nanoseconds 
1 : meters 
2 : feet 
3 : inches 
4: millimeters 

 
 
 
 

139 

Data capture and retrieval commands Page 

FETC:FDET? 
{trace, graphType, 
decimate} 

Retrieves additional detail for the frequency domain curves: 
integrated insertion loss (dB) for graphType = 0, and average 
delay (ns) for graphType = 1 or 2. 

 
152 

FETC:FREQ? 
{trace} 

Queries the OBR for the starting frequency and the increment 
size, both in units of GHz, for the trace specified (A-E). 

 
144 
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FETC:FSIZ? {trace, 
domain, graphType, 
decimate} 

Retrieves the size of the data array for the specified variables: 
Trace can be A, B, C, D or E. 
Domain = 0 for the time domain, 1 for frequency domain. 
GraphType values for the time domain (0): 

0 = Amplitude 
1 = Linear Amplitude 
2 = Polarization States 
3 = Phase Derivative 
4 = Amplitude (dB) 
5 = Spectral Shift (only on some instruments) 
6 = Temporal Shift (only on some instruments) 
7 = Strain (only on some instruments) 
8 = Temporal Shift (only on some instruments) 

GraphType values for the frequency domain (1): 
0 = Return Loss 
1 = Linear Amplitude 
2 = Polarization States 
3 = Group Delay 

Decimate: 1 = use decimation, 0 = return all points. 

 
 
 
 
 
 
 
 
 
 
 
 

145 

FETC:GNAM? Retrieves the available graph names for all numeric values of 
graphType for both time and frequency domain, as listed 
above under FETC:FSIZ? 

 
146 
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FETC:GSTR? 
{domain, 
graphType, xUnits} 

Retrieves the graph title or name, the Y-axis label, and the X- 
axis label for the specified domain, graphType, and xUnits. 
Domain = 0 for the time domain, 1 for frequency domain. 
GraphType values for the time domain (0): 

0 = Amplitude 
1 = Linear Amplitude 
2 = Polarization States 
3 = Phase Derivative 
4 = Amplitude (dB) 
5 = Spectral Shift (only on some instruments) 
6 = Temporal Shift (only on some instruments) 
7 = Strain (only on some instruments) 
8 = Temporal Shift (only on some instruments) 

GraphType values for the frequency domain (1): 
0 = Return Loss 
1 = Linear Amplitude 
2 = Polarization States 
3 = Group Delay 

xUnits values for the time domain (0): 
0 = time (ns) 
1 = length (m) 
2 = length (ft) 
3 = length (in) 
4 = length (mm) 

xUnits for the frequency domain (1): 
0 = wavelength (nm) 
1 = frequency (GHz) 
2 = frequency (THz) 

 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 

146 

FETC:INTL? {trace} Retrieves the loss of the current Integration (or Sensing) 
Area for the specified trace. 

 
153 

FETC:LENE? 
{trace} 

Retrieves the end length for the specified trace.  
154 

FETC:LENS? 
{trace} 

Retrieves the start length for the specified trace.  
154 
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FETC:MDET? 
{trace} 

Queries the OBR for current measurement Details for the 
trace specified (A-E). 

 
150 

FETC:MEAS? 
{trace, domain, 
graphType, 
decimate} 

Retrieves the Y-axis data for the specified parameters. (For 
variable definitions, see “FETC:FSIZ? above.) 

 
 

147 

FETC:RAW? {trace} Retrieves the raw S and P data for the specified trace. 150 

FETC:RSIZ? {trace} Retrieves the size of the raw S and P data for the specified 
trace. 

 
151 

FETC:TIMS? {trace} Retrieves the start time in nanoseconds for the specified trace. 153 

FETC:TIME? {trace} Retrieves the end time for the specified trace. 154 

FETC:TINC? {trace} Queries the OBR for the time increment of the Time Domain 
X-axis in nanoseconds (ns) for the trace specified. 

 
153 

FETC:WL? {trace} Retrieves the starting wavelength (nm) for the specified trace. 152 

FETC:WLC? {trace} Retrieves the Center Wavelength (nm) for the specified trace. 152 

FETC:WLE? {trace} Retrieves the ending wavelength (nm) for the specified trace. 152 

FETC:XAXI? {trace, 
domain, units, 
decimate} 

Retrieves the X-axis data for the specified variables: 
Trace can be A, B, C, D or E. 
Domain = 0 for the time domain, 1 for frequency domain. 
Units for the time domain (0): 

0 = time (ns) 
1 = length (m) 
2 = length (ft) 
3 = length (in) 
4 = length (mm) 

Units for the frequency domain (1): 
0 = wavelength (nm) 
1 = frequency (GHz) 
2 = frequency (THz). 

Decimate: 1 = use decimation, 0 = return all points. 

 
 
 
 
 
 
 
 
 

149 

System level commands Page 
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SCAN Tells the OBR to execute an optical Scan based on the 
configured system parameters. 

 
124 

SYST:ACQ? Queries whether data has been acquired (1) or not (0). 131 

SYST:ALIG Aligns the optics 126 

SYST:ALIG? Queries the OBR if the optics are aligned (1) or not (0). 127 

SYST:CAL Calibrates the system. 127 

SYST:CAL? Queries the system calibration status. Returns “1” if the 
system is calibrated successfully or “0” if it is not. 

 
127 

SYST:CALF {0, 
filename} 

Sets the name of the calibration file. If the filename is not 
specified, this command sets calibration file to the default 
filename, obrCal_refl. 

 
128 

SYST:CALF? 0 Retrieves the name of the calibration file. 129 

SYST:COPY 
{source, destination} 

Copies data from the source trace (A-E) to the destination 
trace (A-E). 

 
131 

SYST:ERR? Returns a numeric error code. Zero (0) indicates no error; i.e. 
the last command or query completed successfully. Any non- 
zero number indicates that an error has occurred. A 
description of the error may be retrieved with the query 
SYST:ERRD? 

 

 
 

126 

SYST:ERRD? Retrieves the detailed error description for the most recent 
remote operation. 

 
126 

SYST:GET? {trace} Queries whether data is loaded in the specified trace (A-E). 131 

SYST:LASE {0|1} Turns the laser on (1) or off (0). 125 

SYST:LASE? Queries if the laser is on (1) or off (0). 126 

SYST:LAST? Queries the last remote command or query processed 132 

SYST:LOAD 
{"filename.obr", 
trace} 

Loads the external file specified in quotes as a source of data 
reference for the measurement. 

 
129 

SYST:ON? Queries whether the OBR is on (1) or off (0). 125 

SYST:RDY? Queries if the OBR is ready to scan (1) or not (0). 126 
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SYST:RLDC Reloads the most recent valid calibration file into memory. 128 

SYST:SAT? Queries whether the detectors were saturated during the 
previous scan. 

 
129 

SYST:SAVE 
{“filename.obr”, 
trace} 

Saves the specified trace (A-E) data as a binary file using the 
specified filename. The file name must be in quotes, and the 
file type ".obr" must be specified. If no trace is specified, the 
data in Trace A will be saved. 

 
 

130 

SYST:SAVT 
{“filename.txt”, 
trace, domain, 
graphType, units, 
spatialResolution} 

Saves the current data from the trace specified (A-E) as text 
or spreadsheet data in the path specified in quotes, based on 
the following variables: 
Trace can be A, B, C, D or E. 
Domain = 0 for the time domain, 1 for frequency domain. 
GraphType can take values from 0 to 8, depending on the 

domain specified, as shown in the table on page 145. 
Units for the time domain (0): 

0 = time (ns) 
1 = length (m) 
2 = length (ft) 
3 = length (in) 
4 = length (mm) 

Units for the frequency domain (1): 
0 = wavelength (nm) 
1 = frequency (GHz) 
2 = frequency (THz). 

SpatialResolution sets the spatial Resolution Bandwidth 
(mm). 

 
 
 
 
 
 
 
 
 
 
 
 

130 

SYST:SPOT 
{center, centerUnits 

Tells the OBR to execute an optical Spot Scan centered about 
the specified center.   
CenterUnits: 

0 = time (ns) 
1 = length (m) 
2 = length (ft) 
3 = length (in) 
4 = length (mm) 

 
 
 
 
 

124 
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SYST:SSEG 
{“filename”, trace} 

Saves as a binary file the segment of the trace defined by the 
Integration (or Sensing) Area. 

 
130 

SYST:VER? Queries the software version. 125 

SYST:WARM? Queries if the laser is at operating temperature (1) or not (0). 125 

SYST:WCLF? Queries whether the wavelength calibration failed during the 
previous scan. 

 
128 

SYST:WTIM? Displays the time remaining on the system one hour warm- 
up timer. 

 
125 

 
 
 
 
 
 
 
 
 
 

7 



173  

8 

 

 

Chapter 8 
 
 
 

Measurement Theory 
 
 

The Luna OBR utilizes swept-wavelength interferometry to interrogate the device 
or system under test. This technique measures the full scalar response, including both 
phase and amplitude information. The amplitude of the time domain data is 
equivalent to a traditional optical time domain reflectometry (OTDR) measurement. 

 
Fiber Optic Interferometry 

The OBR uses swept-wavelength coherent interferometry. Here this technique is 
presented at an introductory level. For more information see the references at the 
end of this section. 

 

The two basic types of fiber interferometers are shown in Figure 8-1. A Mach- 
Zehnder design uses one 3 dB coupler to split the light, and another 3 dB coupler 
to recombine the light. In general, the two paths between the couplers are of different 
lengths. A detector is placed at the output of the second coupler. A Michelson 
interferometer uses a single 3 dB coupler to both split and recombine the light. 
Mirrors are placed at each of the outputs on one side of the coupler, and in general 
the two paths are of different lengths. On the other side of the coupler, one lead is 
used to inject the light, and the other is directed to a detector. 

 

 
 

Figure 8-1. Two basic types of fiber interferometers: 
(a) Mach-Zehnder and (b) Michelson. 
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Both of these interferometer designs can be treated in a basic way using the same 
set of mathematics. Consider an input field of the form 

 
Ein   = E0 ( t )e–i ω ( t ) t , 

 
where ω is angular optical frequency, and ω( t ) describes the instantaneous 
frequency of the tunable laser source. 

 
The spatial dependence of the signal may be ignored because the light is detected 
only at a single point. At the first coupler, the input field is split into two fields, E1 

and E2 . After propagating through different lengths of fiber, the two fields are 
recombined, and the resulting field at the detector is 

 
Eou t = E0 ( t + τ1 )e –i ω ( t + τ1 ) t + E0 ( t + τ2 )e –i ω ( t + τ2 ) t , 

 
where  τ1   and  τ2   are the delays through the two paths of the interferometer. 

The electrical output of the detector is proportional to the optical intensity, I, which 
is given by the square magnitude of the electric field: 

 
I( ω ) = E0 ( t ) 2 + E0 ( t – τ ) 2 + 2E0 ( t )E0 ( t – τ ) cos [ ω( t )τ ] , 

 

8 where the time delay difference between the interferometer paths τ =
 

Optical Network for OBR 

τ1 – τ2 . 

A schematic of Luna’s OBR optical network is shown in Figure 8-2. The optical 
system is comprised of a tunable laser source (TLS), an interferometer (the DUT 
or device under test), and a detector. 
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Figure 8-2. OBR optical network. 
 

The basic idea from the previous section can be applied to device characterization 
by including a device under test (DUT) in one arm of a Mach-Zender interferometer, 
as shown in Figure 8-2. We can describe the DUT by its frequency domain linear 
transfer function, H( ω ) ; the linear transfer function contains information about the 
amplitude, ρ( ω ) , and phase, φ( ω ) , response of the DUT and is given by 
H ( ω ) = ρ( ω )ei φ ( ω ) . Given the amplitude and phase response, the detected power 
is proportional to the intensity, I, given by 

 
I  =  E0 ( t ) 2 + E0 ( t – τ ) 2 ρ( ω )2 

+ 2ρ( ω )E0 ( t )E0 ( t – τ ) cos [ ω ( t )τ – φ( ω ) ] . 
 
 

Next a Fourier transform is performed allowing the three terms in the above 
expression to be separated spectrally. Note that the first two terms will have only 
low frequency characteristics, and thus will appear at or near t = 0 in the time- 
domain. The device information resides in the third term of this expression, called 
the interference term. The interference term oscillates at the frequency ω( t )τ , while 
the other terms do not oscillate. Its location in the time-domain will be determined 
by the delay difference  τ  between the two arms of the interferometer. Provided 
that τ  is large enough, the device response will be separable from the low frequency 
terms, and thus measurable. The Luna OBR is designed such that the internal delay 
path through the device under test is long enough such that the low frequency terms 
will not influence the measurement, even for very short devices. Thus the OBR 
operates with no dead zone. 

 

The Fourier transform of reflected optical intensity (I) for a short length of single- 
mode fiber as the DUT is plotted in Figure 8-3 (a). Figure 8-3 (b) shows the selected 
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segment that contains the device information. Because the initial data was acquired 
as a function of optical frequency, ω , the transformed data is a function of time. 
For this reason, the transformed data is referred to as time domain data. 

 

 
Figure 8-3. (a) The Fourier transform of interference fringes. 

(b) The segment of the time domain data that contains device information. 
 

If there are multiple reflecting interfaces within the device under test, each interface 
will contribute a term to the interference pattern and a peak in the time-domain 
located at the corresponding delay. 

 

In order to more easily locate the source of reflections within a device, the time- 
domain data can be scaled in units of length, using the speed of light and the group 
index of the DUT. 

 

To arrive at a measure of the frequency response of the device, an inverse Fourier 
transform is performed on only the section of the time-domain data that contains 
the device response. The OBR software allows the user to select any portion of the 
time-domain data so the response due to different optical paths or interfaces can be 
separated and measured independently. 
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Once the data has been transformed back into the frequency-domain, the calibrated 
amplitude response yields the loss of the test device. The derivative of the phase 
response yields the group delay. 

 
Fiber Interferometry: References 
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Resolution Bandwidth Calculations 

 

Because the frequency- and time-domain data are related to one another by a discrete 
Fourier transform, the width of the visible window in the time domain determines 
the resolution of the data in the frequency (wavelength) domain. If the width of the 
visible portion of the time domain is denoted ∆tf  and given in units of nanoseconds, 
then the resolution bandwidth (RBW) of the frequency domain data is given by 
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RBW [GHz] = --1---- 
∆tf 

 
or 

 
 

RBW [pm] = λ2 
--------- , c∆tf 

 
where λ is the center scan wavelength and c is the speed of light in a vacuum. 

 
Spatial Resolution Calculations 

The Spatial Resolution field in the Data Processing area sets the length of the box- 
car filter applied to the amplitude data in the time domain. This filter assigns each 
location in the measurement with the simple sum of all the adjacent points within 
the range of the filter resolution setting. Because this is not a weighted average, 
localized reflections—like those at the end of a fiber—will have a rectangular shape 
equal to the width of the control setting. If the Spatial Resolution is set below the 
minimum achievable resolution, the software will coerce it to the actual minimum 
value and thus the data is unfiltered. 

 
Integration Width (or Sensing Range) 

The Integration Width field in the Data Processing area controls the length of the 
segments centered on the vertical cursors, which are used to calculate the average 
loss within and between the two highlighted segments. The width of this segment 
determines the width of the lower graph X-axis. 

 

Note: When Options > Sensing Enabled is on or checked (if purchased, see 
page 187), the fields in the Data Processing area change. To control the width of 
the highlighted area in Sensing Mode, change the Sensing Range in the Data 
Processing area. 

 
Return Loss and Differential Loss 

When the vertical cursors are on in the upper graph, the average return loss is 
calculated over the two Integration Widths (or Sensing Ranges, in Sensing Mode) 
and displayed in the upper right as Ret Loss (dB). For example, if the entire time 
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domain axis is given by t ∈ [ 0, T ] and the data is highlighted at a cursor such that 
t ∈ [ t1, t2 ] , then the average return loss at that cursor is given by 

 
 
 
 

RetLoss = 

t2 

∑ h̃ 
j 

10log --t--1--------- , 

∑ h̃ 
j 

0 
 

where h̃ 
j   is the impulse response, further defined below under “Time Domain 

Amplitude and Amplitude (dB)” on page 180. 
 

The differential loss (Diff Loss (dB)) displayed in the graph area is simply the 
difference between the return losses at each cursor, divided by two. 

 

The differential loss is calculated by summing all of the power, p, within the 
highlighted segment around the first cursor, and dividing this sum by the sum of 
the power within the highlighted segment around the second cursor. The loss is 
calculated as five times the log of this ratio (shown below) because the loss is 
accumulated twice: once for the light to get to the particular segment, and once for 
it to return from the segment. 

 
N 

∑ pk 

Differential Loss = 5 log k =C1
 

∑ p 
k 

k =C2 

 

N is the number of points specified in the Integration Width field (or Sensing 
Range field, in Sensing Mode). C1 and C2 are the start positions for the two 
segments integrated. 

 

 

Standard Parameter Calculations 
As mentioned above, the OBR uses coherent interferometry to measure the linear 
transfer function, H( ω ) = ρ( ω )ei φ ( ω) , of the DUT. (See “Optical Network for 
OBR” on page 174.) From this the loss, dispersion and time domain parameters are 
extracted. 
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Time Domain Amplitude and Amplitude (dB) 

Using the equation above for the linear transfer function, H(ω), the impulse response 
is given by the Fourier transform of the transfer function, 

 

h̃ 
j
 

 

= FFT{ H( ω ) }j   , 
 

where FFT{ H( ω ) } denotes the Fast Fourier Transform of H( ω ) . The index j 
indicates the location in the data array, and corresponds to time. 

 

The Amplitude (dB) curve is the time domain linear amplitude data plotted on a 
log scale, according to the following relation: 

 
 

Amp[ dB ]j   = 10log [ h̃ 
j  ] . 

 
 
 
 
 
 
 
 
 
 
 

8 
 
 

Figure 8-4. Time domain Amplitude data for a switch. 
 

Note that Amplitude has units of dB/mm, as seen above, while Amplitude (dB) 
has units of dB. 

 

The Amplitude curve is the time domain Linear Amplitude (see below), 
normalized by the number of data points in 1 millimeter, converted to a log scale. 
The number of data points in 1mm is dependent on the Start, End and Wavelength 
Range of the Scan. Thus, displaying the time domain Amplitude in these units 
allows for easy comparison between data sets taken using different wavelengths, 
since the nominal scatter level expressed in dB/mm remains constant. 
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Time Domain Linear Amplitude 

The linear amplitude is the  h̃ 
j    plotted on a linear scale. 

 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 

Figure 8-5. Time domain Linear Amplitude data for a switch. 
 

Time Domain Polarization States 
The OBR detects the power returned in two orthogonal polarization states. The 
power in these two states can be summed to form the total power returned from a 
particular location in the fiber. This summation is the blue curve displayed in the 
linear and logarithmic amplitude plots. (See Figure 8-6 below.) In some cases, 
particularly where birefringence is present, it is useful to look at the power returned 
in each of the polarization states. The polarization graph shows these two power 
levels in red and yellow, as well as the sum of the powers in blue. 

 

 
 
 
 
 
 
 
 
 
 
 
 
 
 
 

Figure 8-6.  Polarization data on spooled fiber. 
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Time Domain Phase Derivative 

The time domain phase derivative plot is the derivative of the phase of the impulse 
response with respect to time. Note that the time derivative of phase is the definition 
of optical frequency, so this derivative can be scaled as a wavelength. For a device 
with a distributed impulse response, the time domain phase derivative shows the 
wavelength distribution as a function of time for an infinitely short pulse as it is 
dispersed by the device. Another way to think of the time domain phase derivative 
is it represents the “wavelength” of the device under test. It is therefore especially 
meaningful for wavelength conditioning devices and filters. 

In terms of the impulse response h̃ 
j  defined above, the time domain phase derivative, 

PDj , is defined as 
 

2πc∆t 
= ------------- , 

PDj ----------------- 
∗ arg ( h̃ 

j + 1 h̃ 
j   ) 

 
where c is the speed of light in a vacuum and ∆t is the difference in time between 
index j and index j + 1 . 

 
 
 
 
 

8 
 
 
 
 
 
 
 
 

Figure 8-7. Phase Derivative of the time domain response of a fiber Bragg grating. 
 

Time Domain Magnitude Difference 
This parameter allows the user to display the difference in magnitude between Trace 
A and the Reference Trace in the time-domain. 



Optical Backscatter Reflectometer 4600   183 
User Guide 

 

i + 1     i 

8 

 
Frequency Domain Return Loss 

Return loss is the ratio of optical power output by the device to the optical power 
input to the device, and is expressed in dB. In terms of the transfer function, it is 
defined as 

 
 

RLi = 20Log( Er ⁄ Ein ) . 
 

where the subscript “i” corresponds to the “ith” data point, Er is the reflected field 
and Ein is the input field. 

 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 

Figure 8-8. Return Loss data of a fiber Bragg grating. 
 

Frequency Domain Group Delay 
Group delay (GD) is defined to be the rate of change of phase as a function of 
frequency. Physically, this property corresponds to the delay experienced by the 
sinusoidal envelope of a modulated optical signal as it propagates through the device. 
In terms of the transfer function, the group delay is given by 

 
 

GDi   = arg ( H H ∗ ) -------------------------------- , 
∆ω  
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where arg ( z ) denotes the argument (phase) of the complex number z , and ∆ω is 
the change in optical frequency from index i to index i + 1 . 

 
 
 
 
 
 
 
 
 
 
 
 
 
 
 

Figure 8-9.  Group Delay data for a patch cord. 
 

Frequency Domain Window 
Some OBR users have noted that the reflectance peaks from strong reflection events 
(generally with higher than -45 dB return loss) exhibit marked broadening at the 
base. These side band tails can sometimes obscure the peak of a weak reflector very 
near a strong reflector peak. They can also overwhelm the nearby Rayleigh scatter 
level, making insertion loss measurements near the base of the strong reflection peak 
difficult. Using the Frequency Domain Window option significantly diminishes 
reflection peak side band tails. 

 

The window is applied to all newly scanned data by selecting Options > Display 
Options > Apply Frequency Domain Window. There is no significant scan or 
calculation time penalty associated with selecting this option. 

 

The effects of the Frequency Domain Window are illustrated in Figures 8-10 and 
8-11. Figure 8-10 shows the reflection trace of a FC/PC connector with a clear plastic 
cap covering the ferrule. In the normal trace (blue), the reflections of the end cap 
surfaces are barely visible above the side band tail of the connector. Applying the 
Frequency Domain Window produces a trace (white) which suppresses the side band 
tails and greatly enhances the contrast of the much weaker end cap reflections just 
a few millimeters away from the connector. 
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Fiber End Face Plastic End Cap Surfaces 
 
 

Normal Trace 
 

 
 
 
 
 
 

With Spectral 
Window Applied 

 

 
 

Figure 8-10. OBR traces of a FC/PC connector with a clear plastic cap over the   
ferrule with (white) and without (blue) a Frequency Domain Window applied. 
Each major x-axis division is 2 mm. 

 
Another example which demonstrates the usefulness of the Frequency Domain 
Window function is illustrated in Figure 8-11. In this example, a series of short patch 
cables are connected to the front panel of the OBR. A pair of FC/APC connectors 
at the front panel at L = 0 m is followed by a pair of ST connectors at L = 0.25 m, 
followed by a lossy FC/APC connector pair at 0.50 m, and a final FC/APC connector 
pair at L = 1.0 m. In the normal trace (blue), the side band tails from the ST connector 
pair overwhelm the nearby fiber Rayleigh scatter, making an accurate measure of 
the insertion loss between nearby connections impossible. When the same set of 
patch cables are scanned with the Frequency Domain Window applied, a new trace 
is produced (white) in which the side band tails of the ST connection at 0.25 m are 
suppressed and a large insertion loss at the connection at 0.5 m is now obvious. 
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Figure 8-11.  OBR traces of a series of short patch cables with (white) and without 
(blue) a Frequency Domain Window function applied. Each major x-axis divi- 
sion is 10 cm. 

 
How Frequency Domain Window Effects Measurements 

When a frequency domain measurement for a cursor-defined section of the upper 
graph trace is displayed in the lower graph, the effects of the Frequency Domain 
Window are removed by multiplying through by the inverse of the window function. 

8 Return Loss 

Return Loss (RL) values measured with the upper graph cursors, however, may be 
altered by the Frequency Domain Window if the reflection event being measured 
has significant RL variation in the optical frequency domain. Connectors and splices 
tend to have spectrally flat RL, but fiber Bragg gratings and thin film filters do not. 
For this reason, the Frequency Domain Window should be left off when measuring 
the RL of gratings and filters. If you are not sure if the RL spectrum of your device 
under test is flat, you can simply check by highlighting the device in the upper graph 
with a vertical cursor and selecting the frequency domain setting near the upper right 
corner of the lower graph. 

 
Insertion Loss 

 

Insertion Loss (IL) measurements are made by integrating over the Rayleigh scatter 
in separate parts of the network under test. Since fiber Rayleigh scatter is spectrally 
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uniform, the frequency window function will not significantly alter the measured 
Rayleigh scatter amplitude. 

 
Distributed Sensing 

 

Distributed strain and temperature measurements are made by sensing the spectral 
shift in the fiber Rayleigh scatter. Since the higher and lower parts of the scanned 
spectrum are attenuated by the frequency domain filter, the effective measurable 
temperature and strain range is cut roughly in half. For this reason it is advisable 
but not necessary to leave the Frequency Domain Window off when making 
distributed strain or temperature measurements. It is possible but not advisable to 
use a reference with the window applied and obtain subsequent data with the window 
off, or vice-versa. 

 
Optional Distributed Sensing Parameters 

 

Five distributed sensing parameters can also be measured by the OBR, with a 
purchased software option. The OBR uses swept-wavelength interferometry (SWI) 
to measure the Rayleigh backscatter as a function of length in optical fiber with high 
spatial resolution. Rayleigh backscatter in optical fiber is caused by random 
fluctuations in the index profile along the fiber length. Scatter amplitude is a random 
but static property of a given fiber and can be modelled as a continuous weak fiber 
Bragg grating (FBG) with a random period. 

 

The physical length and index of refraction of the fiber are intrinsically sensitive to 
environmental parameters: temperature and strain, and to a lesser extent, pressure, 
humidity (if the fiber coating is hydroscopic), electromagnetic fields, etc. In most 
practical cases the effects of temperature and strain will dominate the spectral 
response of the Rayleigh backscatter, so we concentrate our examination on these 
parameters. 

 

Changes in the local period of the Rayleigh scatter cause temporal and spectral shifts 
in the locally-reflected spectrum. These shifts can then be scaled to form a distributed 
sensor. This SWI-based technique enables robust and practical, distributed 
temperature and strain measurements, with millimeter-range spatial resolution over 
tens to hundreds of meters of standard fiber, with strain and temperature resolution 
as fine as 1  µε  and 0.1 °C. 
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Measurement Technique 

A strain or temperature sensor is formed by first measuring and storing the Rayleigh 
scatter signature of the fiber under test (FUT) at an ambient state; this data is stored 
as the Shift Reference. Then the scatter profile is measured at a later time with strain 
or heat applied at some point along the length of the fiber. (For more details, see 
“Measurement Technique” on page 61.) The scatter profiles from the two data sets 
are then cross correlated along the segment highlighted by a vertical cursor, in 
increments of  ∆z , which represents an individual sensing element. 

It is important to note that the Gauge Length,  ∆z , affects the spectral resolution 
and the signal-to-noise ratio of the measurement. (The Gauge Length is set by the 
user in the Data Processing area of the main screen.) There is, therefore, a 
relationship between the spatial resolution of the measurement and its accuracy in 
measuring the change in strain or temperature. The longer the segment used, the 
better the temperature accuracy. However, if the strain or temperature varies rapidly 
with position, a smaller segment size is often necessary to prevent the distortion in 
the position scale from blurring the cross correlation spectra. 

 

When the user highlights a portion of temporal domain data in the upper graph using 
the vertical cursors, they can view the spectral data for the highlighted portion in 
the lower graph. (For more information, see “Distributed Sensing Measurements” 
on page 59.) A shift in the spectrum of this data in response to strain ε or temperature 
T is analogous to a shift in the resonance wavelength  ∆λ  or the spectral shift  ∆ν  
of a Bragg grating: 8 

∆λ 
------  = 
λ 

∆ν 
------ 
ν 

= KT ∆T + Kε ε , 

 
where  λ  and  ν  are the mean optical wavelength and frequency, and KT  and Kε 

are the temperature and strain calibration constants, respectively. The default values 
for these constants are set at values common for most germanosilicate core fibers: 
KT  = 6.45 x 10-6 ºC-1 and Kε  = 0.780. The OBR software allows the user to set their 
own values for these constants, according to their specific application. (See 
“Temperature Change and Strain Coefficients” on page 60.) 

 

The values for KT   and Kε   are somewhat dependent on the dopant species and 
concentration in the core of the fiber, but also to a lesser extent on the composition 
of the cladding and coating. Variations of 10% in KT   and Kε   between standard 
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telecom fibers are common; larger variations may be observed in specialty fiber, such 
as polarization maintaining (PM) fiber or Erbium-doped fiber. 

 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 

Figure 8-12.  Spectral Shift result for a constant strain 
applied to a 320 mm length of fiber. 

 
Temperature Change and Strain 

Currently the OBR is not configured to simultaneously measure temperature and 
strain shifts. In the absence of strain, however, the temperature change be written as: 

 
 

Temperature Change = ∆ T = – λ 
-------- 
cKT 

 
where λ  is the center wavelength of the scan and c is the speed of light. Similarly, 
in the absence of a temperature change, the strain can be written as: 

 
 

Strain =   ε λ 
= –------- 

cKε 

 
Assuming a scan center wavelength of 1550 nm, we can substitute in the constants 
KT   and  Kε   to yield the following conversion factors:  ε  = (-6.67 µε /GHz) ∆ν , 
and ∆T = (-0.801 ºC /GHz) ∆ν . 

 

Thus the distributed temperature and strain curves are merely rescaled copies of the 
spectral shift distribution. 
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Temperature Change and Strain Coefficients 

 

The temperature change and strain curves are generated by converting the spectral 
shift curve from values in GHz to degrees C or microstrain. This conversion is done 
using a 4th  order polynomial fit. The default coefficients for this fit have been set 
for standard SMF 28 fiber. The user can customize these coefficients for other fiber 
by recording the Frequency Shift of that fiber, while measuring temperature or strain 
on that fiber externally. (See “Temperature Change and Strain Coefficients” on 
page 60.) 

 
Spectral Shift 

In SWI the backscatter optical power U( ν ) is collected in the spectral frequency 
domain: detectors collect light backscattered from the FUT (fiber under test) as the 
laser spectral frequency is tuned. The data is processed with a Fourier Transform 
to generate the backscatter optical power U'( τ ) as a function of time delay τ , which 
can be scaled to show the return loss as a function of FUT length. 

 

The spectral shift option for the lower graph divides the time domain data highlighted 
in the upper graph into segments and computes the backscatter spectrum for each 
segment. Although the backscatter spectrum appears random for a segment of fiber, 
it is actually determined by random fluctuations in the core index of refraction and 
is stable and repeatable. For a specific fiber segment j, the reflection spectrum is 
denoted as Uj ( ν ) . If the fiber is exposed to a change in strain or temperature, the 
reflection spectrum will experience a shift in optical frequency ∆νj   and can be 
denoted Uj ( ν – ∆ν j ) . The shift in the reflection spectrum ∆νj   is computed by 
performing a cross correlation operation Uj ( ν ) on and Uj ( ν – ∆ν j ) . As shown in 
the equation on page 188, this spectral shift can than be related to a temperature or 
strain change. 

 
Spectral Shift Quality 

The Spectral Shift Quality is a measure of the strength of the correlation between 
the measurement and reference reflected spectra. This value is calculated as: 

 

 
 

Spectral Shift Quality  = MAXIMUM( U ( v ) U ( v – ∆v ) ) --------------------------------------------- ----------------------------- , 

∑ Uj ( v ) 
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where Uj is the reference spectrum for a given segment of data, Uj ( ν – ∆ν j ) is the 
measurement spectrum under a strain or temperature change, and the symbol  is 
used to denote the cross-correlation operator. In other words, the Spectral Shift 
Quality is the maximum value of the cross correlation of the Reference and 
measurement spectra normalized by the maximum expected value, i.e. the maximum 
of the reference spectra autocorrelation. 

 

In practical use, the Spectral Shift Quality will be a value between 0 and 1, where 
1 is a perfect correlation, and zero is uncorrelated. In general, the data sets should 
be considered well correlated if the Spectral Shift Quality is above about 0.15. Note 
that as Strain or Temperature Change increases, Spectral Shift Quality will 
decrease. This is expected since exposing a fiber to a change in strain or temperature 
induces a temporal shift as well as a temporal stretch or compression. 

 
Temporal Shift 

The temporal shift ∆t results from the integrated effect of local time shifts along the 
FUT between the origin at the front panel of the OBR and the delay time at which 
the shift is being evaluated. This temporal shift is calculated from the spectral shift 
using the following relationship: 

 
j  λ1 λ2  SensorSpacing


 

∆τ ( τ )j ≈ –a0  ----------  --------------------------------------- ∑∆vi
 , 

cλc GaugeLength  

i = 0 8 
where the summation is over the Gauge Length (as set by the user in the Data 
Processing area); a0 denotes a scaling constant; λ1, λ2 and λc are the Start, End 
and Center Wavelengths of the scan, respectively; and c is the speed of light. It is 
assumed that the Temporal Shift value is equally distributed over the Gauge 
Length. When this is not a valid assumption, the Temporal Shift data will become 
noisy; a smaller Gauge Length is required for the calculations to succeed. Note that 
when the Sensor Spacing is equal to the Gauge Length, this expression is exact. 
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Figure 8-13. Temporal Shift results for the same source data 
and same length range as in Figure 8-12. 

 
Number of Points and Resolution 

The spatial resolution of the Spectral Shift, Spectral Shift Quality, Temperature 
Change, Strain and Temporal Shift measurements is determined by the Sensor 
Spacing and Gauge Length settings in the Data Processing area of the main 
software window. When these two settings are the same, they are equivalent to the 
two-point spatial resolution. The Gauge Length determines the segment size of the 
Rayleigh scatter that is used to determine the Spectral Shift, from which the other 
sensing parameters are calculated. The Sensing Range divided by the Sensor 

8 Spacing determines the number of points displayed to the user.
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Chapter 9 
 
 
 

Maintenance 
 
 
Cleaning Connectors 

It is extremely important to clean connectors before attaching optical fibers to the 
OBR for testing. Failure to do so may result in erroneous or noisy data. 

 

Optical fiber connectors on devices should be cleaned before every connection to 
the OBR. The bulkhead connectors on the front panel of the OBR should be cleaned 
frequently, roughly once every 25 connections. 

 

The optical fiber connector cleaner is used for cleaning connectors: 
 
 
 

 
 

Mini foam swabs are used for cleaning the OBR bulkhead connectors: 

9 
 
 
 
 
 
 
 

The cleaning supplies used with the OBR are: 
 

• CLETOP connector cleaner - P/N F1-6270 
• CLETOP connector cleaner replacement reel - P/N F1-6271 
• Mini foam swabs (50/package) - P/N F1-0005 
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These supplies can be ordered from: 

 

FIS Incorporated 
161 Clear Road 
Oriskany, NY 13424 
Web: www.fiberinstrumentsales.com 
E-mail: info@fiberinstrumentsales.com. 

 

 
 
 

Important 

Use only cleaners approved for use with fiber optic 
bulkheads and fiber connectors. Do not use any type of 
cleaning fluid, cotton swabs, or cloths. 
Using unapproved cleaning tools or fluids may result in 
erroneous or noisy data, or may damage the fibers and 
OBR components. 

 

 
Cleaning Optical Fiber Connectors 

 
 
 

Important Optical fiber connectors on devices should be cleaned 

                 before every connection to the OBR. 
 
 

1 Expose the cleaning tape by pushing down the cover release lever. 
 
 

Cleaning tape cover closed 

9 
Cleaning tape cover open 

 
 
 
 
 
 
 
 

cover release lever tape cover cleaning tape 

http://www.fiberinstrumentsales.com/
mailto:info@fiberinstrumentsales.com
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The cleaner tape has two cleaning strips: 

 
 

cleaning strips 
 
 
 
 
 
 
 
 
 

2 Holding the fiber connector perpendicular to the cleaner tape surface, 
swipe the tip of the connector down the first cleaning strip, then swipe 
on the second strip. 

 
 
 
 
 
 
 
 
 
 
 
 
 
 
 

3 Close the cleaning tape cover before swiping another connector. This 
advances the cleaning tape. 

 
Cleaning Bulkhead Connectors 

 
 

Important The bulkhead connector should be cleaned about once 

                 every 25 connections. 
 

1 Either turn off the OBR, or turn off the laser by selecting Tools > Turn 
Laser OFF. 

 

2 Make sure that no devices are connected to the OBR. 
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3 Turn the protective cap counterclockwise to remove it. Gently insert one of the 

supplied mini swabs, as shown below. Twist the swab in one direction, and then 
remove. Discard miniswabs after single use. 

 

 
 

 
 

Figure 9-1. Remove the protective cap. Gently insert supplied mini swab, rotate in 
one direction, then remove. 

 
4 Replace the protective cap to protect the connector. 

 
Cleaning the Case 

Clean the case by wiping it with a soft cloth dampened with water or a mild, non- 
abrasive cleaning fluid such as window cleaner. 

 
Caution Do not spray any fluid directly on case surfaces. It may 

9 seep into the interior of the case and damage components.

 
 

Replacing Fuses 
The fuse drawer is located on the power module on the instrument case back panel: 
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fuse drawer 
 
 
 
 

power module 
 
 
 
 
 
 
 

Warning To avoid the risk of serious injury or death, ensure that the 
power cord is disconnected from the instrument when 

               checking or replacing fuses. 
 
 

To replace fuses 
 

1 Disconnect the instrument power cord. 
 

2 Place the blade of a screwdriver or similar tool in the slot at the bottom 
of the fuse drawer, then gently pry the drawer out of the power module. 

 
 
 

9 
 
 
 
 
 
 
 
 
 
 

3 Replace fuses with Bussmann AGC-2 type 2A @ 250VAC 1 ¼” x ¼” 
fast acting (FA) fuses, rated FS01008. 
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4 Push the drawer back into the power module until it snaps into place. 
 

5 Reconnect the power cord. 
 

Packing and Shipping the OBR 
The OBR should only be packed and shipped in its original packing materials. If 
these have been discarded, contact Luna Technologies for packing material. To 
minimize physical shock during shipping, the OBR system should always be shipped 
via air instead of ground, by a reputable shipping service provider. 

 
Required Packing Materials 

• OBR Shipping Box (#1) 
• Desktop or Laptop PC Box (#2) 
• PC Monitor Box (if do not have laptop)(#3) 
• OBR Shipping Foam 
• PC Monitor Shipping Foam 
• PC Shipping Foam 
• OBR Accessory Box 
• PC Accessory Box 
• Sturdy packaging tape to seal the boxes 
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Packing Procedure 

1 Check that all materials to be shipped are ready to be packed using the 
“Components List” on page 7. 

 

2 Place the supplied protective cap over the detector port and turn it 
clockwise until tightened. 

 

3 Obtain an OBR Shipping Box (#1). 
 

4 Seal the bottom center and edges of the box. 
 

5 Pack the OBR in the OBR Shipping Box using the original styrofoam 
insert on each side of the OBR. 

 

6 Pack the user software, the User Guide, the OBR Accessory Pack, and 
OBR cables in the OBR Accessory Box. 

 

7 Place the OBR Accessory Box on top of the OBR. 
 

8 Seal the top of the box, taping the center and open edges. 
 

9 Obtain a Luna Desktop or Laptop PC Shipping Box (#2), as applicable. 
 

10  Seal the bottom center and edges of the box. 
 

11  Pack the PC in the PC Shipping Box using the original styrofoam inserts 
on each side of the PC. 

 

12  Pack the PC software and manuals, as well as the mouse, keyboard, and 
PC Power Cord in the PC Accessory Box. 

 

13  Place the PC Accessory Box on top of the re-packaged PC. 

14  Seal the top of the box, taping the center and open edges. 9 
15  Obtain a Luna Technologies Monitor Shipping Box (#3), if applicable. 

Otherwise disregard the remaining steps. 
 

16  Seal the bottom center and edges of the box. 
 

17  Pack the monitor in the Luna Technologies Monitor Box using the 
original styrofoam inserts on each side of the monitor. The Monitor Box 
should contain the monitor, the monitor software and manuals, the power 
supply and the power cord. 

 

18  Seal the top of the box, taping the center and open edges. 
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Error Message Solution(s) 

 This indicator will be displayed if the laser is not ready 
to perform a measurement. 
If this indicator does not go off within several minutes of 
turning on the instrument, please see “Instrument drifts 
out of calibration” on page 208. 

 Realign, then recalibrate. For instructions, see “Aligning 
the OBR Optics” on page 32, and “Calibrating the 
System” on page 33. 
Measurements may still be performed if this indicator is 
displayed on the screen, but the data may not meet the 
documented specifications. 

 Recalibrate. For instructions, see “Calibrating the 
System” on page 33. 

 

 

 

Chapter 10 
 
 
 

Troubleshooting 
 
 

This chapter describes how to troubleshoot OBR hardware and software errors. The 
first section describes what to do when the various Status Bar Messages appear. 
General Troubleshooting contains procedures for problems that occur without 
accompanying error messages. Error Message Troubleshooting explains error 
messages which appear in dialog boxes. The next two sections are organized roughly 
in the order in which a user would operate the equipment and software. 

 

If you have problems or error messages not listed here, or if the solutions provided 
here do not resolve a problem, please contact Luna Technologies toll free at 1-866- 
LUNAOVA (1-866-586-2682) or by e-mail at support@lunatechnologies.com. 

 
System Status Bar Messages 

Please note that status bar messages are not “fatal” error messages. Rather they 
advise the user of the status of the instrument. 
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Cause(s) Solution(s) 

The OBR and/or the PC is not 
plugged in or turned on (and 
the laptop battery is dead, if 
applicable). 

The OBR and the PC require separate power cords. Plug 
in the OBR and/or the PC, or replace dead batteries with 
charged ones if using a laptop PC. Instructions for the 
PC battery are located in the provided PC manual. Make 
sure to turn on the OBR power switch on the front of the 
instrument, and the PC according to its instructions. 

Blown fuse. Replace the fuse. For instructions, see “Replacing 
Fuses” on page 198. 

 

 
 

Error Message Solution(s) 

 This message is displayed if a measurement cannot be 
calibrated to the wavelength. This simply means that the 
data acquired is accurate in terms of the parameter 
displayed on the screen, but the data is shifted in either 
direction in terms of wavelength. This problem may 
occur once in a while, but the occurrences should be 
fairly sparse. 
First try to scan again or try scanning over a different 
wavelength range to see if the warning indicator is 
displayed again. 
If the error light persists, it generally means that the laser 
(not just the instrument) needs to be recalibrated. First, 
run the Self-Diagnostic software and send the resulting 
text file to Luna (as described beginning on page 211). 
Then you may contact Luna Technologies toll free at 
866-LUNAOVA (866-586-2682) or by e-mail at 
support@lunatechnologies.com. 

 The detector has been saturated by a strong reflection, 
causing “ghost peaks.” To correct this problem, reduce 
the Gain setting in the System Control area by one 
level and retry the scan. 

 

General Troubleshooting 
 

The OBR or PC will not power on 
 
 
 

10 
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Cause(s) Solution(s) 

Generally this occurs when 
other software is installed on 
the PC. 

Remove any software not originally installed on the OBR 
PC, then restart. 
If the problem persists, reinstall the OBR control software 
from the OBR software CD. 

 

 
Laser Ready light does not come on within several minutes 

 
 
 

Cause(s) Solution(s) 

The OBR has not stabilized to 
room temperature. 

Allow time for the entire system to stabilize at room 
temperature before trying to operate. 

Laser overheated because air 
flow to the OBR is restricted. 

Move the OBR away from objects or surfaces that 
restrict air flow through the fan duct on the back of the 
OBR. 

Laser overheated because of 
excessively high ambient 
temperature. 

Move the OBR to a cooler environment or decrease the 
ambient temperature to within the OBR operating range 
of 10–35oC. 
If all of the above conditions are met and the Laser 
Ready light still does not come on, run the Self- 
Diagnostic software and send the resulting text file to 
Luna (as described beginning on page 211). Then you 
may contact Luna Technologies toll free at 866- 
LUNAOVA (866-586-2682) or by e-mail at 
support@lunatechnologies.com. 

 
Control software will not load 

 
 
 
 
 
 
 
 

All software controls are disabled or unavailable 10 
 

Cause(s) Solution(s) 

The instrument is not properly 
connected to the PC. 

Ensure that the cable connecting the instrument to the 
PC is securely attached. 

mailto:support@lunatechnologies.com
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Cause(s) Solution(s) 

Laser not on. Turn the laser on. Then realign after the Laser Ready 
light comes on. For instructions on aligning the optics, 
see “Aligning the OBR Optics” on page 34. 

 

 
 

The instrument could not be 
configured properly due to a 
communication error. 

Reboot the PC. Turn the instrument off and then back 
on again. Restart the OBR control software. 
If the problem persists, reinstall the OBR control software 
from the OBR software CD. 

 
Control software seems to lock up 

 
Cause(s) Solution(s) 

The hardware may have 
stopped responding to the 
software. 

Exit the software, using the Windows® Task Manger if 
necessary. [Click Ctrl + Alt + Del, then click the Task 
Manger button, then select the OBR software, and click 
End Task.] Turn the instrument off and then back on 
again. Restart the OBR control software. 

Multiple Luna Technologies 
software applications may be 
running at the same time. 

Ensure that you are only running one control software 
program at a time. Software applications cannot share 
the OBR instrument, so running more than one at a time 
will produce undesirable results. 

The PC has entered an 
unusable state. 

Reboot the PC. Turn the instrument off and then back 
on again. Restart the OBR control software. 
If the problem persists, reinstall the OBR control software 
from the OBR software CD. 

 
Cannot align the OBR 

 
 
 
 
 

10 
 

Alignment unsuccessful 
 

Cause(s) Solution(s) 

Normal alignment procedure 
occasionally fails. 

Retry. See “Aligning the OBR Optics” on page 34. 
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Cause(s) Solution(s) 

Mechanical vibration. Move, remove, or shut down any sources of vibration 
such as fans or other motor-driven equipment. Isolate 
the OBR from those sources. 

Loose DUT connection. Tighten the DUT (device under test) connections. 

Dirty DUT or bulkhead 
connections. 

Clean all connections. For instructions, see “Cleaning 
Connectors” on page 195. 

OBR not aligned. Realign, then recalibrate. For instructions, see “Aligning 
the OBR Optics” on page 34, and “Calibrating the 
System” on page 35. 

 

 
OBR will not scan 

 
Cause(s) Solution(s) 

Laser not on or ready. If the laser is not on, turn it on. Then re-scan after the 
Laser Ready light comes on. If the laser is on but the 
ready light is not lit, the laser is still warming up. Wait 
until the Laser Ready light comes on, then scan. 
If the Laser Ready indicator does not light within several 
minutes of turning on the instrument, see “Laser Ready 
light does not come on within several minutes” on 
page 205. 

The instrument is not 
calibrated. (The “Out of 
Calibration” indicator should be 
lit in this case.) 

Recalibrate. For instructions, see “Calibrating the 
System” on page 35 

Optics not aligned. (The “Out of 
Alignment” indicator should be 
lit in this case.) 

Realign, then recalibrate. See “Aligning the OBR Optics” 
on page 34, and “Calibrating the System” on page 35. 

The instrument is not properly 
connected to the PC. 

Ensure that the cable connecting the instrument to the 
PC is securely attached. 

 
Excessive noise in data 
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Cause(s) Solution(s) 

Temperature changes will 
cause the instrument to drift. 

Recalibrate. For instructions, see “Calibrating the 
System” on page 35. 

 

 
 

OBR not calibrated. Recalibrate. For instructions, see “Calibrating the 
System” on page 35. 

Wrong fiber connector type. Ensure that the fiber connectors interfacing with the front 
panel of the OBR are FC/APC connectors. 

Incorrect or out-of-date 
calibration file loaded on 
startup. 

Recalibrate. For instructions, see “Calibrating the 
System” on page 35. 

DUT too long. Shorten the leads or replace the DUT to comply with the 
length limit of the OBR. See “Specifications” on page 213 
for the length limits. 

Cracks in bulkhead connector 
alignment sleeve. 

Contact Luna Technologies at 1-866-LUNAOVA or 
support@lunatechnologies.com for service. 

 

No data after scan 
 

Cause(s) Solution(s) 

Incorrect graph range settings. Rescale the plot axes. For detailed information, see 
“Scaling Plot Axes” on page 69. 

 
Unexpected or abnormal data 

 

See “Excessive noise in data” on page 207. 
 

Instrument drifts out of calibration 
 
 

10 
 

 
 

Error Message Troubleshooting 
Errors can occur while operating the OBR software. These errors will be described 
on the screen in a standard Microsoft® Windows® dialog box, showing the numerical 
error code as well. 

mailto:support@lunatechnologies.com
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Cause(s) Solution(s) 

The USB cable connections 
could be loose. 

Check the connections to ensure that the cable is 
connected properly to both the instrument and the PC. 

The instrument is not turned 
on. 

Ensure that the instrument is plugged into the proper 
type of outlet and turn on the power switch. 

The software is in an unknown 
state. 

Exit and restart the software. 

The hardware is in an unusable 
state and is not responding to 
the software. 

Exit the software. Turn the instrument off and then back 
on again. Restart the PC and the control software. 

The USB cable is faulty. If the above solutions do not work, run the Self- 
Diagnostic software and send the resulting text file to 
Luna (as described beginning on page 211). Then you 
may contact Luna Technologies toll free at 866- 
LUNAOVA (866-586-2682) or by e-mail at 
support@lunatechnologies.com. 

 

 
Errors on Software Startup 

 
Instrument not referenced 

 
Cause(s) Solution(s) 

On startup, the software 
attempts to load calibration 
data from a file. If this message 
is displayed, the file was not 
found or was found to be 
corrupted. 

Calibrate the instrument. Once the instrument is 
calibrated successfully, the user will never see this 
message again (unless the calibration data files are 
deleted manually). 

 
Configuration information could not be loaded from the instrument; the 
software goes into “Desktop Analysis” mode 
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Cause(s) Solution(s) 

The calibration was 
unsuccessful due to some 
problem in the hardware or 
software. 

Attempt the calibration again. If the problem persists, run 
the Self-Diagnostic software and send the resulting text 
file to Luna (as described beginning on page 211). Then 
you may contact Luna Technologies toll free at 866- 
LUNAOVA (866-586-2682) or by e-mail at 
support@lunatechnologies.com. 

 

 
Errors During Calibration 

 
Wavelength calibration failed while acquiring data 

 
Cause(s) Solution(s) 

None of the requested scans 
that were acquired were 
properly adjusted to 
wavelength. Although this is 
not a major error when 
performing a measurement, it 
is a problem when calibrating 
the instrument. 

Attempt the operation again. If the problem persists, re- 
calibrate the laser as described under “Calibrating the 
System” on page 35. 

 
The optics were detected to not be aligned properly 

 
Cause(s) Solution(s) 

This is just a warning letting the 
user know that the optics are 
not aligned properly. 

The user will have the option of continuing with the 
calibration even without the optics aligned. 
It is preferable to realign, then recalibrate. For 
instructions, see “Aligning the OBR Optics” on page 34, 
and “Calibrating the System” on page 35. 

 
 
 

Calibration data contains invalid values 
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Errors During Scanning or Referencing 

Any number of errors can be displayed during a scan. However, many of the errors 
are not major problems and most will be isolated incidents. In those cases, the error 
message will be displayed during one scan and the subsequent scans will be 
performed without any error. If any error occurs consistently, please contact Luna 
Technologies toll free at 866-LUNAOVA (866-586-2682) or by e-mail at 
support@lunatechnologies.com 

 
The specified timeout occurred before all of the requested data could be 
acquired 

 
Cause(s) Solution(s) 

There may be a problem with 
the hardware. 

If this problem occurs more than once at any time, exit 
the software. Turn the instrument off and then back on 
again. Restart the PC and the control software. 
If none of these actions fix the problem, run the Self- 
Diagnostic software and send the resulting text file to 
Luna (as described beginning on below). Then you may 
contact Luna Technologies toll free at 866-LUNAOVA 
(866-586-2682) or by e-mail at 
support@lunatechnologies.com. 

 
Self-Diagnostic Software 

Each Luna Technologies PC is loaded with both operating and Self-Diagnostic 
software. If the above-described error messages and solutions do not solve issues, 
please run the Self-Diagnostic software before contacting Luna. The Self-Diagnostic 
software outputs a text file (c:\selfdiag:txt) which will help Luna’s support staff 
correct errors. 10 

Running the Self-Diagnostic Software 
1 Exit the OBR software (by selecting File > Exit) and any other software. 

 

2 Go to the Windows®  Start menu and select Programs > Luna 
Technologies > Self-Diagnostic. 

mailto:support@lunatechnologies.com
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The following window box appears: 

 
 
 
 
 
 
 
 
 
 
 
 

3 Click the blue Start button. 
 

4 Follow instructions as they appear. 
 

5 When the diagnosis is finished, the window will change appearance, as 
shown below: 

 
 
 
 
 
 
 
 
 
 
 

6 You may view the results and then click the red Exit button. 
 

7 As instructed in the above window, send the resulting text file 
(c:\selfdiag:txt) as an attachment to support@lunatechnologies.com. 
Luna’s support staff will examine the file and contact you. 

10 
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Parameter Specification Units 

Electrical 

Input Voltage Range 100-250 VAC 

Input Frequency Range 50-60 Hz 

Operating Power 100 VA 

Optical Output 

Maximum Rated Output Power 2.4 mW 

Internal Laser Module Maximum Rated 
Output Power 

10.0 mW 

Emitted Wavelengths 1260-1340 or 1520-1630 nm 

PC I/O 

 
 
 
 

Input/Output Devices 

•   CD drive 
•   USB ports 
•   RS-232 port 
•   Printer port 
•   Ethernet port 
•   IEEE-488/GPIB (optional) 
•   Keyboard/Mouse 
•   Display 

 

Environmental 

Operating Temperature Range1 10-35 ºC 

Storage Temperature Range 0-40 ºC 

Relative Humidity (non-condensing) < 80 % 

Dimensions and Weight (Including Toughbook® PC) 

 

 

 

Appendix A 
 
 
 

Specifications 
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Parameter Specification Units 

Weight (PC not included) 11.4 
25 

kg 
lbs 

Case Size 366 X 345 X 165 
14.42 X 13.6 X 6.5 

mm 
in 

 
 

1Performance criteria can only be met if the unit is operated within the proper temperature range 
indicated. Maintenance of an acceptable internal operating temperature depends upon proper 
equipment ventilation. To ensure proper ventilation, never obstruct enclosure airflow open- 
ings. 

 

For current performance specifications, check our website at 
www.lunatechnologies.com 

 

 

Minimum PC Requirements 
Pentium 4 or Core 2 Processor 

 

2 GB RAM 

USB 2.0 port 

Windows 2000/XP or Windows 7 (Vista not supported) 

Screen Resolution: 1280 x 1024 

(Laptop resolution setting must be > 1280 x 1024) 
 

Class 1 Laser Product 
The Luna Technologies OBR 4600 is a Class 1 Laser Product, which meets the 
requirements of Class 1 in standards IEC 60825-1: 2001 and 2007, and complies 
with 21CFR1040.10. 

A Maximum rated output power: 2.4 mW 
Internal laser module maximum rated output power: 10.0 mW 

 

Emitted wavelengths: 1260 to 1340 nm or 1520 to 1630 nm 

http://www.lunatechnologies.com/
http://www.lunatechnologies.com/
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Index 
 
 
A 
align optics 31, 34 

remote commands 126–127 
amplitude 68, 173 

remote commands 145 
apply frequency domain window 29 
apply spatial resolution filter 29 
assembling the OBR 7–16 
asterisk 105 
autoscale plot axes 29 
auto-update lower graph 29 

 
 
B 
backscatter 187 
base folder for output files 80 
binary files 62, 65 
Bragg grating 187 
buttons 3 

details 60–61 
graph control 19, 24–27, 70–74 

 
 
C 
calibrate 31, 37, 203–204, 207–208, 210 

checking calibration 38 
reload calibration data 31, 40, 127–128, 171 
remote commands 127–128, 170–171 
storing multiple calibration files 39 

calibration information 
laser 31 

characteristic length 98 
Class 1 laser product 2, 214 
cleaning 

case 198 
connectors 37, 41, 195 
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supplies 195 

*CLS 122, 163 
color palette 30 
compare 84 
compare to reference trace 80 
components list 7–10 
CONFigure:CenterWaveLength 132, 164 
CONFigure:CenterWaveLength? 132, 164 
CONFigure:COEFficients 143, 164 
CONFigure:COEFficients? 144, 164 
CONFigure:ConfFiGuration 114–116 
CONFigure:ConfFiGuration? 113, 115–116 
CONFigure:DeviceUnderTestLength 136 
CONFigure:DeviceUnderTestLength? 136 
CONFigure:DistanceRANge 135 
CONFigure:END? 133, 164 
CONFigure:FrequencydomainWINdow 143, 164 
CONFigure:FrequencydomainWINdow? 143, 164 
CONFigure:GAIN 142, 165 
CONFigure:GAIN? 142, 165 
CONFigure:GaugeLENgth 138, 165 
CONFigure:GaugeLENgth? 138 
CONFigure:GRouP 141, 165 
CONFigure:GRouP? 141, 165 
CONFigure:INTegrationCenter 137, 165 
CONFigure:INTegrationCenter? 138, 165 
CONFigure:INTegrationStart 137, 165 
CONFigure:INTegrationStart? 137, 165 
CONFigure:INTegrationWidth 134, 165 
CONFigure:INTegrationWidth? 135, 165 
CONFigure:RANGe 124, 133, 162, 165 
CONFigure:RANGe? 134, 165 
CONFigure:RATE 124, 140–141, 165 
CONFigure:REFerencetrace 116 
CONFigure:REFerencetrace? 115 
CONFigure:RESolutionGhz? 141, 165 
CONFigure:RESolutionPicometers? 141, 165 
CONFigure:SensingRANge 136, 166 
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CONFigure:SensingRANge? 137 
CONFigure:SensingRESolution 139 
CONFigure:SensorSPAciing 138–139 
CONFigure:SensorSPAcing 166 
CONFigure:SpatialResolutionBandWidth 141, 166 
CONFigure:SpatialResolutionBandWidth? 141, 166 
CONFigure:SpatialresolutionFILter 142, 165 
CONFigure:SpatialresolutionFILter? 142, 165 
CONFigure:SpatialResolutionFilterWidth 142, 166 
CONFigure:SpatialResolutionFilterWidth? 142, 166 
CONFigure:STARt 133, 162, 166 
CONFigure:STARt? 133, 166 
CONFigure:XaxisUNIts 139, 166 
CONFigure:XaxisUNIts? 139–140, 166 
connectors 

attaching to bulkhead 38 
cleaning 195–197 

continuous scan. See scanning, continuous mode 
cursors 19, 24–26, 29, 72–73, 76 

default location 26, 72 
moving 25, 72 
to highlight LPA features 85 

 
 

D 
data 

abnormal 208 
acquiring. See scanning 
capture commands 144, 166 
displaying. See plotting 
files 62–65 
loading from memory 27, 65, 129, 170 
moving data in local memory 59 
no data 144, 208 
noise 195–196, 207 
plotting. See plotting 
retrieval commands 144, 166 
saving 28, 59, 62–65 
scanning. See scanning 
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spreadsheet 64 

data decimation 29 
Data Processing area 21 
decimation 29, 75 

remote commands 146–149, 152 
details 60–61, 150 

remote commands 169 
detectors saturated 204 
differential loss 26, 29, 72–73, 179 
display options 29 
Display Options area 22, 59–60 
disposal 2 
distance range 28 

remote commands 135 
distributed sensing 48–58 

examples 54–58 
options 3, 42 
parameters 48 

drop (LPA feature) 81 
drop detect ratio 103 
drop length 99 
drop tolerance 107 
DUT Length 42 
DUT length 

remote command 136 
 
 

E 
edit menu 28 
Erbium-doped fiber 189 
*ESE 122, 163 
*ESE? 122, 163 
*ESR? 122, 163 
extended range 20, 34, 42 

 
 

F 
Fast Fourier Transform 180 
fast scan mode 
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remote commands 140 

fast scanning 30 
FBG (fiber Bragg grating) 187 
feature extract length 100 
feature highlight graph 85 
feature tolerance detail 85 
FETCh:FEATures 112–113 
FETCh:FREQuency? 144, 157, 167 
FETCh:FrequencydomainDETail? 152, 167 
FETCh:FSIZe? 145, 167, 169 
FETCh:GeneralTOLerances? 113 
FETCh:GraphNAMe? 146, 167 
FETCh:GraphSTRings? 146, 168 
FETCh:INTegrationLoss? 153, 168 
FETCh:LENgthEnd? 154, 168 
FETCh:LENgthStart? 154, 168 
FETCh:MEASurement? 147, 169 
FETCh:MeasurementDETails? 150, 169 
FETCh:NUMberofFeatures? 112 
FETCh:PASSed? 113 
FETCh:RAW? 150, 169 
FETCh:RawdataSIZe? 151, 169 
FETCh:TimedomainINCrement? 153, 169 
FETCh:TIMEnd? 154, 169 
FETCh:TIMeStart? 153, 169 
FETCh:WaveLength? 152, 169 
FETCh:WaveLengthCenter? 152, 169 
FETCh:WaveLengthEnd? 152, 169 
FETCh:XAXIs? 149, 169 
fiber (LPA feature) 81 
file menu 27 
files. See data 
filters 76 

box-car 178 
remote commands 131, 141–142, 171 
spatial resolution 21, 29, 76, 142, 178 

Fourier transform 175, 177, 180 
frequency domain 4, 148 
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remote commands 131, 145–149, 152 

frequency domain window 29, 47 
measurement details 47 
theory 184–187 

fuses 
replacing 198–200 

FUT (fiber under test) 190 
 
 

G 
gain 20, 61 

remote commands 142, 164–165 
gauge length 52, 54, 188, 191 

controls spatial resolution of distributed sensing 53, 192 
GD. See group delay 
general tolerances 

changing 85 
GPIB commands. See remote control commands 
graph areas 18, 23 
graphing. See plotting 
graphType 

remote command parameter 145–146 
group delay 183 

remote commands 145 
group index 61–62, 75 

changing for one trace or all 61–62, 75 
equation 75 
remote commands 141, 150, 165 

 
 

H 
Hanning window 47 
hardware wizard 13 
high resolution data (LPA) 92 

 
 

I 
icons 

desktop 16, 78 
*IDN? 122, 163 
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image file 27, 74 
impulse response 180, 182 
insertion loss 4 

sign convention 85 
instrument configuration 28, 34 
integrated loss 26, 72–73, 179 
integration area 

remote commands 137, 151, 153, 165–166, 168, 172 
integration length 104 
integration width 18, 21, 38, 52, 68, 73, 178 

and differential loss 178 
and return loss 178 
remote commands 134, 137, 139–140, 148, 150, 165 

interferometry 1, 173–177 
 
 

J 
jpg files 27, 74 

 
 

L 
laser 

Class 1 ratings 214 
laser calibration 31 

specifying a calibration file 31 
Laser On LED 33 
LED 

indicators on front panel 33 
legends 26, 72, 74, 76 
LightPath Analysis Software 77 
linear amplitude 68 

remote commands 145 
time domain 181 

load data file 27 
LPA command 81, 91, 93 
remote commands 129 

load reference file 28 
location tolerance 110 
logging enabled 29 
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logging options 30 
loss 

differential 26, 72–73, 179 
integrated 26, 72–73, 179 
return 4, 26, 29, 183 
sign convention 85 

loss tolerance 108 
lower graph 

two plots 66 
updating 67–68 

 
 

M 
Mach-Zehnder interferometer 173 
magnitude difference 182 
main window 18 maximum 
length 111 maximum length 
(LPA) 95–96 menu items 27–
31 
Michelson interferometer 173 

 
 

N 
normal range 20, 34, 42 

acquiring data 42 
 
 

O 
*OPC 122, 163 
*OPC? 123, 163 
optical frequency 182, 184 
optical network 174–176 
optical time domain reflectometry 4, 173 
options menu 28 
output file location 80 

 
 

P 
parameter configuration file 80, 82–84 

adjusting 79 
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parameter specifications 83 
parameters 2, 18, 23, 41 

changing in LPA software 82 
menu 23 
plotting 23, 68–69 
plotting two at a time 66–67 
remote commands 123–124, 155–156, 164 
spreadsheet 64 

peak (LPA feature) 81 
peak dead zone 102 
peak detect ratio 101 
peak tolerance 106 
phase 173 
phase derivative 182 

remote commands 145 
plotting 19 

autoscaling 29, 69 
changing colors 74 
colors 60 
manual scaling 70 
X-axis 24, 70, 90 
Y-axis 24, 70 
zooming 70–71 

polarization 2, 181 
polarization maintaining (PM) fiber 189 
polarization states 68 

remote commands 145 
time domain 181 

printing 11–12, 28, 76 
 
 

Q 
*QUIT 121, 164 

 
 

R 
Rayleigh backscatter 187 
Rayleigh scatter 105 
recalculate 50, 52, 68 
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reduce gain 204 
reference 

acquire 16 reference 
trace 80, 82 reload 
calibration data 31 

remote commands 128 
remote control commands 119–172 

alphabetical listing 163–172 
case sensitive 162 
delay required 163 
GPIB 119–172 
quotes in 161 
semicolons in 163 
setup 120 
spaces in 161 
TCP/IP 119–172 
see also individual commands 

remote interface setup 30, 119–120 
resolution 5, 28, 34–35, 177 

spatial. See spatial resolution 
resolution bandwidth 28, 177 
return loss 4, 26, 29, 39, 73, 178 

asterisk (*) 105 
measured 105 
remote commands 145 

*RST 123, 164 
 
 

S 
save software options 28, 40 
saved data location 80 
saving data 27, 62–65 

remote commands 130–131, 171 
saving graph 27, 74 
scalar response 173 
scale 182 
SCAN 20 

remote commands 124, 170 
Scan 40 
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scan range 42 

remote commands 132, 134, 165 
scanning 

button 20, 80 
continuous mode 20, 43–46, 119 
failed 207 
indicator light 33 
modes 4 
new scans to Matrix A 59 
range 20 
remote commands 124 
single 41–43 
stopping 43, 46 

select calibration file 31 
select file options 28 
self-diagnostic software 211–212 
semicolons in commands 121, 163 
sensing 30 
sensing area 

remote commands 130, 137, 151, 153, 165–166, 168, 172 
sensing enabled 21 
sensing range 52, 73, 178, 192 

and differential loss 179 
and return loss 179 
controls width of integration area 68 
must begin at zero strain difference 49 
remote commands 134–137, 139–140, 148, 150–151, 165 

sensor spacing 191 
controls spatial resolution of distributed sensing 192 

set logging options 30 
setup menu commands 

data processing parameters 82–86 
file configuration 79–80, 97 

shift reference 22, 48, 188 
shipping the instrument 200–201 
Show 29, 52 
show integration area 29, 68 
show sensing area 29, 52, 68 
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software 

installation 12 
software recovery 10 
spaces in commands 161 
spatial resolution 4, 28, 187–188 

filter 21, 29, 76, 142, 178 
maximum 36 
of distributed sensing data 53, 192 
remote commands 130–131, 141, 165, 171 

spatial resolution filter 142, 165 
specifications 214 
specify calibration file 31 
spectral shift 3, 30, 48–49, 57, 188–189 
spectral shift quality 48, 57, 190–191 
splice loss tolerance 109 
spot scan 29, 44 

cursor 74 
must begin at zero strain difference 49 
remote commands 124 

spreadsheet files 62, 65–66 
remote commands 131, 171 

*SRE 123, 164 
*SRE? 123, 164 
*STB? 123, 164 
step size 5 
strain 48, 189 

coefficients 49 
strain coefficients 42 
swept-wavelength interferometry 173, 187 
SWI (swept-wavelength interferometry) 187 
System Control area 20, 42 
SYSTem:ACQuired? 131, 170 
SYSTem:ALIGn 126, 170 
SYSTem:ALIGn? 127, 170 
SYSTem:CALibration 127, 170 
SYSTem:CALibration? 127–129, 170 
SYSTem:CALibrationFile 128, 170 
SYSTem:CALibrationFile? 129, 170 
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SYSTem:COPY 131, 170 
SYSTem:ERRor? 126, 170 
SYSTem:ERRorDescription? 126, 170 
SYSTem:GET? 131, 170 
SYSTem:LASEr 125, 170 
SYSTem:LASEr? 126, 170 
SYSTem:LAST? 132 
SYSTem:LOAD 129, 170 
SYSTem:ON? 125, 170 
SYSTem:ReaDY? 126, 170 
SYSTem:ReLoaDCalibration 128, 171 
SYSTem:SAVE 130, 171 
SYSTem:SaVeLightPathtrace 116–117 
SYSTem:SaveSEGment 130, 172 
SYSTem:SAVText 130, 171 
SYSTem:SPOTscan 124, 128–129, 171 
SYSTem:VERsion? 125, 172 
SYSTem:WARM? 125, 172 
SYSTem:WarmupTIMeremaining? 125, 172 

 
 

T 
TCP/IP commands. See remote control commands 
temperature and strain coefficients 30, 42, 49, 51 
temperature change 48, 189 

coefficients 49 
temporal shift 48, 58, 192 
time domain 4 

definition 176 
remote commands 131 

tools menu 30 
trace 67 
trace comparison 84–85 
trace event listing 85 
traces 59 

displaying multiple traces 60 
moving data in local memory 59 
only two available 34, 59 
remote commands 129–130, 144–145, 147, 149–154, 167, 171 
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troubleshooting 203 
*TST? 124, 164 
tutorial for LightPath analysis 77–96 
two plots 66–67 

 
 

U 
units 

frequency 144 
remote commands 149, 167, 169 
resolution bandwidth 28 
spreadsheet file 66 
time domain 177 
X-axis 24 
Y-axis 24 

upper graph 23 
USB 33 

LED indicator on front panel 33 
 
 

W 
*WAI 123, 164 
wavelength 41, 178 

center 20, 37–38, 41, 132–133, 164 
ending 133, 164 
range 20, 37–38, 42, 133 
remote commands 124, 133 
starting 166 

 
 

X 
X-axis 

remote commands 139–140, 149, 169 
scaling 24, 70 
units 24 
zooming 71 

 
 

Y 
Y-axis 
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scaling 24, 70, 90 
units 24 
zooming 71 

 
 

Z 
zooming 25, 70–72 
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